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SUSE® Linux Enterprise Desktop provides the tools that Linux* users require in their
daily activities. It comes with an easy-to-use graphical environment, the KDE* desktop,
that communicates with the underlying Linux system to access and manage files, folders,
and programs. SUSE Linux Enterprise Desktop provides an integrated suite of applica-
tions that meet all professional requirements to perform tasks in a business environment.
The LibreOffice suite is also included, which allows you to edit and save files in a
number of formats. Because the office suite is available for several operating systems,
you can use the same data across different computing platforms.

1 Getting Started

When you start your system, you are usually prompted to enter your username and
password. If you did not install the system yourself, check with the system administrator
for your username and password.

After logging in to KDE for the first time, you see the KDE desktop, which shows the
following basic elements:

WOIT—— E

Desktop Folder: By default, the desktop folder shows the contents of'its ~/Desktop
directory. Whenever you insert a file into this directory, it appears in this view too.
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Desktop Context Menu: Right-click an empty area on the desktop to access the
context menu for configuring the appearance of the desktop, adding panels or widgets
to the desktop, configuring desktop settings, locking the widgets in their current position,
leaving the current session, or for locking the screen.

Desktop Toolbox: Move your mouse pointer to the icon in the upper right corner of
the desktop to access the menu that lets you add or lock widgets.

KDE Panel: By default, the panel of your KDE desktop consists of the Main Menu
icon on the left, further widgets and program icons, and the panel settings icon on the
right. If you hover the mouse pointer over an icon in the panel, a short description is
displayed.

Main Menu Click on the left side of the bottom panel to open the main menu. The
Main Menu consists of the following elements: a search function at the top and several
tabs at the bottom, providing quick access to the key functions of the menu. Addition-
ally, the menu displays your login name and the hostname of your computer.

2 Starting Programs

Start programs from the Main Menu or from the command line, using a shell or the Run
Command. Additionally, you can start programs from the desktop or the panel by left-
clicking the program icon once.

2.1 Using the Main Menu

To open the Main Menu, click the Main Menu icon in the panel or press Alt + F1.

Favorites shows a default selection of key programs for quick access, whereas Applica-
tions shows all applications installed on your system. To navigate through the menu
structure, click an entry and use the arrow icons at the right or the left to switch back
and forth. Computer and Recently Used provide quick access to some frequently used
places, applications, or documents. Leave shows several options for leaving the session
such as logging out, locking the screen (access can only be regained with a password),
shutting down or restarting the computer. Some computers offer to suspend your session
to RAM or disc.
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If you often need a program and do not want to dig into the menu structure, you can
integrate the icon into the Favorites tab. Right-click the icon on any of the other tabs
and choose Add to Favorites.

2.2 Using the Run Command Dialog

KRunner is a helper application that lets you quickly start programs. Apart from that,
it offers a search function for finding applications or locations.

Press Alt + F2 to open the Run Command dialog. Type a command, for example,
dolphin. While you are typing, the dialog shows a list of applications or actions that
match your input. Select one of the results or press Enter to start the highlighted appli-
cation or action. The command to start the application is often (but not always) the ap-
plication name written in lowercase.
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The Run Command dialog allows you also to use different features. Click on the question
mark icon to see a list of active features. To configure or get a list of all features, click
on the wrench icon. You can use so-called Web shortcuts defined in Konqueror to send
search requests directly to a search engine without first opening the browser. Another
interesting feature is to calculate a mathematical expression like =2+274-sin (2).
Very useful is to convert units, for example, from miles per hour into kilometres per
hour. Just insert the expression 60 mph in km/h to get the converted value.

2.3 Searching for Programs

Both the Main Menu and the Run Command dialog offer a search function that lets you
quickly start programs even if you do not already know the exact application name or
command. To search for an application, start typing a command or part of the application
name in the Main Menu Search field or the input field in the Run Command dialog.
Each character you enter narrows down the search.

From the list below the input field, choose the application matching your query.
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3 Handling Media

If you insert a CD or DVD into your drive or plug in a pluggable device (for example,
a USB stick or removable hard disk), the device notifier widget opens a small window
alerting you to this. It also proposes possible actions, depending on the type of the device.

r b
= Devices recently plugged in:

Cptical Disc

CDROM
@i 4 actions for this device =

For example, if you plugged in a digital camera, the actions allow you to download
your photos with Gwenview or digiKam. Click the device entry in the widget to access
the available actions. To safely remove the device from your computer, use the icon
on the right side of the device entry.

4 Customizing Your Desktop

You can change the way your KDE desktop looks and behaves to suit your personal
preferences.

4.1 Locking and Unlocking Desktop Objects

Desktop elements can be locked in their current position to prevent them from being
moved around on the desktop. As long as the desktop elements are locked you cannot
add, move, or remove any objects to or from your desktop.
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To lock or unlock the desktop elements, click the cashew icon (desktop toolbox) at the
upper right corner of the desktop and select Lock Widgets or Unlock Widgets.

Alternatively, right-click an empty patch on the desktop and select Lock Widgets or
Unlock Widgets.

4.2 Changing Individual Desktop Elements

In the following, you can find some examples of how to change individual desktops
elements.

Procedure 1 Adding Program Icons to the Desktop

To create a link to an application and place it on the desktop or the panel, proceed as
follows:

1 Click the Main Menu button and browse to the desired application.

2 Right-click and select Add to Desktop from the context menu that appears. If this
menu item is not available, your desktop elements are probably locked. Unlock them
first as described in Section 4.1, “Locking and Unlocking Desktop Objects”

(page 6).

3 To change the icon position on the desktop, left-click the icon and drag it to the de-
sired position.

To delete an icon from your desktop, right-click the program icon and select Remove
this Icon.

Procedure 2 Adding Widgets to the Desktop or to the Panel

1 To add widgets to you desktop, right-click an empty patch on your desktop and select
Add Widgets.

To add a widget to the panel, right-click an empty patch on the panel, and select
Panel Options > Add Widgets.

If these menu items are not available, your desktop elements are probably locked.
In this case, right-click and select Unlock Widgets first.
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2 In the list that appears, select a widget. Use the scrollbar to browse through the
available widgets. To limit the selection of widgets, either enter a search term in the
input field or choose a Category.

3 To make the selected widget appear on the desktop or in the panel, double-click it
and close the dialog box.

4 To remove a widget from your desktop or panel, right-click the widget and select
the Remove... entry.

Procedure 3 Configuring Desktop Widgets

1 Hover your mouse pointer over the widget until a translucent frame appears around
the widget, showing a number of symbols:

If the frame does not appear, your widgets are probably locked. Unlock them first
as described in Section 4.1, “Locking and Unlocking Desktop Objects” (page 6).

2 To change the widget size, left-click the scale symbol in the frame and keep the
mouse button pressed while slowly moving your cursor across the desktop.

3 To rotate the widget in any direction, left-click the arrow symbol in the frame and
keep the mouse button pressed while moving your cursor in a circle across the
desktop. There is a sticky boundary in the horizontal and vertical positions where
you can “clamp” the widget, if you like. Of course, you can also arrange it in any
tilted position.
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4 To change the contents, settings, or properties of a widget, left-click the wrench
symbol in the frame. In the configuration dialog box that appears, set the options
according to your wishes.

Procedure 4 Adding and Removing Panels

1 If you want multiple panels on the desktop, right-click an empty area on the desktop,
select Add Panel and choose a panel type from the list.

If these menu items are not available, your desktop objects are probably locked. In
this case, right-click and select Unlock Widgets first.

2 Click the cashew icon at the end of the new panel to access the configuration options
and customize the panel as described in Procedure 5, “Configuring Panels” (page 9).

3 To delete a panel, right-click a blank space in the panel you want to delete and select
Panel Options > Remove this Panel. SUSE Linux Enterprise Desktop requires that
at least one panel is left on the desktop.

Procedure 5 Configuring Panels

You can customize all KDE panels according to your preferences. Applications and
widgets can be added to the quick launch area or the system tray in the main panel or
to additional panels. Panel elements and additional panels can be moved to different
places or be completely removed at any time.

1 To access any options for the current panel, right-click an empty patch in the
panel (or click the cashew icon at the end of the panel) and select Panel Options
> Panel Settings. The panel changes view and shows its configurations options.

If the menu item and the icon are not available, your desktop objects are probably
locked. To unlock, right-click and select Unlock Widgets first.

2 To move panel objects to a different place within the panel, hover the mouse
cursor over the respective panel object (for example, program icon, pager, task
manager, system tray). The mouse cursor turns into a crosslines-like form. Click
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the object and move the cursor to the desired position in the panel. Click again
to fix it at this place.

3 To enlarge the distance between two widgets, use Add Spacer.... A spacer widget
appears on the right side. Drag and drop it to the preferred place.

4 To change the panel width, click and drag the small arrow icons at the left and
right end of the settings panel. Use the arrow on the left side to set the panel's
position and the arrows at the right side to set the maximum and minimum size.

5 To change the panel height, click the Height button and move the mouse cursor
to the desired end location.

6 To place the panel at different sides of the screen use the Screen Edge button.
Drag and drop the panel to the preferred location.

7 Ifyou need additional widgets on your panel, add them with the Add Widgets...
button as described in Procedure 2, “Adding Widgets to the Desktop or to the
Panel” (page 7).

8 To remove program icons or widgets from the panel, right-click the unwanted
object and select the menu item to remove the icon or widget.

The icons in the system tray usually belong to applications running in the back-
ground. Therefore you can only remove those icons if you close those applications
(right-click the icon and select Quit).

9 To prevent the panel and widgets from being moved accidentally, use Lock Wid-
gets.

10 For additional configurations options like alignment and functions (like auto hide),
click More Settings....

11 If all panel changes are according to your wishes, close the panel settings with
the red close button on the right side.

Procedure 6 Changing the Desktop Background

You can change the desktop background to display images, a slideshow, patterns or
colors. It is even possible to use a map of the globe or the weather report as desktop
background.
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1 Right-click an empty patch of the desktop and select Desktop Settings. A configuration
dialog appears.

2 In the View section, choose a type from the Wallpaper drop-down list. The further
configuration options depend on the choice of the object to use as background.

3 For example, to use an image wallpaper:

3a Set Wallpaper to Image.
3b Define the Positioning of the image.

3¢ To use one of the available wallpapers, either choose a wallpaper from the
list or click Get New Wallpapers to download additional wallpapers.

3d To use a custom picture, click Open and select an image file from the file
system.

Get New Wallpapers.

o OK & Apply @ cancel

4 Set the other options in the configuration dialog according to your wishes, and click
OK to save your changes and leave the configuration dialog.

KDE Quick Start
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4.3 Modifying Personal Settings

Apart from changing individual desktop elements, KDE allows you to personalize your
desktop to a very high degree. Possibilities to adjust the overall appearance and behavior
of your desktop can be found in the Personal Settings configuration dialog.

Start the Personal Settings from the Main Menu by selecting Favorites > Configure
Desktop.

The settings are grouped into different categories. Hover over an icon to see more details.
Performing tasks in some areas of the personal settings requires system administrator
(root) permissions.
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Change the settings as desired. No changes take effect until you click Apply. To discard
changes in the recent view that you have not yet applied, click Reset. To reset all items
in the recent view to the default values, click Defaults.

To get back to the start-up view (showing all categories) again, click Overview at the
top left corner of the dialog. You can also enter a search string at the top of the window
(for example, Screen Saver) to find the category which holds options related to the
search string. Each character you enter in the Search field further narrows the search.
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For easier overview of all categories, you can also switch to a tree view by clicking
Configure and selecting another View Style.

5 Applying Desktop Effects

If your computer supports a 3D graphics card with Xgl, you can use graphical effects
like turning your desktop into a rotating 3D cube, enabling translucent or transparent
windows, and zooming in and out of the desktop screen. You can also use other window
effects such as shadows, fading, and transformations. If you do not have a 3D graphics
card, some effects may be disabled or reduce the performance of your system. If the
performance of your system is too low, disable the effects for your current session with
Alt + Shift + F12.

To configure effects on your desktop, proceed as follows:

1 Start the System Settings as described in Section 4.3, “Modifying Personal Settings™
(page 12).

2 Select Desktop Effects from the Workspace Appearance and Behavior category and
choose Enable Desktop Effects. If your graphic card does not support 3D, you will
be notified.

3 Optionally, change some options below Common Settings.

4 On the All Effects tab, select the effects you want to activate. Click the information
icon for a short explanation of the respective effect. If an effect is activated, the
wrench icon on the right gives access to further configuration options like assigning
keyboard shortcuts to the effect.

5 Use Apply to enable the effects permanently.

6 Using Virtual Desktops

The desktop environment allows you to organize your programs and tasks on several

virtual desktops. If you often run a lot of programs simultaneously, this minimizes the
number of windows to arrange on your screen. You might, for example, use one desktop
for e-mailing and calendaring and another for word processing and graphics applications.

KDE Quick Start
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Procedure 7 Moving an Application to Another Virtual Desktop

You can display a running application on one or all virtual desktops, or move it to other
desktops.

1 Open the application.

2 Right-click the title bar of the application.

3 Click To Desktop.

4 Select the desktop on which to place the application.

5 To switch to a certain desktop, click the desired desktop in the pager in the panel.
Switch to the next or previous desktop by placing the mouse cursor on an empty
patch on the desktop and move the mouse wheel.

Procedure 8 Configuring Virtual Desktops
You can increase the number of virtual desktops, change the default names, assign ac-
tivities, configure effect animations or assign keyboard shortcuts for switching virtual

desktops.

1 To add additional desktops, right-click the pager in the panel and select Add Virtual
Desktop. A new desktop is shown in the pager.

2 For any configuration options, right-click the pager and select Pager Settings.
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You can configure how many virtual desktops there are.

Number of desktops: 40

Deskiop Names

Desktop 1:  Work Desktop 11:
Desktop 2:  Mail Desktop 12:
Desktop 3:  Music Desktop 13:
Desktop 4: Desktop 4 Desktop 14:
Deskiop 5: Desktop 15:
Desktop 6: Desktop 16:
Desktop 7: Deskiop 17:
Desktop 8: Desktop 18:
Desktop 9: Desktop 19:
Desktop 10: Desktop 20:
B Help &) Defaults W OK & Apply @ cancel

3 Use the options on the General screen to configure the appearance of the pager in
the panel.

4 Desktop names, keyboard shortcuts for switching desktops and the switching type
can be configured on the Virtual Desktops screen.

5 Set the options according to your wishes and click OK to apply the changes and to
close the configuration dialog.

7 Managing Files and Folders

With KDE 4, Dolphin has replaced Konqueror as the default file manager. Konqueror
remains a Web browser (refer to Section 8, “Browsing the Internet” (page 20)). Start
Dolphin, from the Main Menu by selecting Favorites > File Manager or press Alt + F2
and enter dolphin.
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7.1 Dolphin Main Window

The Dolphin main window consists of the following elements:
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Menu Bar: The menu bar holds menu items for actions like copying, moving, or
deleting files, changing views, starting additional tools, defining your settings, and
getting help.

Toolbar: The toolbar provides quick access to frequently used functions that can also
be accessed via the menu. If you hover the mouse pointer over an icon, a short descrip-
tion is displayed.

Location Bar: The location bar displays the path to the current directory. It is available
in two versions: one shows the path to the current directory with icons for every parent
folder in a “bread crumb” view. Click any icon in the bread crumb view to change to
that directory. The second version of the location bar shows the path to the current di-
rectory as a string of text you can edit.

Panels: By default, Dolphin shows the Places panel. It allows quick access to some
often-used places like your home directory, the root directory of the file system (/),
the trash bin, and removable media. There are several other panels you can add to the
main window by clicking View > Panels.
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Display Field (Working Space): The display field shows the contents of the selected
directory or file. By default, Dolphin displays the contents of your home directory on
start-up. By default, clicking a folder or file in Dolphin directly starts an action: Dolphin
loads the file into an application for further processing or opens the folder.

Status Bar: Shows the file type and size of the currently selected object and allows
you to enlarge or diminish the size of the icons or entries shown in the display field.

7.2 Managing Files and Folders with Dolphin

To perform actions like copying, moving, creating or deleting files, you need appropriate
permissions to the folders and files involved in your action.

To copy, move, or delete a file or folder, proceed as follows:

1 In order to select one or multiple files and folders in Dolphin, move your mouse
pointer over the file or folder but do not click. A green cross appears on the upper-
left edge. If you click it, the object is selected. To deselect again, click the red minus
icon that appears if the object is currently selected.

Alternatively, press Ctrl and click the objects you want to select or deselect.

2 Right-click and select Copy or Cut from the context menu.
3 Navigate to the destination folder in which to insert the object.

4 To create a new folder at the current location, select File > Create New > Folder or
press F10. Enter a folder name in the new window and press Enter.

5 To insert the object you copied or cut in Step 2 (page 17), right-click the destination
folder in the main display field and select Paste. The object is copied or moved there.

6 To delete a file or folder, right-click the object in the main display field and select
Move to Trash from the context menu. The object is moved to the trash bin. From
there, you can restore it if necessary or delete the object permanently.

To quickly filter for certain filenames in the current directory, press Ctrl + | to add the
Filter input field to the bottom of the Dolphin main window. Type any part of the file-
name you are searching for to see all files in the current directory containing the search

KDE Quick Start
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string. For more detailed and advanced searches, press Ctrl + F to use the desktop search.
For more information, refer to Section 14.2, “Using Strigi Desktop Search” (page 32).

7.3 Configuring Dolphin

Dolphin offers many options for adjusting the view and the overall settings according
to your preferences.

Procedure 9 Changing the View

1 To switch from the bread crumb view to the editable version of the location bar,
press F6. Enter a path to a directory by typing it in. After typing an address, press
Enter or click on the background of the bread crumb view.

To delete the contents of the location bar click the black X symbol on the left. To
switch back to bread crumb view, press Ctrl + L.

H E L [
Icons Details  Columns Freview Split

= [':‘ ihomeinilbel| « V] '

2 To change the view of the currently displayed folder, either click Icons, Details, or
Columns in the toolbar. Dolphin remembers the selected view for each folder. Click
Split or press F3 to view the contents of the current folder in two separate columns.
Now you can navigate to a different directory in each column and easily drag or drop
objects or compare the contents of directories. Press F3 again to leave the split view.
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3 To make Dolphin also show hidden files, select View > Show Hidden Files.

4 To view more details about the files (like access permissions or ownership) in the
working space, select View > Additional Information and enable the corresponding
options.

5 To add further directories to the Places panel, drag a folder from the working space
to the Places panel and drop it there. Right-click and use the context menu to hide,
edit or remove entries from Places.

6 To add more panels to the main window, select View > Panels and select additional
panels such as Folders, or Terminal.

Detach the panels from the main Dolphin window by clicking the left icon at the top
of each panel. Click the panel's title bar and drag it to another place on the desktop. To
reintegrate the panel into the Dolphin window, click the left symbol at the top of the
panel again.

Procedure 10 Changing Dolphin's Overall Behavior

If you want to change Dolphin's overall behavior or view, select Settings > Configure
Dolphin and explore the options offered in the Dolphin configuration dialog.

1 To use the same view mode for all folders, click General in the left sidebar and acti-
vate Use Common View Properties for All Folders. Click View Modes in the left
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sidebar and adjust the options for the individual view modes. Click Apply to save
the changes.

2 If you want Dolphin to show a different directory on start-up, or if you want to per-
manently use the editable location bar instead of the bread crumb view, click Startup
in the left sidebar and change the relevant options.

3 To configure which entries and services to show in the Dolphin context menu, click
General. On the Context Menu tab, activate the entries to show. Click Services in
the left sidebar and activate or deactivate the respective services to appear in the
context menu.

4 Click OK to save the changes and to close the Dolphin configuration dialog.

8 Browsing the Internet

Apart from Konqueror (KDE's default Web browser), SUSE Linux Enterprise Desktop
also includes the default Firefox Web browser. To start Konqueror or Firefox, press
Alt + F2 and enter konqueror or firefox.

With features like tabbed browsing, pop-up window blocking, and download and image
management, both browsers combine the latest Web technologies. Their easy access
to different search engines helps you find the information you need.
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Enter a URL in the location bar to start browsing. To open a new, empty tab, press Ctrl
+ T. To open a link in a new tab, click the link with your middle mouse button. Right-
click the tab itself to access more tab options. You can create a new tab, reload one or
all existing tabs, or close them. You can also change the sequence of the tabs by dragging

and dropping them to the desired position.

8.1 Finding Information

Both browsers offer different kinds of search options: you can find information on the

Web or you can search the current Web page for keywords.
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Procedure 11 Searching the Web

1 To start a search on the Web, click the left icon in the search bar (located next to the
location bar) to open a list of search engines.

2 Select the desired engine and type your search keywords into the input field.
3 Press Enter to start the search.

4 To search the current Web page with Firefox or Konqueror, press Ctrl + F to open a
find bar at the bottom of the window. Enter your search keyword there and use the
buttons beneath the bar to search in different directions or to configure search options
such as Match Case.

Konqueror offers predefined Web shortcuts for quickly searching the Web. For example,

to search the Web for yast using the Google search engine, just type gg: yast into
the Konqueror location bar (or the Run Command dialog) and press Enter.

You can also define individual Web shortcuts in Konqueror and Firefox as described
in Section 8.3, “Configuring Preferences” (page 22).

8.2 Downloading Files from the Web

If you download a file with Firefox or Konqueror, a dialog window appears asking you
if you want to save the file or to open it with a specific application. Also choose if to
remember the action you selected for this type of file. By default, Firefox saves the file
to the folder configured in the Firefox Preferences and shows your finished downloads
in the Downloads dialog.

To open the downloaded files directly from there, right-click and select Open. To clean
up the history of downloaded files, click Clear List.

8.3 Configuring Preferences

Adjust preferences in Konqueror or Firefox. In Konqueror, access the configuration
dialog with Settings > Configure Konqueror. To change the behavior of Konqueror as
Web browser, select one of the Web Browsing sub categories in the left sidebar to show
the options for the relevant category. For example, you can “hide” Konqueror's real
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identity and make Konqueror identify as a different browser (for example, Internet
Explorer*) for certain Web sites you visit. To do so, select Browser Identification, and
click New to add a new, site-specific identification.
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You might also want to configure the Web shortcuts you can use with Konqueror (and
the Run Command dialog). In the Konqueror configuration dialog, click Web Shortcuts
to see which shortcuts are already defined. Click New to define new shortcuts. Leave
the Konqueror configuration dialog with OK to apply your changes.

In Firefox, select Edit > Preferences to open the Firefox Preferences. Click the icons
in the upper display field to access the options for the relevant category. For example,
change the default download folder on the General page, or adjust the pop-up blocking
feature on the Content page. Click OK to apply the changes.

To configure a Web shortcut for a search in Firefox, browse to the Web page with the
desired search field. Right-click the search field and choose Add a Keyword for this
Search.... Enter a Keyword and leave the dialog with OK.
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9 Managing Passwords

When you enter a password in a KDE application for the first time (in KMail or Kon-
queror, for example), you are asked if you want to store the password. If you click Yes,
KWallet wizard starts by default. KWallet is a password management tool that can

collect all passwords and store them in one or more encrypted files (called wallets).
P 00 O
KWallet - The KDE Wallet System

Welcome to KWallet, the KDE Wallet System. KWallet allows you to
store your passwords and other personal information on disk in an
encrypted file, preventing cthers from viewing the information. This wizard
will tell you about KWallet and help you configure it for the first time.

@ Basic setup (recommended)

Advanced setup

Next = Cancel

To activate KWallet, select Basic Setup and click Next. Select Yes, I wish to use the
KDE wallet to store my personal information and enter a password. This is your master
password for the default wallet (named kdewallet) that is created during the next
step.

WARNING: Protect Your KWallet Password

If you forget your master password for any wallet, it cannot be recovered.
Furthermore, anyone who knows your master password can obtain all informa-
tion contained in the respective wallet.

Click Finish to close the wizard. If you started the KWallet wizard initially from another
application like Konqueror or KMail, KWallet will prompt you to enter the password

once again in order to store the password for this application in the newly created wallet.
After initial configuration you can open your wallet at any time to view, search, delete,
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or create entries. Normally you do not need to insert an entry manually. KDE recognizes
if a resource requires authentication and KWallet starts automatically, prompting you

for the KWallet password. However, you can add additional data if you wish. To con-
figure any KWallet options, press Alt + F2 and enter kwalletmanager. In the KDE
Wallet Manager that opens select Settings > Configure Wallet.

Whereas KWallet is designed to centrally manage passwords for several KDE applica-
tions, Firefox also offers the ability to store data when you enter a username and a
password on a Web site. If you accept by clicking Remember, the password will be
stored on your hard disk in an encrypted format. The next time you access this site,
Firefox will automatically populate the login fields.

To review or manage your passwords in Firefox, click Edit > Preferences > Security
> Saved Passwords....

10 E-Mailing and Calendaring

For reading and managing your mails and appointments, you can use Kontact as your
personal information management tool (PIM). Kontact combines KDE applications
like KMail, KOrganizer, and KAddressBook into a single interface. This gives you
easy access to your e-mails, calendar, address book, and other PIM functionality.
Kontact can also manage multiple e-mail accounts.

10.1 Starting Kontact for the First Time

To start Kontact, press Alt + F2 and enter kontact. To access one of its components
like KMail, click the corresponding icon in the left sidebar.
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Before you can send or receive mails, you must configure an e-mail identity and account:
1 From the menu, select Settings > Configure Kontact....

2 In the left side pane under Mail, click Identities and select the identity that KMail
has automatically created for you. Modify it by entering your full name and e-mail
address and confirming your changes.

3 Click Accounts in the left side pane under Mail and Add at least one account on the
tabs for Receiving and Sending mails. (Optionally, you can configure multiple mail
accounts).

Usually, the following information is required for both incoming and outgoing mail:
Account Type, Server Name and Port. Depending on the account, you may also need
to set encryption or authentication options. If you are not sure about the settings or
items to select, consult your Internet Service Provider or system administrator.

4 Confirm the setup and leave the configuration dialog with OK.

To write a new mail, click the Mail icon in the Kontact main window and press Ctrl +
N to open the mail composer. After you have finished your mail, click Send to send it
immediately. In case you have configured multiple e-mail accounts, keep the Send
button pressed, then select the account from which you want to send the mail.
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11 Instant Messaging with Kopete

Kopete is an online messenger application that allows multiple partners connected to
the Internet to chat with each other. Kopete currently supports a number of common
messenger protocols, such as AOL* Instant Messenger (AIM), Gadu-Gadu, GroupWise®
Messenger, ICQ, Jabber*, SMS, and Yahoo!*. To be able to use instant messaging
(IM), you must register with a provider offering IM services and configure a Kopete
account.

To start Kopete, press Alt + F2 and enter kopete. If started for the first time, click the
wrench icon at the bottom of the Kopete window to create an account. Kopete guides
you through the setup steps like selecting the messaging service, and entering the re-
spective account information like user name or ID, server name and port and any au-
thentication details like passwords. If you have not registered with the provider for the
selected messaging service yet, click Register New Account. In the browser window
that opens, enter your user data to register. Switch back to Kopete and enter the data
received on registration. Complete the configuration of your account by clicking Finish.

If you decided to go online after configuring your account, you can now add contacts

in the main Kopete window. If the Kopete window shows off1ine , first click File
> Set Status > Online and enter your password if you are prompted for it. After connect-
ing, click File > Add Contact and select the Kopete account for which you want to add
contacts. Enter the contact data or search for a contact and click OK.

To view all your contacts, even if they are offline at the moment, select Settings > Show
Offline Users.

To start a chat with someone, click the desired contact and type your message in the
lower part of the chat window. Press Enter to send the message. The upper part of the
window displays the messages you have sent and received.
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12 Starting LibreOffice

The office suite LibreOffice offers a complete set of office tools, including word pro-

cessor, spreadsheet, presentation, vector drawing, and database components. Because
LibreOffice is available for a number of operating systems, you can use the same data
across different computing platforms.

To start LibreOffice press Alt + F2 and enter 1ibreof fice. To create a new document,
select File > New and choose the type of document to create. To open an existing doc-

ument, select Open and choose the appropriate file from the file system.

Find more information in the LibreOlffice.org Quick Start.

13 Viewing PDF Files and Other
Documents

Documents that need to be shared or printed across multiple platforms can be saved as
PDF (Portable Document Format) files, for example, in the LibreOffice suite. View
them with Okular, the default KDE document viewer.
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13.1 Using Okular Document Viewer

Apart from PDF files, Okular allows you to view a great number of file formats, such
as PostScript, several image formats, OpenDocument format (ODF), OpenDocument
text (ODT), some eBook formats (ePub), and even Microsoft* Compiled HTML Help
(CHM). Okular also provides support for bookmarks, annotations, form fields and
multimedia content, and the rotation of pages.

Start Okular from the Main Menu or press Alt + F2 and enter okular.

To open a document, select File > Open and choose the desired file from the file system.
Navigate through the document by using the navigation icons at the top or bottom of
the window. Depending on which icon you click on the navigation panel on the left,
the sidebar either shows a table of Contents, a Thumbnail view of each page, the Reviews,
or your Bookmarks for this file. To filter for any text listed in the sidebar or the overall
document, enter a string into the input field at the top of the sidebar. If you want to select
and copy text or images from the file in Okular, click the Selection icon in the toolbar
and select one of the options from the context menu. Click the Browse icon to switch
back to browsing the document.

Procedure 12 Working with Bookmarks and Annotations

With Okular, you can review a document by highlighting certain text parts or adding
annotations or bookmarks that Okular then attaches to the file in the form of metadata.
Note that the annotations and markers you add are not stored within the document, so
you cannot print them or pass them on to other users.

1 To add a bookmark for a page, click the page in the sidebar or in the main display
field and press Ctrl + B. The page is added to the Bookmarks list on the left sidebar.
Right-click the bookmark entry to access a context menu for going to this bookmark
or renaming, or removing it.

2 To create an annotation for a page, press F6 and select one of the annotation tools
from the toolbar that appears. The annotation is added to the list of Reviews and is
flagged with the login name of the user who created it. Use the icons at the bottom
of the sidebar to group the annotations by page, by author or to show the annotations
for the current page only.
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3 To open a pop-up note and add text for an annotation (or to remove an annotation),
right-click the annotation entry in the Reviews list and select the corresponding menu
item. The annotations or markers you added are automatically attached to the file,
you do not need to save them.

14 Searching for Data

KDE provides more than one application for finding data on your computer or in the
file system. One application is KFind, which is described below.

14.1 Using KFind

To perform basic and advanced searches, use KFind. Start it from the Main Menu by
clicking Applications > Find Files/Folders or press Alt + F2 and enter k£ ind.
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Procedure 13 Searching by Name
To use a filename (or a part of it) as the search keyword, proceed as follows:

1 Enter the filename or a part of the filename in the Named input field. Use wild cards,
such as an asterisk (*), to indicate missing characters in the filename.

2 Specify the folder in which to search for the file. Either enter a path to the folder in
Look in or click Browse to locate the folder.

3 To search subfolders, check Include Subfolders.

4 Click Find to start the search. The results are displayed in the lower part of the dialog.
To directly open the result, just click it. Right-click it to choose one of the options
from the context menu.

Procedure 14 Searching by Contents or Properties

For a more detailed search, you can also specify further options, such as a text the file
must contain or the creation or modification date of a file. To search for content or
properties, proceed as follows:

1 On the Name/Location tab, specify at least the path to search for the file. You can
leave Named empty.

2 To search for certain content in a file, click the Contents tab. In Containing Text,
enter the word or phrase the file to find must contain. This option does not work for
all types of files.

3 To search for properties such as creation or modification date of the file, click the
Properties tab and choose the options you want.
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4 Click Find to start the search.

14.2 Using Strigi Desktop Search

Strigi Desktop Search offers advanced search capabilities by additionally searching for
metadata such as tags, ratings, and even source URLSs for downloads. It requires the
services nepomuk and strigi to run. To activate these services, press Alt + F2 and
enter strigi. Choose Nepomuk/Strigi server Configuration to start the configuration
dialog. Enable the two services on the tab Basic Settings and leave the dialog by clicking
Apply and OK.

Once activated, you can use KRunner (Alt + F2) to search for files by just typing a
keyword. A more advanced search interface is available in the Dolphin file manager.
Press Ctrl + F in Dolphin to activate the desktop search. You can filter the search results
for Filename, Content or location.

15 Creating a CD or DVD

If you possess a CD or DVD writer, you can burn files to a CD or DVD with K3b. To
create a data CD or DVD, proceed as follows:

T Press Alt + F2 and enter k3b. K3b opens.
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2 Select File > New Project > New Data Project from the main menu.

3 Use the tree view in the top left part of the window to search for the files or folders
to burn. When they appear in the top right part of the window, drag and drop them
into the Current Projects window.
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4 Insert a writable CD or DVD into the device then click the Burn icon.

5 Check the settings on the Writing tab. Usually the defaults should work well for al-
most all files. If you wish, you can change more options (for example the Volume
Name) on the Filesystem tab.

6 Click Burn.
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16 Managing Your Digital Image
Collection

With digiKam, it is easy to manage your digital images: download your images from
the camera, edit and improve them, organize them in albums (or flag them with tags
for easy retrieval, independent of folders or albums), archive them on CD or DVD, or
export them to a Web image gallery.

digiKam also contains a set of useful batch functions and plug-ins, allowing you to
convert multiple images to various different formats, rename multiple images, or auto-
matically improve them with functions such as red eye reduction, speck removal, and
hot pixel removal. Various filter and effects plug-ins help create works of art from your
digital images.

To start digiKam, press Alt + F2 and enter digikam. On initial start-up, the first-run
wizard appears to guide you through the setup.
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digiKam's main window contains a tree view on the left and shows thumbnails of the
images on the right. For quick access to your images, use the sidebar on the left, which
allows you to switch between different views, for example, sorting the images according
to Albums, Dates, Tags or Searches. To enter digiKam's viewing and editing mode,
double-click an image thumbnail.
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17 Managing Your Music Collection

KDE's Amarok music player allows you to play various audio formats, create playlists,
listen to streaming audio broadcasts of radio stations on the Internet and subscribe to
podcasts. The file types supported depend on the engine used for Amarok.

To start Amarok, press Alt + F2 and enter amarok. On first start, Amarok asks for the
folders where to look for your music files.

Amarok Playlist Tools Settings Help

SOOI -
1:07 (— )10:55

b A

e t b4 A
. Avist/ Year - Abum va Arriving Somewhere But Not Here E Firth of Fifth 937 A
3|[F 2 Overhead By Porcupine Tree d Genesis Selling England by.
20+ 2 Philips, Anthony on Deadwing Choose What You Want To Lo. 5:05
O+ & The Pineapple Thief RPWL The RPWL Experi
© + 2 PinkFloyd Play count  Score LastPlayed Lost ForWords e
+ & Placebo L O O O e 1 50 4 weeks ago Pink Floyd The Division Bell
- & Porcupine Tree - g Thunder Fly 6:19
- A 2009 - The Incident Albums by Porcupine Tree Bl viarition Happiness Is The
1 - Occam's Razor - — A Strange World 4:20
- L Spock's Beard The Kindness Of
. 2 The Biind House = | o racks L N .|
5 3 - Shesmovedon gSo But No 02
= 4- Kneel and Disconnect Warszawa (2004) Porcupine Tree Deadwing
] 5 - Drawing The Line 10 tracks i Quest For The Last Virtue 13:58
6 - The Incident Unifaun Urifaun
8- The Yellow Windows Of The Evenin ‘1"2’?"59:“9 (e m AFairytale Ending 16:45
racks
e ' The Bt ofEppngFarest 1145
LIl gsy The Battle of Epping Fores
q signify (1996
+ B8 2007 - Fear Of ABlank Planet 1zgtraik(s ) a & Genesis Seling England by.
< - il 2007 - Nl Recurring ( — v [ The Conflict 25:00
3 = Morse, Neal Sola Scriptura
o+ W/ 2006 - Stupid Dream (1999) 2005 R — e e
= - I 2005 - Deadwing il spocks Beara Octane CD1
1- Deadwing g9 Naminanu 354
2- Shallow Genesis Extra Tracks 1976,
e ——"The Colors changed 6:48
4 - Halo Bl Sylvan Leaving Backstag.
5 - Arriving Somewhere But Not Here Atom Heart Mother 23:47
8 6 - Mellotron Scratch Pink Floyd Atom Heart Mother
= 7 - Open Car B Jaden Maiden 4:04
= 8- The Start Of Something Beautiful b8 Volenweider, Andr Eolian Minstrel
9- Glass Arm Shattering P Out of Your League 429 &
+ Il 2004 - Warszava S Lyries Wikipedia | Current Track | Albums | /% B8 HD &

Playing: Arriving Somewhere But Not Here by Porcupine Tree on Deadwing (12:02) 32 tracks (5:08:31)

Amarok's main window shows a sidebar on the left providing different views: your local
music collection, some addresses to listen to podcasts or streams from the Internet, your
playlists and a file browser. The middle part, the context browser, displays information
about the current track, the Wikipedia page of the artist and the song's lyrics by default.
The right part of the window shows the current playlist. To play music, just drag and
drop items from any of the sidebar browsers to the playlist area. Double-click an item
in the playlist to start playback.

If your music files are properly tagged (containing at least information about the artist
and album), you can make use of several nice Amarok features. To automatically retrieve
the album cover images from Amazon, select Tools > Cover Manager and click Fetch
Missing Covers. The next time you play a track from this album, the cover is displayed
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in the context browser and on the on-screen display. To learn more about the artist,
click on the Wikipedia button in the middle area to make Amarok search for the appro-
priate Wikipedia article.

To configure the use of another engine (or various other Amarok features), select Settings
> Configure Amarok.

18 Logging Out

Log out (and leave the system running), restart or shut down the computer.

18.1 Logging Out or Switching Users

Click the Main Menu button on your panel and select Leave > Logout. This ends your
session but leaves the system running. To start a parallel session as a different user,
select Leave > Switch User instead.

18.2 Restarting or Shutting Down the
Computer

Click Leave, then select one of the following options:

Sleep
Only available if your computer provides power management functionality. Pauses
your computer without logging you out. All your data and the session data is saved
to RAM.

Hibernate
Only available if your computer provides power management functionality. Pauses
your computer without logging you out. All your data and the session data is saved
to disk before the system is laid to rest. It is thus protected against data loss should
you lose power in the meantime.

Restart
Restarts your computer.
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Shutdown
Logs you out of the current session, then turns off the computer.

19 For More Information

This guide gave you a short introduction to the KDE desktop and some key applications
running on it. To discover more, refer to the KDE User Guide (1 KDE User Guide), and
the other manuals available for SUSE Linux Enterprise Desktop at http: //www
.suse.com/documentation/sledll/.

To learn more about KDE and KDE applications, also refer to http://www.kde
.org/and http://www.kde—apps.org/.

20 Legal Notice

Copyright© 2006—2012 Novell, Inc. and contributors. All rights reserved.

Permission is granted to copy, distribute and/or modify this document under the terms
of the GNU Free Documentation License, Version 1.2 or (at your option) version 1.3;
with the Invariant Section being this copyright notice and license. A copy of the license
version 1.2 is included in the section entitled “GNU Free Documentation License”.

For Novell trademarks, see the Novell Trademark and Service Mark listhttp: //www

.novell.com/company/legal/trademarks/tmlist.html. All otherthird
party trademarks are the property of their respective owners. A trademark symbol (®,
™ etc.) denotes a Novell trademark; an asterisk (*) denotes a third party trademark.

All information found in this book has been compiled with utmost attention to detail.
However, this does not guarantee complete accuracy. Neither Novell, Inc., SUSE
LINUX Products GmbH, the authors, nor the translators shall be held liable for possible
errors or the consequences thereof.

GNU Free Documentation License

Version 1.2, November 2002
Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.
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PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under
the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the
license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of
text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires
to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled
XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers
may have is void and has no effect on the meaning of this License.

VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.
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COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access
to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option,
you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of
that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this require-
ment.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.
H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance and
tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the

Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.
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You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your Modified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement
of any Modified Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS

‘You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License
in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying
of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate,
the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.
TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
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been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

Copyright (c) YEAR YOUR NAME.

Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2

or any later version published by the Free Software Foundation;

with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU

Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.
If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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