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SUSE® Linux Enterprise Desktop provides the tools that Linux* users require in their
daily activities. It comes with an easy-to-use graphical environment, the GNOME*
desktop, that communicates with the underlying Linux system, to let you access and
manage files, folders, and programs. SUSE Linux Enterprise Desktop provides an inte-
grated suite of applications for a wide range of office, multimedia, and Internet activities.
The LibreOffice suite, which allows you to edit and save files in a number of formats,
is also included. The office suite is available for several operating systems. Therefore,
you can use the same data across different computing platforms.

1 Getting Started

When you start your system, you are usually prompted to enter your username and
password. If someone else installed your system, check with your system administrator
for your username and password.

After logging in to GNOME for the first time, you see the GNOME desktop, offering
the following basic elements:
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Desktop Icons: Access programs and features on your system by double-clicking an
icon. Right-click an icon to get additional menus and options. By default, the desktop

Quick Start Manuals



features several key icons, including your personal Home folder and a trash can for
deleted items. Other icons representing devices on your computer, such as CD drives
or USB flash disks, may also be present on the desktop, and you can add as many icons
on your desktop as you like. If you double-click your Home folder, the Nautilus file
manager starts and displays the contents of your home directory.

Bottom Panel: The desktop includes a panel at the bottom of the screen. This panel
contains the Computer menu, the Tomboy Notes applet, a taskbar to display buttons
for all currently running applications, and the system tray. You can also add applications
and applets to the panel for easy access.

Main Menu: Click Computer on the left side of the bottom panel to open the main
menu. Commonly used applications appear in the main menu along with recently used
applications. Click the Documents button to display your recent documents, or click
the Places button to display your favorite places (such as your home directory, your
desktop, or available network servers). Click More Applications to access additional
applications, listed in categories. Use the options on the right to access help, open the
GNOME Control Center, run YaST, install additional software, lock your screen, log
out of the desktop, shut down the system, or check the status of your hard drive and
network connections.

System Tray: The right side of the bottom panel shows some smaller icons, including
the system clock that displays the current date and time, the Workspace Switcher, the
volume control, and icons for several other helper applications.

Taskbar: By default, all applications running on the current desktop are displayed in
the taskbar (the area in the middle of the panel between the Computer button and the
system tray). You can access these applications by clicking their name in the taskbar.
Right-click the name of the application to see options for moving, restoring, or mini-
mizing the window.

Desktop Menu: Right-click an empty spot on the desktop to display a menu with
various options. Click Create Folder to create a new folder. Use Create Launcher to
create a launcher icon for an application. Provide the name of the application and the
command for starting it, then select an icon to represent it. You can also change the
desktop background, open a terminal, create a document, and align desktop icons.
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1.1 Modifying Desktop Panels

The bottom panel can be customized to meet your individual needs, and additional
panels can be added and configured to further personalize your desktop.

To add a new panel, right-click a blank space in the bottom panel and select New Panel.
To delete a panel, right-click a blank space in the panel and select Delete This Panel.
SUSE Linux Enterprise Desktop requires that at least one panel is left on the desktop.

1.2 Adding and Removing Panel Icons

1 Right-click a blank space on the panel and select Add to Panel.
2 Browse to the desired program and double-click it to add it to the panel.

3 To remove a program icon from a panel, right-click its icon in the panel and select
Remove From Panel.

2 Starting Programs

Start programs from the Main Menu or from the command line, using a shell or the Run
Command. Additionally, you can start programs from the desktop or the panel by left-
clicking the program icon once.

2.1 Using the Main Menu

To run a program in SUSE Linux Enterprise Desktop, click Computer on the panel to
open the main menu screen. If the program you want does not appear in the main menu
screen, click More Applications to view a list of all available applications grouped in
categories. You can also limit the list to show only applications with a specific name
by entering all or part of the name into the Filter field. Click an entry in the list to start
the corresponding program.
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You can also add an icon to your panel that opens a more traditional version of the main
menu. Right-click a blank space on the panel, select Add to Panel, then double-click
Traditional Main Menu.

If you already know the name of an application but are not sure how to start it from the
main menu, use the Search field in the main menu. Click Computer, type a portion of
the application name in the Search field, then press Enter. If the application is installed
on your system, the name of the application appears in the Desktop Search dialog box.

Click the name to start the program.

2.2 Using the Run Application Dialog

Press Alt + F2 to open the Run Application dialog. Type a command, for example,
f-spot, and press Enter or click Launch to start the application. The command to
start the application is often (but not always) the application name written in lowercase.
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3 Handling Media

If you insert a CD or DVD into your drive or plug in a pluggable device (for example,
a USB stick or removable hard disk), GNOME opens Nautilus and shows the content
of the media.

4 Customizing Your Desktop

Easily add, delete, and create shortcut icons on your desktop. You can also change icon
properties and the desktop background to suit your needs.

4.1 Adding Program Icons to Your Desktop
1 Click Computer.
2 Browse to the desired program.

3 Click and drag the icon to the desktop and position it as desired.

Quick Start Manuals



To delete an icon from your desktop, simply click the program icon and press the Delete

key on your keyboard.

4.2 Changing the Desktop Background

1 Right-click the background.

2 Select Change Desktop Background.

i Appearance Preferences

Theme éBackgroundf Fonts  Interface

Wallpaper

)
N B
B G

e &
Style: |Fillscreen & ¢ Add...| | = Remove
Colors
Solid color < ||/
@ e ¥ Close

3 To select a wallpaper from the pre-installed images, browse to and select the desired
image. After you select it, the background changes automatically.

4 To add an image, select Add, browse to the desired image, then click Open.

5 To display a colored background, select the solid color rectangle from the top of the
list; then, from Colors, select the fill pattern and the desired colors.

6 Click Close.
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4.3 Using the GNOME Control Center

In addition to letting you change individual desktop elements, GNOME lets you exten-
sively personalize your desktop. You can find more settings to adjust the overall appear-
ance and behavior of your desktop in the GNOME Control Center. There, you can also
change fonts, keyboard and mouse configurations, regional and language settings, pa-
rameters for your Internet and network usage, and more.

To start the Control Center, click Computer, then click Control Center on the right of
the main menu.
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5 Applying Desktop Effects

If your computer supports a 3D graphics card with Xgl, you can use graphical effects
like turning your desktop into a rotating 3D cube, enabling translucent or transparent

windows, and zooming in and out of the desktop screen. You can also use other window
effects such as shadows, fading, and transformations. If you do not have a 3D graphics
card, some effects may be disabled or reduce the performance of your system. If the
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performance of your system is too low, disable the compositing effect for your current
session with Alt + Shift + F12.
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To configure the effects on your desktop, proceed as follows:

1 Start the personal settings window as described in Section 4.3, “Using the GNOME
Control Center” (page 8).

2 Select Look and Feel > Desktop Effects and choose Enable Desktop Effects. If your
graphic card does not support 3D, you will be notified.

3 Select the effects in one of the tabs.

6 Using Virtual Desktops

The desktop environment allows you to organize your programs and tasks on several

virtual desktops. If you often run a lot of programs simultaneously, this minimizes the
number of windows to arrange on your screen. You might, for example, use one desktop
for e-mailing and calendaring and another for word processing and graphics applications.
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Procedure 15 Moving an Application to Another Virtual Desktop

You can display a running application on one or all virtual desktops, or move it to other
desktops.

1 Open the application.

2 Right-click the title bar of the application.

3 Click Move to Another Workspace.

4 Select the desktop on which to place the application.

5 To switch between desktops, click the desired desktop in the pager in the panel.

Procedure 16 Adding Additional Virtual Desktops

Some users might need more desktops than are provided by default. To add additional
desktops :

1 Right-click the pager in the panel and select Preferences. A configuration dialog
appears:
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2 Decrease or increase the Number of Workspaces.

3 Ifyou want to change the names of the desktops double click on the list entries and
enter the new names.

7 Managing Files and Folders

Use the Nautilus File Manager to create and view folders and documents, run scripts,
and create CDs of your data. Double-click your home directory icon on the desktop to
open Nautilus and see the contents of your home directory.
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The elements of the Nautilus window include the following:
Menu Lets you perform most tasks.

Toolbar Lets you quickly navigate among files and folders, and provides access to
files and folders.

Location Bar Lets you locate files, folders, and URI sites. The button on the left side
toggles between button-based and text-based display.

Side Pane Lets you navigate or display information about the selected file or folder.
Use the drop-down list to customize what is shown in the pane. The list includes ways
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to view information about files, perform actions on files, attach emblems to files, view
a history of recently visited sites, and display your files in the tree system.

View Pane Displays folders and files. Use the options on the View menu to increase
or decrease the size of content in the view pane and to display items as a list or as icons.

Status Bar Displays the number of items in a folder and gives the available free space.
When a file is selected, the status bar displays the filename and size.

7.1 Archiving Folders

If you have files you have not used recently but want to keep on your computer, you
can compress the files into a tape archive (TAR) format.

1 In the Nautilus view pane, right-click the folder you want to archive and select
Compress.

A% FEilename: [ tar.gz o
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| Hel Cancel & Create
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2 Accept the default archive filename or provide a new name.

3 Select a file extension from the drop-down list. Use tar . gz for the most common
archive form.

4 Specity a location for the archive file, then click Create.

To extract an archived file, right-click the file and select Extract Here.

7.2 Using Bookmarks

Use the Nautilus bookmarks feature to mark your favorite folders.
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1 Open the folder you want to create a bookmark for.

2 Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the
folder name as the bookmark name.

3 To select an item from your bookmarks list, click Bookmarks, then click the desired
bookmark in the list.

You can also organize your bookmarks list by clicking Bookmarks > Edit Bookmarks
and making your selections in the dialog box.

EBookmarks Name
e )

Location

| momestuxsscreenshots |

@ Help A umpto | | = Remove

To change the order of your bookmarks, click a bookmark shown in the Edit Bookmarks
dialog and drag it to the desired location.

8 Browsing the Internet with Firefox

Firefox* is becoming the Web browser of choice. It has all the familiarity of other
browsers, plus added features such as security and privacy tools.

GNOME Quick Start
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To start Firefox, click Computer > Firefox Web Browser.

With features like tabbed browsing, pop-up window blocking, and download and image
management, Firefox combines the latest Web technologies. Its easy access to different
search engines helps you find the information you need. Enter a URL in the location
bar to start browsing.

To open a new empty tab in Firefox, press Ctrl + T or the “+” button next to the last tab
. Type a new URL to browse. To open a link in a new tab, click the link with your
middle mouse button. Right-click a tab to access more tab options. You can create a
new tab, reload one or all existing tabs, or close a single tab or all tabs. You can also
change the sequence of the tabs by dragging and dropping them to a new position.

8.1 Finding Information

1 To start a search on the Web type your search keywords in the integrated search box
on the right of the location bar, then press Enter. The results are displayed in the
active window or tab.

2 To use a different search engine than the default, click the icon in the search box to
open a list of other search engines.

3 Click the desired engine, then press Enter to start the search.
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To search the current Web page for words, press Ctrl + F to open the Find bar at the
bottom of the window. Enter your search keyword there and use the buttons to the right
of the box to search in different directions or to select all hits in the text.

8.2 Downloading Files from the Web

If you download a file with Firefox, the Firefox download manager starts and saves
this file to the folder configured in Firefox Preferences. By default, your desktop is the
destination folder for downloaded files. Firefox shows your finished downloads in the
Downloads window.

Downloads

openSUSE . org.html 02:08 PM
171 KB — opensuse.org
Gimp.cz.html Thursday
21.7 KB — gimp cz

%\‘/-»Qlear List | |

Open the downloaded files directly from the Downloads window or from the destination
folder. To clean up the history of downloaded files, click Clean Up.

8.3 Configuring Preferences

To adjust the default download folder or to activate or modify the pop-up blocking
feature, click Edit > Preferences.

GNOME Quick Start
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Here also configure many other settings such as appearance, language, privacy, and tab
options. Click the icons and set the options on each page according to your preferences.
Click Close to apply the changes.

9 Managing Passwords

GNOME allows you to store your passwords and encryption keys in a keyring. This is
useful, if you want to store passwords for different Web sites.

To create a new keyring, proceed as follows:

1 Press Alt + F2 and enter seahorse.

2 Select File > New.

3 Choose Password Keyring and proceed with Continue.
4 Enter a name for your keyring. A dialog box opens.

5 Enter your password, confirm, and click OK.
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You can create as many keyrings as you like. For example, you can create one for private
and one for business. To store passwords in your keyring, proceed as follows:

1 Press Alt + F2 and enter seahorse.

2 Select File > New.
3 Choose Store Password and proceed with Continue.

4 Select your keyring, enter description and password.

5 Finish with Add.

10 E-Mailing and Calendaring

For reading and managing your mail and events, SUSE Linux Enterprise Desktop offers
you Evolution™, a groupware program that makes it easy to store, organize, and retrieve
your personal information.

Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in
one easy-to-use application. With its extensive support for communications and data
interchange standards, Evolution can work with existing corporate networks and appli-
cations, including Microsoft* Exchange.
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To start Evolution, click Computer > Evolution Mail and Calendar.

The first time you start it, Evolution prompts you with a few questions as it sets up a
mail account and helps you import mail from your old mail client. It shows you how
many new messages you have and lists upcoming appointments and tasks, as well as
the current weather and news from news feeds. The calendar, address book, and mail
tools are available in the shortcut bar on the left.

Press Ctrl + N to open a new item for whatever part of Evolution you are working in.
In mail, this creates a new message. If you are in the address book, Ctrl + N creates a
new contact card, and in the calendar, it creates a new appointment.

For more information on using Evolution, click Help > Contents in any Evolution
window.

11 Instant Messaging with Pidgin

Pidgin is a multiprotocol instant messaging (IM) client. It is compatible with AOL*
Instant Messenger (AIM), Google Talk, GroupWise® Messenger, ICQ, IRC, MSN
Messenger, Jabber/XMPP, Yahoo!*, and other networks.

With Pidgin, you can log in to multiple accounts on multiple IM networks simultane-
ously. Pidgin also supports many features of the various networks, such as file transfer,
away messages, and typing notification.

To start Pidgin, click Computer > More Applications > Internet > Pidgin, or press Alt
+ F2 and enter pidgin.

To add an account to Pidgin, either use the initial configuration wizard or select Accounts
> Manage Accounts from the Buddy List. Click Manage Accounts, click Add, select the
protocol you want, and type your login information in the appropriate fields. Activate
the account by checking the Enabled checkbox in the account list.

Add contacts by clicking Buddies > Add Buddy. An assistant appears to help with cre-
ation. However, you must be online and connected to the selected messaging service
to add a contact to your list.
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To start a chat, double-click the desired contact and type your message in the lower
part of the chatting window. Press Enter to send the message. The upper part of the
window displays the messages you have sent and received.

12 Starting LibreOffice

The LibreOffice office suite offers a complete set of office tools, including word pro-
cessing, spreadsheet, presentation, vector drawing, and database components. Because
LibreOffice is available for a number of operating systems, you can use the same data
across multiple platforms.

To start LibreOffice, click Computer > OpenOlffice.org Writer. To create a new docu-
ment, click File > New, then choose the type of document you want to create. To open
an existing document, click Open, then select the file you want from the file system.

Find more information in the LibreOffice.org Quick Start.

13 Viewing PDF Files and Other
Documents

Documents that need to be shared or printed across platforms are often distributed as
PDF (Portable Document Format) files. PDF files can be created using the LibreOffice
suite or other applications. The GNOME PDF viewer is called Evince. It can be used
to view PDFs and many other document formats, like PostScript, DjVu, DVI, and
multi-page TIFFs.

To start Evince, press Alt + F2 and enter evince .

1 To view a PDF file, double-click the PDF file.
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2 Use the navigation icons at the top of the window to navigate through the document.
If the PDF document provides bookmarks, you can access them in the left panel of
the viewer.

14 Searching for Data

GNOME provides more than one application for finding data on your computer or in
the file system.

14.1 Using Desktop Search

To locate files or programs on your computer, click Computer. Enter a search term in
the Search field and press Enter. The results are displayed in the Tracker Search Tool.
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For a more advanced search tool, use Desktop Search (Beagle Search). To start it, click
Computer > More Applications > System > Search.

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item depend on the type of file it is. Clicking a file in the
list displays a preview of the file and information such as the title, path, and date the
file was last modified or accessed.

Use the Find In menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The View menu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.

14.2 Using GNOME Do

GNOME Do describes itself as an “intelligent launcher that makes performing common
tasks on your computer simple and efficient.” It is extensible with plug-ins.

Start it by pressing Super + Space. The Super is normally located on the left and right
Windows or Penguin key.

GNOME Do allows you to perform different actions. For example, if you type b, it
displays a starter button for the Banshee musicplayer:
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To customize GNOME Do to your needs, select the arrow button on the upper-right
corner of the window and select Preferences. It gives you a list of plug-ins to search
for e-mails in Evolution, listen to your music, etc.
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15 Creating a CD or DVD

If your system has a CD or DVD writer, use the Nautilus file manager to burn CDs and

DVDs.

1 Click Computer > More Applications > System > CD/DVD Creator, or just insert a

blank disk.

2 Copy the files and folders you want to put on the CD or DVD into the Nautilus

CD/DVD Creator window.

CD/DVD Creator - File Browser
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3 Click Write to Disk.

4 Modify the relevant information in the Write to Disk dialog box, or accept the default
values, then click Write. The files are burned to the disk. This could take a few
minutes, depending on the amount of data being burned and the speed of your

burner.

You can also use Brasero or Banshee to burn data and audio CDs.
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16 Managing Your Digital Image
Collection

F-Spot is a management tool for your collection of digital images, tailored for the
GNOME desktop. It allows you to assign different tags to your images in order to cat-
egorize them, and offers various image editing options. For example, you can remove
red-eye, crop, and adjust brightness and colors. F-Spot supports all important image
formats, including JPEG, PNG, TIFF, and several vendor specific RAW formats.

You can import photos from your hard drive, your digital camera, or your iPod. You
can also use F-Spot to create photo CDs, generate a Website gallery, or export your
photos to your Flickr, 23, Picasa Web, or SmugMug account.

To access F-Spot, click Computer > F-Spot Photo Browser or press Alt + F2 and enter
f-spot. The first time you run F-Spot, you must define the location from where you
want to import images into your collection. If you already have a collection of images
stored on your hard drive, enter the path to the directory and (optionally) include sub-
folders. F-Spot imports these images into its database.
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Thumbnails of your images are displayed in the right part of the window, and detailed
information for a selected image is displayed in a sidebar to the left. By default, your
photos are displayed in reverse-chronological order, so your newest photos are always
at the top. You can sort your photos in chronological order or reverse-alphabetical order
by clicking View > Reverse Order.

A menu bar at the top of the window allows you to access the main menus. A toolbar
below offers several different functions depicted by a matching icon.

17 Managing Your Music and Videos

Use Banshee to import CDs, sync your media collection to a digital media player, play
music directly from a digital media player, create playlists with songs or videos from
your library, create audio and data CDs from subsets of your library, and subscribe to,
download, and listen to your favorite podcasts. Banshee also has an Internet Radio plug-
in that allows you to listen to audio streams.

To open Banshee, click Computer > Banshee Media Player or press Alt + F2 and enter
banshee-1.

When you start Banshee for the first time, you need to import your media to make them
available in the library. To do so, select Media > Import Media from the menu. Choose
an import source and click Import Media Source. After successfully importing your
media, you can access them from your library.
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Banshee|Music Player: = o

Music Edit Playback Tools \iew Help
ka > oA e a)
it Music Library Music Library Search; |, Classical |
§ Podcasts o) Track  Artist Title Album Time |
Ei Radio 22) 1 Various Rossini / William Tell Ove . Classical Treasures 25 302
(5) Classical Trea... =) 2 Various Strauss / Blue Danube Classical Treasures 25 209

3 Various Ponchielli/ Dance of the Classical Treasures 25 1:59

4 Various Bizet / Carmen Overture Classical Treasures 25 220

5 Various Schubert / Serenade Classical Treasures 25 314

6 Various Schubert / Marche Militaire  Classical Treasures 25 141

7 Warious J. Strauss / Radetsky Ma Classical Treasures 25 218

8 Various Chopin / Nocturne Classical Treasures 25 207

9 Various Debussy / Claire de Lune  Classical Treasures 25 1:43

10 Various Schubert / Unfinished S Classical Treasures 25 2:03

n Various Mendelssohn / Violin Con Classical Treasures 25 1:34

12 Various Tchaikevsky / Waltz Of FI... Classical Treasures 25 2:04

13 Various Liszt / Hungarian Rhapsody Classical Treasures 25 201

14 Various Verdi/ Dance Of The Prie... Classical Treasures 25 1:30

15 Various Strauss / Voices of Spring  Classical Treasures 25 1:18 L

16 Various Mozart / Minuetin D Classical Treasures 25 0:22

17 Various Tchaikevsky / Dance of th... Classical Treasures 25 1:36 =

@ T )

-+ & 19 Items, 37 minutes, 25 seconds

To play a song or a movie, simply select it in the library and click the play button. You
can also use the buttons in the upper left corner to pause a song or play the next or
previous song. Use the loudspeaker button on the right to adjust the volume.

Banshee also has an integrated CD player. When you insert a music CD, your CD title
appears in the left panel. Select the title and click the Play button to play your full CD.

To create audio and MP3 CDs, select the songs you want, then click the Edit > Write
CD from the menu.

18 Logging Out

When you are finished using the computer, you can log out and leave the system running,
or restart or shut down the computer.

18.1 Logging Out or Switching Users

Click Computer > Logout, then select one of the following options:
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Log out Logs you out of the current session and returns you to the login screen.

Switch User Suspends your session, allowing another user to log in and use the
computer.

18.2 Restarting or Shutting Down the
Computer

Click Computer > Shutdown, then select one of the following options:
Shutdown Logs you out of the current session, then turns off the computer.
Restart Logs you out of the current session, then restarts the computer.

Suspend Puts your computer in a temporary state that conserves power. The state of
your session is preserved, however, including all applications you have running and all
documents you have open.

Hibernate Suspends your session, using no power until the computer is restarted. The
state of your session is preserved, however, including all applications you have running
and all documents you have open.

19 For More Information

This guide gave you a short introduction to the GNOME desktop and some key appli-
cations running on it. To discover more, refer to GNOME User Guide (t GNOME User

Guide) and the other manuals available for SUSE Linux Enterprise Desktopathttp://
www.suse.com/documentation/sledll/.

To learn more about GNOME and GNOME applications, referto ht tp: //www . gnome
.org/.

20 Legal Notice

Copyright© 2006—2012 Novell, Inc. and contributors. All rights reserved.
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Permission is granted to copy, distribute and/or modify this document under the terms
of the GNU Free Documentation License, Version 1.2 or (at your option) version 1.3;
with the Invariant Section being this copyright notice and license. A copy of the license
version 1.2 is included in the section entitled “GNU Free Documentation License”.

For Novell trademarks, see the Novell Trademark and Service Mark listhttp://www

.novell.com/company/legal/trademarks/tmlist.html. All other third
party trademarks are the property of their respective owners. A trademark symbol (®,
™ etc.) denotes a Novell trademark; an asterisk (*) denotes a third party trademark.

All information found in this book has been compiled with utmost attention to detail.
However, this does not guarantee complete accuracy. Neither Novell, Inc., SUSE
LINUX Products GmbH, the authors, nor the translators shall be held liable for possible
errors or the consequences thereof.

GNU Free Documentation License

Version 1.2, November 2002
Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under
the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the
license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.
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A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of
text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires
to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled
XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers
may have is void and has no effect on the meaning of this License.

VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access
to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option,
you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of
that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this require-
ment.
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C. State on the Title page the name of the publisher of the Modified Version, as the publisher.
D. Preserve all the copyright notices of the Document.
E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.
H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance and
tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.
N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.
O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your Modified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement
of any Modified Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS

‘You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License
in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying
of each of the documents in all other respects.

‘You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.
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AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate,
the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION

‘You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

Copyright (c) YEAR YOUR NAME.

Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2

or any later version published by the Free Software Foundation;

with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU

Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.
If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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