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About This Guide
This manual introduces you to a variety of applications shipped with SUSE® Linux
Enterprise Desktop. It guides you through the use of these applications and helps you
perform key tasks. It is intended mainly for end users.

The manual is divided into the following parts:

OpenOffice.org Novell Edition
Introduces the OpenOffice.org suite, including Writer, Calc, Impress, Base, Draw,
and Math. Learn which additional features are included in the Novell edition of
OpenOffice.org.

Information Management
Get to know the e-mailing and calendaring software provided by your product.
Learn how to use protected information transfer by signing and encrypting your
documents or mails. Make use of note-taking applications to collect and sort infor-
mation and to organize your ideas.

Communication and Collaboration
Stay in contact with others and communicate via network connections using Instant
Messaging or Voice over IP.

Internet
Search for information on the Web with browsers combining the latest browsing
and security technologies. Make use of file transfers client to transfer data from
the Internet.

Graphics
Get to know GIMP, an image manipulation program that meets the needs of both
amateurs and professionals. Learn how to download digital photographs from your
camera and how to manage your image collection by creating albums or exporting
them to image galleries on the Web.

Multimedia
Get introduced to your desktop's applications for playing music and movies. Learn
how to create data or audio CDs and DVDs for archiving your data.



Many chapters in this manual contain links to additional documentation resources.
These include additional documentation that is available on the system, as well as
documentation available on the Internet.

For an overview of the documentation available for your product and the latest docu-
mentation updates, refer to http://www.novell.com/documentation or to
the following section.

1 Available Documentation
We provide HTML and PDF versions of our books in different languages. The following
manuals for users and administrators are available on this product:

KDE User Guide (↑KDE User Guide)
Introduces the KDE desktop of SUSE Linux Enterprise Desktop. It guides you
through using and configuring the desktop and helps you perform key tasks. It is
intended mainly for users who want to make efficient use of KDE as their default
desktop.

GNOME User Guide (↑GNOME User Guide)
Introduces the GNOME desktop of SUSE Linux Enterprise Desktop. It guides you
through using and configuring the desktop and helps you perform key tasks. It is
intended mainly for end users who want to make efficient use of GNOME desktop
as their default desktop.

Application Guide (page 1)
Learn how to use and configure key desktop applications on SUSE Linux Enterprise
Desktop. This guide introduces browsers and e-mail clients as well as office appli-
cations and collaboration tools. It also covers graphics and multimedia applications.

Deployment Guide (↑Deployment Guide)
Shows how to install single or multiple systems and how to exploit the product
inherent capabilities for a deployment infrastructure. Choose from various approach-
es, ranging from a local installation or a network installation server to a mass de-
ployment using a remote-controlled, highly-customized, and automated installation
technique.

Administration Guide (↑Administration Guide)
Covers system administration tasks like maintaining, monitoring and customizing
an initially installed system.
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Security Guide (↑Security Guide)
Introduces basic concepts of system security, covering both local and network se-
curity aspects. Shows how to make use of the product inherent security software
like Novell AppArmor (which lets you specify per programwhich files the program
may read, write, and execute) or the auditing system that reliably collects informa-
tion about any security-relevant events.

System Analysis and Tuning Guide (↑System Analysis and Tuning Guide)
An administrator's guide for problem detection, resolution and optimization. Find
how to inspect and optimize your system by means of monitoring tools and how
to efficiently manage resources. Also contains an overview of common problems
and solutions and of additional help and documentation resources.

Virtualization Guide (↑Virtualization Guide)
Offers an introduction to virtualization technology of your product. It features an
overview of the various fields of application and installation types of each of the
platforms supported by SUSE Linux Enterprise Server as well as a short description
of the installation procedure.

In addition to the comprehensive manuals, several quick start guides are available:

KDE Quick Start (↑KDE Quick Start)
Gives a short introduction to the KDE desktop and some key applications running
on it.

GNOME Quick Start (↑GNOME Quick Start)
Gives a short introduction to the GNOME desktop and some key applications
running on it.

OpenOffice.org Quick Start
Gives a short introduction into the OpenOffice.org suite and its modules for writing
texts, working with spreadsheets, or creating graphics and presentations.

Installation Quick Start (↑Installation Quick Start)
Lists the system requirements and guides you step-by-step through the installation
of SUSE Linux Enterprise Desktop from DVD, or from an ISO image.

Linux Audit Quick Start
Gives a short overview how to enable and configure the auditing system and how
to execute key tasks such as setting up audit rules, generating reports, and analyzing
the log files.
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Novell AppArmor Quick Start
Helps you understand the main concepts behind Novell® AppArmor.

Find HTML versions of most product manuals in your installed system under /usr/
share/doc/manual or in the help centers of your desktop. Find the latest documen-
tation updates at http://www.novell.com/documentation where you can
download PDF or HTML versions of the manuals for your product.

2 Feedback
Several feedback channels are available:

Bugs and Enhancement Requests
For services and support options available for your product, refer to http://www
.novell.com/services/.

To report bugs for a product component, please use http://support.novell
.com/additional/bugreport.html.

Submit enhancement requests athttps://secure-www.novell.com/rms/
rmsTool?action=ReqActions.viewAddPage&return=www.

User Comments
We want to hear your comments and suggestions about this manual and the other
documentation included with this product. Use the User Comments feature at the
bottom of each page in the online documentation or go tohttp://www.novell
.com/documentation/feedback.html and enter your comments there.

3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: directory names and filenames

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH
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• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as
on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to a
chapter in another manual.
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Part I. OpenOffice.org Novell
Edition





1OpenOffice.org: The Office
Suite
OpenOffice.org is an open-source office suite that provides tools for all types of office
tasks such as writing texts, working with spreadsheets, or creating graphics and presen-
tations. With OpenOffice.org, you can use the same data across different computing
platforms. You can also open and edit files in other formats, includingMicrosoft Office,
then save them back to this format, if needed. This chapter contains information that
applies to all of the OpenOffice.org modules and gives an overview of the features
specific to the Novell edition of OpenOffice.org that is shipped with SUSE® Linux
Enterprise Desktop.

1.1 OpenOffice.org Modules
OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 1.1. A full description of
each module is available in the online help, described in Section 1.11, “For More Infor-
mation” (page 19).

Table 1.1 The OpenOffice.org Application Modules

PurposeModule

Word processor application moduleWriter

Spreadsheet application moduleCalc

Presentation application moduleImpress
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PurposeModule

Database application moduleBase

Application module for drawing vector graphicsDraw

Application module for generating mathematical formulasMath

1.2 Novell Edition of OpenOffice.org
SUSE® Linux Enterprise Desktop provides the Novell edition of OpenOffice.org. The
Novell edition has several enhancements that are not included in the standard edition:

General

• Many performance improvements for a better user experience

• Built-in extensions

• Google Docs and Zoho load and save

• Support for Open Document Format (ODF) v1.2

Base

• Built-in extensions. Report designer for creating smart-looking database reports.

Calc

• Extended row limit (1,048,576 rows) and related performance improvements

• Improved load and save of files in .xlsx format.

• Improved support for VBA macros.

• Usability improvements in selections and copying.

• Built-in extensions and non-linear solver.
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• Support for Comments.

• New chart types, like Bubble.

Writer

• Improved load and save of files in .docx format.

• Built-in extensions for PDF import and MediaWiki export.

• Autocorrection improvements.

Impress

• Improved load and save of files in .pptx format.

• Built-in extensions provided: Presenter console for better overview of the presenter
(time, next slide); Presentation minimizer to clean up the presentation before
sending it to others

Additionally, the following features are known from older versions:

Excel VBA Macro Interoperability:
OpenOffice.org Novell edition eases the migration of manymacros fromMicrosoft
Excel. Although not all macros can be successfully migrated, this interoperability
offers more than the standard edition, which does not support migration of macros.

Data Pilots:
Data Pilots are interoperable with Microsoft Office PivotTables*. OpenOffice.org
Novell edition substantially improves the Data Pilot feature, making it possible to
edit pilots after creation.

Enhanced Fonts:
Licensed fonts from Agfa* Monotype* which are metrically identical and visually
compatible with some of the key Microsoft fonts. This allows OpenOffice.org
Novell edition to match fonts when opening documents originally composed in
Microsoft Office, and very closely match pagination and page formatting.

EMF+Support:
The ability to render EMF+ formatted graphics.
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SVG Support:
The ability to import scalable vector graphics.

Import File Formats:
Microsoft Works, WordPerfect* text and graphics, T602 files, Office Open XML,
and more.

GroupWise® Integration:
OpenOffice.org Novell edition includes improved integration with ODMA (Open
DocumentManagement Architecture) services, for example for GroupWise. If you
have the GroupWise client installed on the machine, OpenOffice.org Novell edition
will offer to open documents from GroupWise, or save documents in GroupWise.

You can also use the standard edition of OpenOffice.org rather than the Novell edition.
If you install the latest version of OpenOffice.org, all of your Novell edition files remain
compatible. However, the standard edition does not contain the enhancements made in
the Novell edition.

For a full list of new core features available with OpenOffice.org 3.2.0, refer to
http://development.openoffice.org/releases/3.2.0.html.

1.3 Starting OpenOffice.org
To start the OpenOffice.org suite, press Alt + F2 and enter ooffice. The OpenOf-
fice.org window opens.
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Figure 1.1 The Welcome Screen of OpenOffice.org

In the selection dialog, choose the module you want to open or which file type you
want to create. If any OpenOffice.org application is open, you can start any of the other
applications by clicking File > New > Name of Application.

You can also start individual OpenOffice.org modules from your main menu or by
pressing Alt + F2 and entering the command for the respective module. For example,
enter oowriter to start OpenOffice.org Writer, or oocalc to start Calculator, or
ooimpress to start Impress.

Before you start working with OpenOffice.org, you may be interested in changing some
options from the preferences dialog. Click Tools >Options... to open it. One of the most
importants are:

OpenOffice.org > User Data
Insert your user data like company, first and last name, street, city, and other useful
information. This data is used in OpenOffice.orgWriter for annotations, for example.

OpenOffice.org > Fonts
Offers mappings from one font name to another. This could be useful, if you ex-
change documents with others and the document you received contains fonts that
are not available on your system.
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Load/Save > General
Contains load and save specific options. For example, here select the option to al-
ways create a back-up copy or decide which default file format OpenOffice.org
should use.

NOTE: How to Switch to Edit Mode for Read-Only Documents

If you open your document in read-only mode, a lot of functionality is disabled
per default. To edit your document, save it first or click the Edit File button in
the standard toolbar. After you have accepted the warning message, you can
edit your text in a copy of your document.

1.4 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, including Microsoft Office. They can be easily opened like
other files and saved back to the original format. If you have problems with your docu-
ments, consider opening them in the original application and resaving them in an open
format such as RTF for text documents. In case of migration problems with spreadsheets
however, it is advisable to re-save them as Excel files and use this as intermediate format
(with CSV format you would lose all cell formatting and formulas; a CSV sometimes
leads to incorrect cell type detection for spreadsheets).

TIP: OpenOffice.org Migration Guide

For useful information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide at http://
documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf.
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1.4.1 Converting Documents to the
OpenOffice.org Format

OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following:

1 Select File >Wizards > Document Converter.

2 Choose the document type (StarOffice* or Microsoft Office).

3 Choose the file format from which to convert. There are several StarOffice and
Microsoft Office formats available.

4 Click Next.

5 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.

Documents retrieved from a Windows partition are usually in a subdirectory of
/windows.

6 Make sure that all other settings are correct, then click Next.

7 Review the summary of the actions to perform, then start the conversion by
clicking Convert. When everything is done, close the Wizard by clicking Close.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

1.4.2 Sharing Files with Users of Other
Office Suites

OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.
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When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file
Save the document in the format the other user needs. For example, to save as a
Microsoft Word file, click File > Save As, then select the Microsoft Word file type
for the version of Word the other user needs.

If the recipient only needs to read the document
Export the document to a PDF file with File > Export as PDF. PDF files can be
read on any platform using a PDF viewer.

If you want to share a document for editing
Agree on a common exchange format that works for everyone. TXT and RTF for-
mats, although limited in formatting, might be a good option for text documents.

If you want to e-mail a document as a PDF
Click File > Send > E-mail as PDF. Your default e-mail program opens with the
file attached.

If you want to e-mail a document to a Microsoft Word user
Click File > Send > E-mail as Microsoft Word. Your default e-mail program opens
with the file attached.

Send a document as the body of an e-mail
Click File > Send > Document as E-mail. Your default e-mail program opens with
the contents of the document as the e-mail body.

1.5 Saving OpenOffice.org Files with
a Password

You can save files, no matter in which OpenOffice.org format, with a password. Note
that this offers limited protection only. For stronger protection, use encryption methods
as described in Chapter 11, Encrypting Partitions and Files (↑Security Guide). To save
a file with a password, select File > Save or File > Save As. In the dialog that opens,
activate the Save with password check box and click OK. After you have typed and
confirmed your password, your file will be saved. The next time a user opens the file,
he will be prompted for the password.
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To change the password, either overwrite the same file by selecting File > Save As or
select File > Properties and click Change Password to access the password dialog.

1.6 Signing Documents
You can digitally sign documents to protect them. For this you need a personal key
(certificate). When applying a digital signature to a document, a kind of checksum is
created from the document's content and your personal key. The checksum is stored
together with the document. When another person opens the document, the recent
checksumwill be compared to the original checksum and if both are equal, the applica-
tion will signal that the document has not been changed in the meantime. To sign a
document, select File > Digital Signature and click Add to add the certificate you want
to use for signing.

SUSE Linux Enterprise Desktop allows you to access certificates from the certificate
store. For more information, refer to Chapter 12, Certificate Store (↑Security Guide).

1.7 Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign the macro to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are
what you wanted and go back and modify them if they are not. See the OpenOffice.org
help files for detailed instructions.

To access the customization dialog in any open OpenOffice.org module, select Tools
> Customize.
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Figure 1.2 Customization Dialog in Writer

Procedure 1.1 Customizing Toolbars

1 In the customization dialog, click the Toolbar tab.

2 From the Toolbar drop-down list, select the toolbar you want to customize.

3 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you do not want to appear.
A short description for each command is shown at the bottom of the dialog.

4 With Save In, select whether to save your customized toolbar in the current
OpenOffice.org module or in the current document. If you decide to save it in
the OpenOffice.org module, the customized toolbar is used whenever you open
that module. If you decide to save it together with the current document, the
customized toolbar is used whenever you open that document.

5 Repeat to customize additional toolbars.

6 Click OK.

If you want to switch back to the original settings again, open the customization dialog,
click the Toolbardrop-down list and select Restore Default Settings. Click Yes and Reset
to proceed.
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Procedure 1.2 Showing or Hiding Buttons in the Toolbar

1 Click the arrow icon at the right edge of the toolbar you want to change.

2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list to enable (check) or disable (uncheck) them.

Procedure 1.3 Customizing Menus

You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools > Customize >Menus.

2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete menu items as desired.

4 Click OK.

Procedure 1.4 Customizing Keyboard Shortcuts

You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools > Customize > Keyboard.

2 Select the keys you want to assign to a shortcut.

3 Select a Category and an appropriate function.

4 ClickModify to assign the function to the key or Delete to remove an existing
assignment.
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NOTE: Further Information

Click Help for more information about the options in the Customize dia-
log.

5 Click OK.

Procedure 1.5 Customizing Events

OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assignedmacro runs automatically whenever
the selected event occurs.

1 Click Tools > Customize > Events.

2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

1.8 Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools >
Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.
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Figure 1.3 The Options Window

The settings categories that appear depend on the module you are working in. For ex-
ample, if you are in Writer, the OpenOffice.org Writer category appears in the list, but
the OpenOffice.org Calc category does not. The OpenOffice.org Base category appears
in both Calc and Writer. The Application column in the table shows where each setting
category is available.

The following table lists the settings categories along with a brief description of each
category:

Table 1.2 Global Setting Categories

ApplicationDescriptionSettings Category

AllVarious basic settings, including your user
data (such as your address and e-mail), impor-

OpenOffice.org

tant paths, and settings for printers and exter-
nal programs.

AllIncludes the settings related to the opening
and saving of several file types. There is a di-

Load/Save

alog for general settings and several special
dialogs to define how external formats should
be handled.

AllCovers the various settings related to lan-
guages and writing aids, such as your locale

Language Settings
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ApplicationDescriptionSettings Category

and spell checker settings. This is also the
place to enable support for Asian languages.

WriterConfigures the global word processing op-
tions, such as the basic fonts and layout that
Writer should use.

OpenOffice.org
Writer

WriterChanges the settings related to the HTML
authoring features of OpenOffice.org.

OpenOffice.org
Writer/Web

CalcChanges the settings for Calc, such as those
related to sorting lists and grids.

OpenOffice.org
Calc

ImpressChanges the settings that should apply to all
presentations. For example, you can specify

OpenOffice.org Im-
press

the measurement unit for the grid used to ar-
range elements.

DrawIncludes the settings related to the vector
drawing module, such as the drawing scale,
grid properties, and some print options.

OpenOffice.org
Draw

MathProvides a single dialog to set special print
options for formulas.

OpenOffice.org
Math

BaseProvides dialogs to set and edit connections
and registered databases.

OpenOffice.org
Base

AllDefines the default colors used for newly
created charts.

Charts

AllIncludes the dialogs to configure any proxies
and to change settings related to search en-
gines.

Internet

16 Application Guide



IMPORTANT: Settings Applied Globally

All settings listed in the table are applied globally for the specified applications.
They are used as defaults for every new document you create.

1.9 Using Templates
A template is a document containing only the styles—and content— that you want to
appear in every document of that type. When a document is created or opened with the
template, the styles are automatically applied to that document. Templates greatly en-
hance the use of OpenOffice.org by simplifying formatting tasks for a variety of different
types of documents. For example, in a word processor, you might write letters, memos,
and reports, all of which look different and require different styles. Or, for example,
for spreadsheets, you might want to use different cell styles or headings for certain
types of spreadsheets. If you use templates for each of your document types, the styles
you need for each document are always readily available.

OpenOffice.org comes with a set of predefined templates, and you can find additional
templates on the Internet. For details, see Section 1.11, “For More Information”
(page 19). If you want to create your own templates, this requires some up-front plan-
ning. You need to determine how you want the document to look so you can create the
styles you need in that template.

A detailed explanation of templates is beyond the scope of this section. Procedure 1.6,
“Creating OpenOffice.org Templates” (page 17) only shows how to generate a template
from an existing document.

Procedure 1.6 Creating OpenOffice.org Templates

For text documents, spreadsheets, presentations, and drawings, you can easily create
a template from an existing document as follows:

1 Start OpenOffice.org and open or create a document that contains the styles and
content that you want to re-use for other documents of that type.

2 Click File > Templates > Save.

3 Specify a name for the template.
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4 In the Categories box, click the category you want to place the template in. The
category is the folder where the template is stored.

5 Click OK.

NOTE: Converting Former Microsoft Word Templates

You can convert Microsoft Word templates like you would create any other
Word document. See Section 1.4.1, “Converting Documents to the OpenOf-
fice.org Format” (page 9) for information.

1.10 Setting Metadata and Properties
When exchanging documents with other people, it is sometimes useful to store metadata
like the owner of the file, received from, an URL, or other useful data. OpenOffice.org
lets you save these metadata which can be attached to your file. This helps you track
metadata which should or can not be saved in your file. It is also useful for sorting,
searching and retrieving your documents based on the metadata that you have inserted
before.

As an example, we assume you want to set these properties to your file:

• A title, subject, and some keywords

• An owner of your file

• When it was received from

To attach these metadata to your document, proceed as follows:

Procedure 1.7 Setting Properties

1 Click File > Properties. A dialog box opens with the following tabs:

General
This is a more overview tab where you can see the type, its location, size,
when it was created and modified and other useful information. If you have
a digital signature, it is also possible to digitally sign your document.
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Description
Insert your title, subject, keywords and comments as you like.

Custom Properties
Custom properties specify the editor, owner, publisher, received from, and
other useful metadata.

Internet
Determine if your document needs a refresh from the Internet.

Statistics
Contains an overview about your documents. Usually it lists the number of
pages, tables, graphics, and others depending on the type of your document.

2 Change to the Description tab and insert title, subject, and your keywords.

3 Switch to the Custom Properties tab.

4 Click Add. In the properties list a new entry is created.

5 Click on the pull-down menu of the first entry in the Name row. A list of proper-
ties appears.

6 Choose the Owner and insert your text in the Value row.

7 Repeat the previous step with the Received from property and a suitable value.

8 Leave the dialog box with OK.

9 Save your file.

1.11 For More Information
OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. The following lists shows some of the places where you can
go for additional information.

OpenOffice.org Online Help Menu
Extensive help on performing any task in OpenOffice.org.
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http://support.openoffice.org/index.html
Official OpenOffice.org support page. provides manuals, tutorials, user and devel-
oper forums, users@openoffice.org mailing list, Frequently Asked Questions, and
much more

http://documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf

OpenOffice.org Migration Guide. Provides information about migrating to
OpenOffice.org from other office suites, including Microsoft Office.

http://www.taming-openoffice-org.com/
Taming OpenOffice.org: books, news, tips and tricks.

http://www.pitonyak.org/oo.php
Extensive information about creating and using macros.

http://documentation.openoffice.org/Samples_Templates/User/
template_2_x/index.html

The OpenOffice.org documentation Web site provides templates for Writer, Calc,
Impress, and Draw. Including thesis templates, Curriculum Vitae or templates for
CD cases, fax cover sheets, and much more.

http://www.worldlabel.com/Pages/openoffice-template.htm
Various templates for creating labels with OpenOffice.org.

http://documentation.openoffice.org/HOW_TO/index.html
Detailed HOWTOs for various OpenOffice.org tasks, including how to create and
use templates.
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2OpenOffice.org Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces of other major word processors, and it
includes some features that are usually found only in expensive desktop publishing
applications.

This chapter highlights a few key features of Writer. For more information about these
features and for complete instructions for usingWriter, look at the OpenOffice.org help
or at the sources listed in Section 1.11, “For More Information” (page 19).

Much of the information in this chapter can also be applied to other OpenOffice.org
modules. For example, other modules use styles similarly to how they are used in
Writer.

2.1 Creating a New Document
There are three ways to create a new Writer document.

• From Scratch To create a document from scratch, click File > New > Text
Document and a new empty Writer document is created.

• Wizard To use a standard format and predefined elements for your own docu-
ments use a wizard. Click File >Wizards > Letter... and follow the steps.
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• Templates To use a template, click File > New > Templates and Documents
and choose one of themany folders (for example,Business Correspondence)
and a new document based on the style of your selected template is created.

For example, to create a business letter, click File >Wizards > Letter. Using the wizard's
dialogs, easily creates a basic document using a standard format. A sample wizard dialog
is shown in Figure 2.1.

Figure 2.1 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.

2.2 Sharing Documents with Other
Word Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
aWord document. MostWord documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents (such as documents containing complicated
tables, Word macros, or unusual fonts or formatting) might require some editing after
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being imported. OpenOffice.org can also save inmany popular word processing formats.
Likewise, documents created in OpenOffice.org and saved asWord files can be opened
in Microsoft Word.

This means if you use OpenOffice.org in an environment where you frequently share
documents with Word users, you should have little or no trouble exchanging document
files. Just open the files, edit them, and save them as Word files.

2.3 Formatting with Styles
Using styles, rather than any direct formatting has the following advantages:

• Gives your pages, paragraphs, texts, and lists a more consistent look.

• Easier to change your formatting later.

• Reuse and load styles from another document.

• Change one style and its properties are passed on to its descendants.

For example, if you emphasize text by selecting it and clicking the Bold button, but
later decide you want the emphasized text to be italicized, you would need to find all
bolded text and manually change it to italics. Whereas, if you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that same style automatically changes from bold to italics.

OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 2.1 About the Types of Styles

What it DoesType of Style

Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph

Paragraph

style to a first-level heading to set the font and font size,
spacing above and below the heading, location of the heading,
and other formatting specifications.
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What it DoesType of Style

Applies standardized formatting for types of text. For exam-
ple, if you want emphasized text to appear in italics, you can

Character

create an emphasis style that italicizes selected text when
you apply the style to it.

Applies standardized formatting to frames. For example, if
your document uses marginal note, you can create frames

Frame

with specified borders, location, and other formatting so that
all of your marginal notes have a consistent appearance.

Applies standardized formatting to a specified type of page.
For example, if every page of your document contains a

Page

header and footer except for the first page, you can use a first
page style that disables headers and footers. You can also
use different page styles for left and right pages so that you
have bigger margins on the insides of pages and your page
numbers appear on an outside corner.

Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes

List

and a bullet list with round bullets, then easily apply the
correct style when creating your lists.

Text that is formatted with a menu option or button overrides any styles you have ap-
plied. If you use the Bold button to format some text and an emphasis style to format
other text, then changing the style does not change the text that you formatted with the
button, even after applying the style to the text you bolded with the button. You must
manually disable bold in your text and then apply the style.

Likewise, if you manually format your paragraphs using Format > Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formattings. However,
if you apply paragraph styles, formatting remains consistent. If you change a style, the
change is automatically applied to all paragraphs formatted with that style.
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2.3.1 The Styles and Formatting Window
The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org) is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format > Styles and Formatting or press
F11.

Figure 2.2 Styles and Formatting Window

TIP: Docking And Undocking the Style and Formatting Window

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. To make
it appear always in the same part of the Writer interface, you can dock the
Styles and Formatting window. To do so, drag its title bar to the left or right
side of the main Writer window until a grey frame appears, then release the
mouse button to position it there. To undock the window and make it appear
as a floating window again, just drag its icon bar to a different place.

The docking/undocking mechanism applies to some other windows in
OpenOffice.org as well, including the Navigator.

OpenOffice.org comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles. Use the icons at the top of the window to display
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formatting styles for the most common elements like paragraphs, frames, pages or lists.
Go on with the instructions below, to learn more about styles.

2.3.2 Applying a Style
To apply a style, select the element you want to apply the style to, and double-click the
style in the Styles and Formattingwindow. For example, to apply a style to a paragraph,
place the cursor anywhere in that paragraph and double-click the desired paragraph
style.

2.3.3 Changing a Style
By changing styles you can change formatting throughout a document, rather than ap-
plying the change separately everywhere you want to apply the new formatting.

To change an existent style, proceed as follows:

1 In the Styles and Formatting window, right-click the style you want to change.

2 ClickModify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

2.3.4 Creating a Style
OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist and therefore, want to create
their own style:
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Procedure 2.1 General Approach for Creating a New Style

1 Open the Styles and Formatting window with Format > Styles and Formatting
or press F11.

2 Make sure you are in the list of styles for the type of style you want to create.

For example, if you are creating a character style, make sure you are in the
character style list by clicking the corresponding icon in the Styles and Formatting
window.

3 Right-click in any empty space in the Styles and Formatting window.

4 Click New and the style dialog box opens. The Organizer tab is preselected.

5 First configure the three most important entries:

Name
The name of your style. Insert any name you like.

Next Style
The style that follows your style. When you press Enter the selected style is
used.

Linked With
The style that your style depends on. If the selected style is changed, your
style changes as well. For example, if you want to make consistent headers
create a “parent” header style and subsequent headers depending on it. This
is useful as you just change the properties that need to be different, for exam-
ple, font size. Or choose to use None.

For details about the style options available in any tab, click that tab and then
click Help.

6 Confirm with OK to close the window.

Example: Defining a Note Style
Let us assume, you need a note with a different background and borders. To create this
styles, proceed as follows:
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Procedure 2.2 Creating a Note Style

1 Press F11. The Styles and Formatting window opens.

2 Make sure you are in the Paragraph Style list. The first icon (looks like ¶) must
be activated.

3 Right-click in any empty space in the Styles and Formatting window and select
New.

4 Enter the following parameters in the Organizer tab:

NoteName

NoteNext Style

- None -Linked with

Custom StylesCategory

5 Change the indentation in the Indents & Spacing tab, labeled with Before Text.
If you want more space above and below, change the values in the Above para-
graph and Below paragraph accordingly.

6 Switch to the Background tab and change the color of the background.

7 Switch to the Borders tab and determine your line arrangements, line style, color
and other parameters.

8 Confirm with OK to close the window.

9 Select your text in your document and double-click on the Note style. Your style
parameters are applied to the text.

Example: Defining an Even-Odd Page Style
If you print your documents, it is a good idea to create even and odd pages. To create
page styles for this, proceed as follows:
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Procedure 2.3 Create an Even (Left) Page Style

1 Press F11. The Styles and Formatting window opens.

2 Make sure you are in the Page Style list.

3 Right-click in any empty space in the Styles and Formatting window and select
New.

4 Enter the following parameters in the Organizer tab:

Left PageName

Leave that empty, it will be changed laterNext Style

not applicableLinked with

not applicableCategory

5 Change additional parameters as you like in the other tabs. Probably you would
like to adapt the page format and margins ( Page tab) or any headers and footers.

6 Confirm with OK to close the window.

Procedure 2.4 Create an Odd (Right) Page Style

1 Follow the instruction in Procedure 2.3, “Create an Even (Left) Page Style”
(page 29) but use the string Right Page in the Organizer tab.

2 Choose the entry Left Page from the Next Style pop-up menu.

3 Choose the same parameters as you did in the left page style. If you used different
sizes for the left and right margin of your even page, you have to adapt these
values in your odd pages as well.

4 Confirm with OK to close the window.

Then connect the left page style with the right page style:
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Procedure 2.5 Connect the Right Page Style with the Left Page Style

1 Right-click the Left Page entry and chooseModify....

2 Choose Right Page from the Next Style pop-up menu.

3 Confirm with OK to close the window.

To attach your style, make sure your page is a left (even) page and double-click Left
Page. Whenever your text exceeds the page limit, the text is automatically broken into
a right page and vice versa.

2.4 Working with Large Documents
You can useWriter to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

2.4.1 Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click View > Navigator or press F5. The elements listed in the
Navigator vary according to the document loaded in Writer.
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Figure 2.3 Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.

2.4.2 Using Master Documents
If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for multiple Writer
files. You can maintain chapters or other subdocuments as individual files collected in
the master document. Master documents are also useful if multiple users are working
on a single document. You can separate each user’s section of the document into sub-
documents collected in a master document, allowing multiple writers to work on their
subdocuments at the same time without fear of overwriting others' work.

Procedure 2.6 Creating a Master Document

1 Click New >Master Document.
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or

Open an existing document and click File > Send > Create Master Document.

2 Select Insert in the navigator window and hold the button.

3 Move the mouse to File and release the mouse button.

4 Select a file to add an existing file to the master document.

To create and add a new document to the master document, choose Insert > New Doc-
ument. The new file opens in another OpenOffice.org Writer window. The content of
the file will be integrated in the master document. To save the file as part of the master
document, switch back to the master, enter the filename into the open file menu and
click OK.

To enter some text directly into the master document, select Insert > Text.

The OpenOffice.org help files contain more complete information about working with
master documents. Look for the topic entitled Using Master Documents and Subdocu-
ments .

TIP: Styles and Templates in Master Documents

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory. However, if subdocuments are formatted differently, you might
need to do some reformatting to successfully bring subdocuments into the
master document without creating inconsistencies. For example, if two docu-
ments imported into your master document include different styles with the
same name, the master document will use the formatting specified for that
style in the first document you import.

2.5 Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
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a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

Procedure 2.7 Creating an HTML Document

1 Click File > New > HTML Document.

2 Press F11 to open the Styles and Formatting window.

3 Click the arrow at the bottom of the Styles and Formatting window.

4 Select HTML Styles.

5 Create your HTML document, using the styles to tag your text.

6 Click File > Save As.

7 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

8 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View > HTML Source. In
HTML Source mode, the Formatting and Styles list is not available.

The first time you switch to HTML Source mode, you are prompted to save the file as
HTML, if you have not already done so.

2.6 For More Information
http://wiki.services.openoffice.org/wiki/Documentation/OOo3
_User_Guides/Writer_Guide
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3OpenOffice.org Calc
Calc is the OpenOffice.org spreadsheet and data plotting module. Spreadsheets consist
of a number of sheets, containing cells which can be filled with elements like text,
numbers, or formulas. A formula can manipulate data from other cells to generate a
value for the cell in which it is inserted. Calc also allows you to define ranges, filter
and sort the data or creates charts from the data to present it graphically. By using
DataPilots, you can combine, analyze or compare larger amounts of data.

As with the entire OpenOffice.org suite, Calc can be used across a variety of platforms.
It provides a number of exchange formats (including export to PDF documents), and
can also read and save files inMicrosoft Excel's format. Its interoperability is constantly
ameliorated.

This chapter can only introduce some very basic Calc functionalities. For more infor-
mation and for complete instructions, look at the OpenOffice.org help or at the sources
listed in Section 1.11, “For More Information” (page 19).

NOTE: VBA Macros

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not yet complete. When opening an Excel spreadsheet that
makes heavy use of macros, you might discover that some do not work.

3.1 Creating a New Document
There are two ways to create a new Calc document:
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• From Scratch To create a document from scratch, click File > New > Spread-
sheet and a new empty Calc document is created.

• Templates To use a template, click File > New > Templates and Documents
and open Finances. You can see a list of Spreadsheet templates. Select the one that
fits your needs and your new document is created based on the style of your selected
template.

Access the individual sheets by clicking the respective tabs at the bottom of the window.

Enter data in the cells as desired. To adjust the appearance, either use the Formatting
toolbar or the Format menu—or define styles as described in Section 3.2, “Using For-
matting and Styles in Calc” (page 36) . Use the File menu or the relevant buttons in
the toolbar to print and save your document.

3.2 Using Formatting and Styles in
Calc

Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.

Procedure 3.1 Creating a Style

1 Click Format > Styles and Formatting.

2 In the Styles and Formatting window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Styles and Formatting window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.

5 Click OK.
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Procedure 3.2 Modifying a Style

1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then clickModify.

4 Change the desired formatting options.

5 Click OK.

To apply a style to specific cells, select the cells you want to format. Then double-click
the style you want to apply in the Styles and Formatting window.

3.3 Working With Sheets
Sheets are a good method to organize your calculations. For example, the accounting
for your business is much clearer if you create a sheet for each month.

To insert a new sheet in your spreadsheet, do the following:

Procedure 3.3 Inserting New Sheets

1 Select Insert > Sheet... from the main menu. A dialog box opens.

2 Decide whether the new sheet should be positioned before or after the selected
sheet.

3 If you want to create a new sheet, make sure the New Sheet radio button is acti-
vated. Enter the number of sheets and the sheet name. Skip the next step.

4 If you want to import a sheet from another file, do the following otherwise skip
this step:

4a Select From file and click Browse...
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4b Select the filename and confirm with OK. All the sheet names are now dis-
played in the list.

4c Select the sheet names you want to import by holding the Shift key.

4d Confirm with OK to import the sheet names you selected.

To rename a sheet, right-click a sheet in the sheet tab and select Rename Sheet.

To delete the current sheet, select Edit > Sheet > Delete... and confirm with Delete
Sheets. It is possible to delete more than one sheet by holding the Shift key and selecting
the sheets you want to delete in the sheet tab. Right-click and choose Delete Sheet and
the same dialog box appears. Confirm with Delete Sheets.

3.4 Conditional Formatting
Conditional formatting is a useful feature to highlight certain values in your spreadsheet.
For example, define a condition and if the condition is true, a style is applied to each
cell that fulfills this condition.

NOTE: Enable AutoCalculate

Before you apply conditional formatting, choose Tools > Cell Contents > Auto-
calculate. You should see a check mark in front of AutoCalculate.

Proceed as follows:

Procedure 3.4 Using Conditional Formatting

1 Define a style first. This style is applied to each cell when your condition is true.
Use Format > Styles and Formatting... or press F11. For more information, see
Procedure 3.1, “Creating a Style” (page 36). Confirm with OK.

2 Select the cell range where you want to apply your condition.

3 Select Format > Conditional Formatting... from the main menu. A dialog box
opens.
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4 Determine your condition. You can define up to three conditions. Each of the
three conditions can be enabled or disabled independently. A condition can operate
in “cell mode” or in “formula mode”:

Cell Mode
The condition is tested if it matches a certain cell value. Beside the first pull-
down menu, you can select the operator like equal to, less than, greater than,
and so forth.

Formular Mode
The condition is tested if a certain formular returns true.

5 Depending on the mode, enter:

5a Cell Mode Select the operator and the value of the cell.

5b Formular Mode Select the function which you want to test.

6 Choose the style you want to apply when this condition is true or click New
Style... to define a new appearance.

7 Repeat the previous steps, if you need additional conditions.

8 Confirm with OK.

Now the style of your cells has changed.

3.5 Grouping and Ungrouping Cells
Grouping a cell range helps to fold your spreadsheet into parts. This makes your
spreadsheets more readable as you can display only the parts you are currently interested
in. It is possible to group rows or columns and nest groups in other groups.

To group a range, proceed as follows:

Procedure 3.5 Grouping a Selected Cell Range

1 Select a cell range in your spreadsheet.
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2 Select Data > Group and Outline > Group.... A dialog box appears.

3 Decide if you want to group your selected range as row or as column. Confirm
with OK.

After grouping selected cells, a line indicating the grouped cell range appears in the
upper-left margin. Fold or unfold the cell range with the + and - icons. The numbers
in the margins display the depth of your groups and can be clicked too.

To ungroup a cell range, click into a cell which belongs to a group and select Data >
Group and Outline > Ungroup.... The line in the margin disappears.

3.6 Freezing Rows or Columns as
Headers

If you have a spreadsheet with lots of data, scrolling makes your header usually disap-
pear. OpenOffice.org locks rows or colums or both so it remains even if you scroll
around.

To freeze a single row or a single column, proceed as follows:

Procedure 3.6 Freezing a Single Row or Column

1 To freeze a row, click on the header of the row in the left strip.

To freeze a column, click on the header of the column. The header of the column
is the strip under the icon bar, labeled as A, B, C and so forth.

2 SelectWindow > Freeze. A dark line appears, indicating where the row or column
remains.

It is also possible to freeze both, rows and colums. Proceed as follows:

Procedure 3.7 Freezing Row and Column

1 Click into the cell to the right of the column and below the row you want frozen.
For example, if your header occupies the space from A1 to B3 then click into
cell C4.
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2 SelectWindow > Freeze. A dark line appears, indicating where the row or column
remains.

If you want to revert the freezing, selectWindow > Freeze and the check mark disap-
pears.

3.7 For More Information
http://wiki.services.openoffice.org/wiki/Documentation/OOo3
_User_Guides/Chapters
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4OpenOffice.org Impress, Base,
Draw, and Math
Besides OpenOffice.orgWriter and OpenOffice.org Calc, OpenOffice.org also includes
the modules Impress, Base, Draw, and Math. With these you can create presentations,
design databases, draw up graphics and diagrams, and create mathematical formulas.

4.1 Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations. This means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

4.1.1 Creating a Presentation
You can either create a new presentation from scratch (without any preformatted slides)
or use an existing template or presentation for your new document. Impress uses styles
and templates the same way other OpenOffice.org modules do. See Section 1.9, “Using
Templates” (page 17) for more information about templates. Awizard leads you through
the available options for creating new presentations.

1 Start OpenOffice.org Impress directly or in OpenOffice.org, click File > New >
Presentation.
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2 Select one of the options for creating a new presentation.

3 If you decide to create a presentation from a template, choose one of the templates
from the drop-down list and click Next.

4 From a variety of backgrounds and ready-made presentations, select a slide design.
To create your own design, select Original.

5 Select an output medium. The output medium is the form the final presentation
will take, such an overhead sheet, paper, or a screen slide show, among other
choices.

Select Preview for a thumbnail showing your choices. If all options are set ac-
cording to your wishes, click Next.

6 If you want to use effects for slide transitions, select the Effect you want to use
and specify the Speed.

7 Either use the default presentation type or chooseAutomatic to specify the amount
of time each page displays and the length of the pause between presentations.

8 If all options are set according to your wishes, click Create.

The presentation opens, ready for editing.
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4.1.2 Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:

Slide Master
Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

Notes Master
Determines the formatting and appearance of the notes in your presentation.

Creating a Slide Master
Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View >Master > Slide Master.

This opens the current slide master inMaster View.

3 Right-click the left-hand panel, then click New Master.

4 Edit the slide master until it has the desired look.

5 Click Close Master View or View > Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
to create presentations that use those slide masters, open a new presentation
with your template.
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Applying a Slide Master
Slide masters can be applied to selected slides or to all slides in the presentation.

1 Open your presentation, then click View >Master > Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides. Select the slides that you want that slide master applied to.

To select multiple slides, pressCtrl in the Slides Panewhile clicking on the slides
you want to use.

3 In the Tasks Pane, right-click the master page you want to apply.

If you do not see the Task Pane, click View > Task Pane.

4 Apply the slide master by clicking one of the following:

Apply to All Slides
Applies the selected slide master to all slides in the presentation.

Apply to Selected Slides
Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change toMaster View and apply a slide master to that slide.

4.2 Using Databases with Base
OpenOffice.org includes a database module: Base. Use Base to design a database to
store many different kinds of information, from a simple address book or recipe file to
a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or by using convenient
wizards. For example, the TableWizard contains a number of common fields for business
and personal use. Databases created in Base can be used as data sources, such as when
creating form letters.
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It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 1.11, “For More Information”
(page 19).

4.2.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. A
wizard guides you through the steps to create a new database. The steps in this section
are specific to creating an address book using predefined fields, but it should be easy
to follow them to use the predefined fields for any of the built-in database options.

The process for creating a database can be broken into several subprocesses:

1. Creating the Database (page 47)

2. Setting Up the Database Table (page 48)

3. Creating a Form (page 49)

4. Modifying the Form (page 50)

Creating the Database
1 Click File > New > Database.

2 Select Create a new database > Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules and select the check boxes to Open
the database for editing and Create tables using the table wizard. Then click
Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK. The Table Wizard window opens.
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Setting Up the Database Table
Next, in the Table Wizard window, define the fields you want to use in your database
table.

1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.

3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single arrow icon to move the selected items to the Selected fields
menu.

Tomove all available fields to the Selected fieldsmenu, click the double right-
arrow.

5 Use the ↑ and ↓ keys to adjust the order of the selected fields.

The fields appear in the table and forms in the order in which they are listed.

48 Application Guide



6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, maximum characters and whether it is
a required field. For this example, leave the settings as they are.

8 Click Next.

9 ClickCreate a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, selectCreate a form based on this table,
then click Finish. The Form Wizard window opens.

Creating a Form
Next, create the form to use when entering data into your address book.

1 In the FormWizard, click the double right-arrow icon to move all available fields
to the Fields in the form list, then click Next.

2 Select Add Subform if you want to add a subform, then click Next.

For this example, accept the default selections.

3 Select how you want to arrange your form, then click Next.
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4 Select The form is to display data and leave all of the check boxes empty, then
click Next.

5 Apply a style and field border, then click Next.

For this example, accept the default selections.

6 Name the form, select theModify the form option, then click Finish.

Modifying the Form
After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?
After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.

Refer to OpenOffice.org online help and other sources listed in Section 1.11, “ForMore
Information” (page 19) for additional information about Base.

4.3 Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
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import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

Procedure 4.1 Creating a Graphic

1 Press Alt + F2 and enter oodraw to open OpenOffice.org Draw.

2 Use the toolbar at the bottom of the window to create a graphic.

3 Save the graphic.

To embed an existing Draw graphic into an OpenOffice.org document, select Insert >
Object > OLE Object. Select Create from file and click Search to navigate to the Draw
file to insert. If you insert a file as OLE object, you can easily edit the object later by
double-clicking it.

Procedure 4.2 Opening Draw From Other OpenOffice.org Modules

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From anOpenOffice.org module (for example, fromWriter), click Insert >Object
> OLE Object > OpenOffice.org 3.x Drawing > OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.

4.4 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents. To
make this task easier, the OpenOffice.orgMath equation editor lets you create formulas
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using operators, functions, and formatting assistants. You can then save those forumlas
as an object that can be imported into other documents. Math functions can be inserted
into other OpenOffice.org documents like any other graphic object.

NOTE: Math is For Creating Mathematical Formulas

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

To create a formula proceed as follows:

1 Start OpenOffice.org.

2 Click File > New > Formula. The formula window opens.

3 Enter your formula in the lower part of the window. For example, the binomial
theorem in OpenOffice.org Math syntax is:
(a + b)^2 = a^2 + 2 a b + b^2

The result is displayed in the upper part of the window.

4 Use the Formula Elementswindow or right-click on the lower part of the window
to insert other terms. If you need symbols, use Tools >Catalog... to, for example,
insert Greek or other special characters.

5 Save your document.

The result is shown in Figure 4.1, “Mathematical Formula in OpenOffice.org Math”
(page 53):
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Figure 4.1 Mathematical Formula in OpenOffice.org Math

It is possible to include your formula in Writer, for example. To do so, proceed as fol-
lows:

1 Create a new Writer document or open an already existing one.

2 Select Insert >Object >OLE Object... in the main menu. The Insert OLE Object
window appears.

3 Select Create from file.

4 Click Search... to locate your formular. If needed, you can activate Link to file.

5 Confirm with OK and your formular is inserted at the current cursor position.

4.5 For More Information
• http://wiki.services.openoffice.org/wiki/Documentation/
OOo3_User_Guides/Impress_Guide

• http://wiki.services.openoffice.org/wiki/Documentation/
OOo3_User_Guides/Draw_Guide
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Management





5Kontact: E-Mailing and
Calendaring
Kontact combines the functionality of a number of KDE applications into a convenient,
single interface for personal informationmanagement. These applications include KMail
for email, KOrganizer for the calendar, KAddressBook for contacts, KNode for news-
groups, and KNotes for notes. Kontact integrates easily with the rest of the KDE desktop
and connects to a variety of groupware servers. It includes extra features such as journal
entries, Spam and virus filtering, and an RSS reader.

Start Kontact from the main menu. Alternatively, press Alt + F2 and enter kontact .
You can also open the individual components instead of the combined application if
you only need partial functionality.

5.1 Kontact Overview
The default window view is shown in Figure 5.1, “The Kontact Summary View”
(page 58). Use the icons in the left section to access the different components. The
Summary provides basic information, including upcoming birthdays, to-dos and the
number of new mail messages. The news section can access RSS feeds to provide up-
dated news of interest to you. Use Settings > Configure Summary View to configure
the information displayed.
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Figure 5.1 The Kontact Summary View

Mail
The folder area to the left contains a list of your mail folders (mail boxes) indicating
the total number of messages and the number of unread messages. To select a
folder, simply click it. The messages in that folder appear in the top right frame.
The number of messages in that folder is also shown in the status bar at the bottom
of the application window.

The subject, sender, and time of receipt of each message are listed in the header
area to the right. Click a message to select it and display it in the message window.
Sort the messages by clicking one of the column headers (subject, sender, date,
etc.). The contents of the currently selected message are displayed in the message
frame of the window. Attachments are depicted as icons at the end of the message,
based on the MIME type of the attachment, or they can be displayed inline.

Contacts
The upper left frame of this component shows all addresses in the currently-activated
address books. The lower left frame lists your address books and shows whether
they are currently active. The right frame shows the currently-selected contact. Use
the search bar at the top to find a particular contact.

Calendar
The calendar view is divided into a number of frames. By default, view a small
calendar of this month and a week view of the current week. Also find a list of to-
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dos, a detailed view of the current event or to-do, and a list of calendars with the
status of each. Select a different view from the toolbar or the View menu.

To-Do List
To-do List shows your list of tasks. Click the field at the top to add a new item to
the list. Right-click in the column of an existing item to make changes to the value
in that column. An item can be broken into several subitems. Right-click and select
New Sub-to-do to create a subitem. You can also assign to-dos to other people.

Journal
The Journal provides a place for your reflections, occurrences, or experiences.
Choose a date in the calendar frame and click Add Journal Entry to add a new entry.
If a journal entry already exists for the chosen date, edit it in the right frame.

Notes
Use the Notes component to keep sticky notes to yourself. If you are using KDE,
use the KNotes icon in the system tray to make your notes visible on the desktop.

Feeds
The Feeds window is divided into three frames—a tree view with RSS feeds on
the left, an article list on the top right, and the article view on the bottom right side.
Click a feed in the tree view to display it. Right-click a feed to update, edit, or
delete it. Right-click a folder in the tree view to open a menu where you can add a
new feed or manipulate existing feeds within.

5.2 Mail
Kontact uses KMail as its email component. You can also start it separately with the
command kmail. To configure it, open the mail component then select Settings >
Configure KMail. KMail is a fully-featured email client that supports a number of
protocols.
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Figure 5.2 The Kontact Mail Component

5.2.1 Configuring Identities
KMail can manage multiple email accounts (private or business). Creating separate
identities for your different email accounts allows you to associate different sender ad-
dresses, cryptography settings and signatures with each of them. To create an identity,
select Settings > Configure KMail and choose Identities > Add. Determine whether to
create a new identity from scratch, use the control center settings , or whether to duplicate
an existing identity.

To create a new identity from scratch, enter the name of the new identity and enter your
name, organization and email address in the General tab. You can also configure one
or several of the following options:

Cryptography
Set the keys to use for signing and encrypting messages. For the encryption to
work, first create a key with KGpg, as described in Chapter 9, KGpg: Signing and
Encrypting Data (page 105).
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Advanced
Enter a default reply-to and a default blind carbon-copy address, (usually empty),
choose a dictionary, select the folders for draft, sent messages, and templates, and
define by which sending account the messages should be sent.

Templates
Define custom templates to use for new messages, for default replies to senders
and lists, and for forwarded messages. To use templates, activate Use Custom
Message Templates, first.

Signature
Click Enable Signature first to use it. Decide how your messages should be signed.
Use the input field below to configure your signature or obtain it from a file or the
output of a command.

Picture
Use this tab to include a picture in the X-Face format in your messages. X-Face
can only hold black and white images with a dimension of 48 × 48 pixels. You can
obtain the picture from the input field below or from an external source.

5.2.2 Creating Accounts
Before you can send or receive emails, create one or several accounts. KMail allows
both remote accounts and local mailboxes. The settings under Accounts determine how
Kontact receives and sends email. Many of these settings vary depending on the system
and network in which your mail server is located. If you are not sure about the settings
or items to select, consult your ISP or system administrator.

To configure a remote account, proceed as follows:

1 Start Kontact and select Settings > Configure KMail > Accounts.

2 Create an incoming account by clicking on the Receiving tab:

2a ClickAdd and choose the account type. Usually it is POP3, IMAP, or discon-
nected IMAP.

2b Enter your account name (can be freely choosen), the incoming mail server,
login and password.
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2c Decide, if the following options are useful to your setup:

General > Store POP password
If you use KWallet, check Store POP password. This makes it a bit more
convenient as you do not have to type in your passwords (it is taken
once from KWallet, see Chapter 8, Managing Passwords with KWallet
Manager (↑KDE User Guide).)

General > Enable interval mail checking
If you need to be up-to-date with your mails, check this option and enter
the interval.

Advanced > Leave fetched messages on the server (POP3 only)
KMail can leave the original message on the server and receive a copy.
Especially for POP3 accounts, this could be useful, if you need the mail
on a different computer.

Advanced > Use default identity (IMAP/disconnected IMAP only)
This option lets you choose your identity.

2d Proceed with OK.

3 Create an outgoing account by clicking on the Sending tab and click Add to
choose either SMTP or Sendmail:

• If you select SMTP (the default), enter an account name and the host name
of the SMTP server. Should the server require login and password, also check
Server requires authentication and enter the required credentials. Configure
additional security settings using the Security tab.

• If you select Sendmail, no further configuration is required.

4 Apply your settings and leave the account configuration dialog with OK.

To configure a local mailbox, proceed as follows:

1 Start Kontact and select Settings > Configure KMail > Accounts.
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2 Create an incoming account by clicking on the Receiving tab:

2a Click Add and choose Local mailbox or Maildir mailbox.

2b Enter your account name. Choose any name you like.

2c Decide which lockingmethod youwant. Usually you can leave it onProcmail
lockfile

2d Proceed with Ok.

3 Create an outgoing account as described in Step 3 (page 62).

5.2.3 Composing Messages
To compose new messages, selectMessage > New Message or click the corresponding
icon in the toolbar. To send messages from different email accounts, select one of the
identities as described in Section 5.2.1, “Configuring Identities” (page 60). Select View
> Identity to show a popup menu. In To, enter an email address or part of a name or
address in your address book. If Kontact can match what you enter to something in the
address book, a selection list opens. Click the desired contact or complete your input
if none matches. To select directly from the address book, click the Select... button next
to the Address field.

To attach files to your message, click the paper clip icon and select the file to attach.
Conversely, drag a file from the desktop or another folder to the NewMessagewindow
or select one of the options in the Attachmenu. Normally, the format of a file is recog-
nized correctly. If the format is not recognized, right-click the icon. From the menu
that appears, select Properties. Set the format and filename in the next dialog and add
a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, send it immediately withMessage >
Send or move it to the outbox withMessage > Send Later. If you send the email, the
message is copied to sent-mail after having been sent successfully. Messages moved
to the outbox can be edited or deleted.
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5.2.4 Managing Folders
Message folders help organize your messages. By default, they are located in the ~/
.kde4/share/apps/kmail/mail directory. When starting KMail for the first
time, the program creates several folders. If you are using IMAP, the IMAP folders are
listed below the local folders. Each incoming mail server has its folders in the Folder
list.

If you want to organize your messages in additional folders, select from your list your
parent folder and create new folders by selecting Folder > New Folder. This opens a
window in which to specify the name and format of the new folder.

Right-click the folder for a context menu offering several folder operations. Click Expire
to specify the expiration date for read and unread messages, what should happen with
them after expiration, and whether expired messages should be deleted or moved to a
folder. If you intend to use the folder to store messages from a mailing list, set the
necessary options under Folder >Mailing List Management.

To move one or several messages from one folder to another, drag them from the upper
window and drop them into the appropriate folder in the left window. Messages can
also be moved by highlighting the messages then pressing M or selectingMessage >
Move to. In the list of folders that appears, select the folder to which to move your
messages.

Additionally, you can add folders to the Favorite Folders pane. This enables you to go
quickly to your frequently used mail folders, especially if your folders are deeply
structured. Choose the relevant folder and select Add to Favorite Folders.

5.2.5 Signing and Encrypting emails
Email is an insecure medium, as anyone could theoretically read your emails or send
some in your name. By signing your emails you enable the recipient of your emails to
verify the sender of the messages as the key used to sign is only available to you. By
encrypting the contents of your emails you ensure that they can only be read by the re-
cipient. KMail supports both the signing and encryption of emails.

Prepare KMail for signing and encrypting emails:
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1 Generate a key pair as described in Section 9.2, “Generating a New Key Pair”
(page 106) and export your public key as described in Section 9.3, “Exporting
the Public Key” (page 109).

2 Configure the details of the encryption procedure in KMail:

2a Start KMail and go to Settings > Configure KMail > Identities.

2b Select the identity under which to send encrypted and signedmessages. Click
Modify... and proceed to Cryptography.

2c Change the OpenPGP signing key by clicking on Change... and selecting
your key from the dialog box.

2d Change theOpenPGP encryption key by clicking onChange... and selecting
your key from the dialog box.

3 Change to Security >Composing and checkWhen encrypting emails, always also
encrypt to the certificate of my own identify. With this option you can decrypt
the message or file at any time.

4 Apply your settings and leave the configuration dialog with OK.

Sending Signed Mails
Sign your emails to allow the recipient to verify whether these have really been sent
by you. KMail uses your private key to sign your messages and the recipient can verify
the signature using your public key available on key servers. To sign an email, proceed
as follows:

1 Compose your email as usual.

2 Select Options > Sign Message.

3 If you know the recipient can download your public key from a key server, you
can omit this step. For convenience reasons, select Attach > Attach My Public
Key to create an attachment to your email containing your public key.
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4 Send your message as usual viaMessage > Send Mail and enter your key's
passphrase when prompted. KMail signs your message using your private key
and the recipient can verify the signature by the public key attached to your
message.

Sending Encrypted Mails
Use encryption on your emails whenever you want to make sure that only the recipient
can read the contents. To be able to exchange encrypted emails with another party, get
the appropriate public key and use it to encrypt your message. At the other end, the
private key is then used to decrypt the contents of your message. Of course, you can
use both signatures and encryption on your messages.

To send an encrypted email, proceed as follows:

1 Start KGpg with Alt + F2 and entering kgpg.

2 Get the recipient's public key:

• If you get it directly from the recipient, import the key with KGpg via Keys
> Import Key.

• Access a public key server and import it from there. Select in KGpg File >
Key Server Dialog, and search for the key. Select the respective key and
import it into your keyring.

3 Compose a new message in KMail.

4 Select Options > Encrypt Message. In the mail window a blue lineMessage will
be encrypted is displayed.

5 Send the mail. A dialog window opens and asks you for the correct key.

6 Check whether all keys are correct.

7 Enter your passphrase.
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5.2.6 Importing Email from Other Mail
Programs

To import email from other applications, select File > Import Messages from the mail
view in Kontact. It currently features import filters for Outlook Express, the mbox for-
mat, email text format, Pegasus Mail, Opera, Evolution, and more. The import utility
can also be started separately with the command kmailcvt.

Select the corresponding application and confirmwithContinue. A file or a folder must
be provided, depending on the selected type. KMail then completes the process.

5.2.7 Filters
Filters are a convenient method of automatically processing incoming mail. They use
aspects of the mail such as sender or size, to move mail to certain folders, delete unwant-
ed mails, bounce mails back to the sender, or perform a number of other actions.

Setting Up a Filter
To create a filter based on an existing message, right-click the desired message then
select Create Filter and the desired filter criteria. To create a filter from scratch, select
Settings > Configure Filters.

Select the match method for filter criteria (all or any). Then select criteria that applies
only to the desired messages. In Filter Actions, set what the filter should do to the
messages that meet the criteria. The Advanced tab provides control over whether the
filter is applied for specific accounts only.

Applying Filters
Filters are applied in the order listed in the dialog accessed with Settings > Configure
Filters. Change the order by selecting a filter and clicking the arrow buttons. Filters
are only applied to new incoming messages or sent messages as specified in the filter's
advanced options. To apply filters to existing messages, right-click the desired messages
and chooseMessages > Apply Filter and the desired filter.
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If your filters do not act as expected, monitor them with Tools > Filter Log Viewer.
When logging is enabled in this dialog, it shows how messages are processed by your
filters and can help locate the problem.

5.3 Contacts
The contacts component uses KAddressBook. You can also start it separately with the
command kaddressbook. Configure it with Settings > Configure KAddressBook.
To search for a particular contact, use the search bar. With Filter, select to display only
contacts in a certain category. Right-click a contact to open a menu in which to select
from a variety of options, such as sending the contact information in an email.

Figure 5.3 The Kontact Address Book

5.3.1 Adding Contacts
To add a contact with the name and email address from an email, right-click the address
in the mail component and select Open in Address Book. To add a new contact without
using an email, select File > New Contact in the address component. Both methods
open a dialog in which to enter information about the contact.

In theGeneral tab, enter basic contact information, such as name, email addresses, and
telephone numbers. Categories can be used to sort addresses. Details contains more
specific information, such as birthday and spouse's name.
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If your contact uses an instant messenger, you can add these identities in IM Addresses.
If you do this and have Kopete or another KDE chat program running at the same time
as Kontact, view status information about these identities in Kontact. InCrypto Settings,
enter the contact's encryption data, such as public key.

Misc has additional information, such as a photograph and the location of the user's
Free/Busy information. Use Custom Fields to add your own information to the contact
or address book.

Contacts can also be imported in a variety of formats. Use File > Import and select the
desired format. Then select the file to import.

5.3.2 Creating a Distribution List
If you frequently send email messages to the same group of people, a distribution list
enables you to store multiple email addresses as a single contact item so that you do
not need to enter each name individually in every email you send to that group. To
create a distribution list, proceed as follows:

1 Click Settings > Show Extension Bar > Distribution List Editor. A new section
appears.

2 Click New List.

3 Enter a name for the list and click OK.

4 Add contacts to the list by dragging them from the address list and dropping them
in the distribution list window.

5 Use this list like you would an individual contact when creating an email.

5.3.3 Adding Address Books
IMPORTANT: Groupware Address Books

The best way to add groupware resources is with the Groupware Wizard, a
separate tool. To use it, close Kontact then run groupwarewizard in a
command line or from the Office group of the KDE menu. Select the server
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type (such as SLOX, GroupWise, or Exchange) from the list offered, then enter
the address and authentication data. The wizard then adds the available re-
sources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell
GroupWise or an LDAP server. Select View > Address Books to view the current address
books. Press Add to add one then select the type and enter the required information.

The check boxes in front of the address books show the activation status of each address
book. To prevent the display of a book without deleting it, uncheck it. Remove deletes
the selected book from the list.

5.4 Calendar
Kontact uses KOrganizer as its calendar component. You can also start it separately
with the command korganizer. To configure it, use Settings > Configure Calendar.
With the calendar, enter appointments and schedule meetings with others. If desired,
you can be reminded of upcoming events. You can also import, export, and archive
calendars with the options from the File menu.

Figure 5.4 The Kontact Calendar
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5.4.1 Scheduling an Event
Add a new event or meeting with Actions >New Event. Enter the desired details. Under
Reminder, specify the exact time (minutes, hours, or days in advance) that the attendees
should be reminded of the event. If an event recurs, specify the appropriate interval.
Another way to create an event at a specific point in the calendar is to double-click the
corresponding field in one of the program's calendar views. This opens the same dialog
window as that available from the menu. Alternatively, select a time range in the Cal-
endar view and right-click.

Specify the attendees of an event by entering their data manually in the dialog or by
inserting data from the address book. To enter data manually, select New. To import
data from the address book, click Select Addressee then select the corresponding entries
from the dialog. To schedule the event based on the participants' availability, go to
Free/Busy and click Pick Date.

Use the Recurrence tab to configure an event that happens on a regular basis. Attach-
ments can be convenient for linking other information with the event, such as an agenda
for a meeting.

5.4.2 Adding Calendars
IMPORTANT: Groupware Calendars

The best way to add groupware resources is with Groupware Wizard, a separate
tool. To use it, close Kontact then run groupwarewizard in a command line
or from the Office group of the KDE menu. Select the server type (such as
SLOX, GroupWise, or Exchange) from the list offered then enter the address
and authentication data. The wizard adds the available resources to Kontact.

The calendar module can connect to multiple calendars simultaneously. This is useful
for combining a personal calendar with an organizational one. To add a new calendar,
click Add then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To prevent
the display of a calendar without deleting it, uncheck it. Remove deletes the selected
calendar from the list.
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5.5 Kontact for GroupWise Users
If you are used to working in GroupWise, you should have very little trouble adjusting
to Kontact. The two programs share many features and provide many of the same ser-
vices. This section discusses notable terminology differences, as well as some tips to
help GroupWise users make the most of Kontact.

Table 5.1 Kontact and GroupWise Terminology Differences

KontactGroupWise

EventsAppointments

Free/BusyBusy search

Journal entriesNotes

An event without attendees is posted. If an
event has attendees, it is a Sent item.

Posted, nonposted items

To-dosTasks

5.5.1 Accessing GroupWise Mail Account
Accessing your GroupWise server is not very different from accessing an IMAP or
POP3 server. Proceed as follows:

1 Start Kontact and select the mail component (KMail).

2 Choose Settings > Configure KMail from the menu.

3 Select Accounts.

4 Create an new account with Add.

5 Choose your account type. In most cases your GroupWise account is IMAP.

6 Enter your login, password and hostname and proceed with OK.
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5.5.2 Accessing GroupWise Calendar
To access your GroupWise calendar through Kontact, proceed as follows:

1 Start Kontact and open the calendar view (KOrganizer).

2 Click on Add. You find this button on the lower left corner.

3 Choose Novell GroupWise Server and proceed with OK.

4 Enter your name, URL, user and password. The URL is your GroupWise server,
for example https://groupwise.example.com:7191/soap.

5 Apply your settings with OK and leave the configuration dialog. The calendar
view now includes your GroupWise calendar entries.

5.5.3 Tips for GroupWise Users
This section contains hints to help GroupWise users work with some of the differences
between GroupWise and Kontact:

Contact Information
You can add your GroupWiseMessenger and email contacts to your Kontact contact
information. Then you can create an email or open an instant messaging session
with that contact by right-clicking the name in the Contact view.

Color Coding
It is helpful to color code GroupWise items, as well as items from other sources.
Color coding makes it easy to scan your emails, contacts, and other information
for items from a particular source.

Inviting Attendees to Events
Unlike GroupWise, Kontact does not automatically enter you as an attendee for
events you schedule. Make sure that you remember to invite yourself.
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5.6 For More Information
Kontact includes help for itself and its various components. Access it with Help >
Kontact Handbook. The project's Web page, http://www.kontact.org, is also
informative.
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6Evolution: E-Mailing and
Calendaring
Evolution™makes the tasks of storing, organizing, and retrieving your personal infor-
mation easy, so you can work and communicate more effectively with others. It is a
highly evolved groupware program and an integral part of the Internet-connected
desktop.

Evolution can help you work in a group by handling e-mail, addresses, and other contact
information, and one or more calendars. It can do that on one or several computers,
connected directly or over a network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks. For example, it
takes only one or two clicks to enter appointment or contact information sent to you by
e-mail, or to send e-mail to a contact or appointment. People who get lots of e-mail will
appreciate advanced features like search folders, which let you save searches as though
they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started. For more details,
refer to the Evolution documentation.

• Section 6.1, “Starting Evolution for the First Time” (page 76)

• Section 6.2, “Using Evolution: An Overview” (page 86)
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6.1 Starting Evolution for the First
Time

To start the Evolution client click Computer > Evolution, or type evolution in a
terminal window.

6.1.1 Setup Assistant
The first time you run Evolution, it creates a directory called .evolution in your
home directory, where all the local data is stored. Then, it opens a setup assistant to
help you set up e-mail accounts and import data from other applications.

If you want to change your account, or if you want to create a new one, click Edit >
Preferences, then clickMail Accounts. Select the account you want to change, then
click Edit. To add a new account click Add.

The Setup Assistant helps you to provide all the required information.

Defining Your Identity
The Identity Window is the first step in the assistant.

When the First-Run Assistant starts, the Welcome page is displayed. Click Forward to
proceed to theRestore from Backupwindow. If you previously backed up your Evolution
configuration and wish to restore it in this new installation, it is the right time to do so:
check Restore Evolution from the Backup File and select the backup file in the file
chooser dialog. Or click Forward and proceed to the Identity Window.

1 Type your full name in the Full Name field.

2 Type your e-mail address in the E-mail Address field.

3 (Optional) Select if this account is your default account.

4 (Optional) Type a reply to address in the Reply-To field.

Use this field if you want replies to e-mails sent to a different address.
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5 (Optional) Type your organization name in the Organization field.

This is the company where you work, or the organization you represent when
you send e-mails.

6 Click Forward.

Receiving Mail
The Receiving E-mail option lets you determine the server where you want to receive
your e-mail.

You need to specify the type of server you want to receive mail from. If you are not
sure about the type of server, contact your system administrator or Internet Service
Provider (ISP).

• Select a server type in the Server Type list.

The following is a list of available server types:

Novell GroupWise: Select this option if you want to connect to Novell®
GroupWise®. Novell GroupWise keeps e-mail, calendar, and contact information
on the server.

Microsoft Exchange: Available only if you have installed the connector for
Microsoft* Exchange. You can connect to a Microsoft Exchange 2000, 2003 or
2007 server, which stores e-mail, calendar, and contact information on the server.

IMAP: Keeps the e-mail on your server so you can access your e-mail from
multiple systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing
up space on the e-mail server.

Hula: Hula project offers managing of your e-mails and calendars stored on
the server, and adds a search facility for all your data saved there.

ExchangeMAPI: Select this option if you want to accessMicrosoft Exchange
server through MAPI (Messaging Application Program Interface) interface. It is
designed to enable applications (usually word processors or spreadsheets) to
communicate directly with the Exchange server.
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USENETNews: Connects to the news server and downloads a list of available
news digests.

Local Delivery: If you want to move e-mail from the spool and store it in
your home directory, you need to provide the path to the mail spool you want to
use. If you want to leave mail in your system’s spool files, choose the Standard
Unix Mbox Spool option instead.

MH Format Mail Directories: If you want to download your e-mail using
mh or another MH-style program, you need to provide the path to the mail direc-
tory you want to use.

Maildir FormatMail Directories: If you download your e-mail using Qmail
or another maildir-style program, you should use this option. You need to provide
the path to the mail directory you want to use.

Standard Unix Mbox Spool or Directory: If you want to read and store e-
mail in the mail spool on your local system, choose this option. You need to
provide the path to the mail spool you want to use.

None: If you do not plan to check e-mail with this account, select this option.
There are no configuration options.

Remote Configuration Options

If you have selected Novell GroupWise, IMAP, POP, or USENETNews as your server,
you need to specify additional information.

1 Type the hostname of your e-mail server in the Server field.

If you are not sure about the hostname, contact your system administrator.

2 Type your username for the account in the Username field.

3 Select a secure (SSL) connection.

If your server supports secure connections, enable this security option. If you are
not sure about secure connections, contact your system administrator.

4 Select your authentication type in the Authentication list. clickCheck for Support-
ed Types to have Evolution check for supported types. Some servers do not an-
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nounce the authentication mechanisms they support, so clicking this button is
not a guarantee that available mechanisms actually work.

If you are not sure about the required server type, contact your system adminis-
trator.

5 Select if you want Evolution to remember your password.

6 Click Forward.

7 (Conditional) If you chose Microsoft Exchange, provide your username in the
Username field and your Outlook Web Access (OWA) URL in the OWA Url
field. OWA URL and user names should be entered as in OWA. If the mailbox
path is different from the username, the OWA path should include the mailbox
path also. You should see something similar to this: http://<server name>/ex-
change/<mail box path>

Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail
Directories, or Standard Unix Mbox Spool or Directory, you must specify the path to
the local files in the path field.

Receiving Mail Options
After you have selected a mail delivery mechanism, you can set some preferences for
its behavior.

• Section “Novell GroupWise Receiving Options” (page 80)

• Section “Microsoft Exchange Receiving Options” (page 80)

• Section “IMAP Receiving Options” (page 81)

• Section “POP Receiving Options” (page 82)

• Section “USENET News Receiving Options” (page 83)

• Section “Local Delivery Receiving Options” (page 83)

• Section “MH-Format Mail Directories Receiving Options” (page 83)
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• Section “Maildir-Format Mail Directories Receiving Options” (page 84)

• Section “Standard Unix Mbox Spool or Directory Receiving Options” (page 84)

• Section “Hula Receiving Options” (page 84)

Novell GroupWise Receiving Options

If you select Novell GroupWise as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want to apply filters to new messages in the inbox on the server.

4 Select if you want to check new messages for junk content.

5 Select if you want to only check for junk messages in the inbox folder.

6 Select if you want to automatically synchronize remote mail locally.

7 Type your Post Office Agent SOAP port in the Post Office Agent SOAP Port
field.

If you are not sure what your Post Office Agent SOAP port is, contact your system
administrator.

8 Click Forward.

Microsoft Exchange Receiving Options

If you select Microsoft Exchange as your receiving server type, you need to specify the
following options.

1 Select if you want Evolution to automatically check for new mail.
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If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want the password expire warning period.

If you select this option, you need to specify how often Evolution should send
the password expire message.

4 Select if you want to automatically synchronize remote mail locally.

5 Select if you want to apply filters to new messages in the inbox on the server.

6 Select if you want to check new messages for junk content.

7 Select if you want to only check for junk messages in the inbox folder.

8 Specify the Global Catalog server name in the Global Catalog Server Name
field.

The Global Catalog Server contains the user information for users. If you are
not sure what your Global Catalog server name is, contact your system admin-
istrator.

9 Select if you want to limit the number of Global Address Lists (GAL).

The GAL contains a list of all e-mail addresses. If you select this option, you
need to specify the maximum number of responses.

10 Click Forward.

IMAP Receiving Options

If you select IMAP as your receiving server type, you need to specify the following
options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.
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2 Select if you want to check for new messages in all folders.

3 Select if you want to check for new messages in subscribed folders.

4 Select if you want Evolution to use custom commands to connect to Evolution.

If you select this option, specify the custom command you want Evolution to
use.

5 Select if you want Evolution to show only subscribed folders.

Subscribed folders are folders that you have chosen to receive mail from by
subscribing to them.

6 Select if you want Evolution to override server-supplied folder namespaces.

By choosing this option you can rename the folders that the server provides.
If you select this option, you need to specify the namespace to use.

7 Select if you want to apply filters to new messages in the inbox.

8 Select if you want to check new messages for junk content.

9 Select if you want to check for junk messages in the inbox folder.

10 Select if you want to automatically synchronize remote mail locally.

11 Click Forward.

POP Receiving Options

If you select POP as your receiving server type, you need to specify the following op-
tions:

1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to leave messages on the server.

3 Select if you want to delete messages after specified number of days.

82 Application Guide



4 Select if you want to disable support for all POP3 extensions.

5 Click Forward.

USENET News Receiving Options

If you select USENET News as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to show folders in short notation.

For example, comp.os.linux would appear as c.o.linux.

3 Select if you want to show relative folder names in the subscription dialog box.

If you select to show relative folder names in the subscription page, only the
name of the folder is displayed. For example the folder evolution.mail would
appear as evolution.

4 Click Forward.

Local Delivery Receiving Options

If you select Local Delivery as your receiving server type, you need to specify the fol-
lowing options:

1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Click Forward.

MH-Format Mail Directories Receiving Options

If you select MH-Format Mail Directories as your receiving server type, you need to
specify the following options:
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1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to use the .folders summary file.

3 Click Forward.

Maildir-Format Mail Directories Receiving Options

If you select Maildir-Format Mail Directories as your receiving server type, you need
to specify the following options:

1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the inbox.

3 Click Forward.

Standard Unix Mbox Spool or Directory Receiving Options

If you select Standard Unix Mbox Spool or Directory as your receiving server type,
you need to specify the following options:

1 Select if you want Evolution to automatically check for new mail. If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the inbox.

3 Select if you want to store status headers in Elm, Pine, and Mutt formats.

4 Click Forward.

Hula Receiving Options

If you select Hula as your receiving server type, you need to specify the following op-
tions:
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1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want Evolution to use custom commands to connect to Evolution.

If you select this option, specify the custom command you want Evolution to
use.

4 Select if you want Evolution to show only subscribed folders.

Subscribed folders are folders that you have chosen to receive mail from by
subscribing to them.

5 Select if you want Evolution to override server-supplied folder namespaces.

By choosing this option you can rename the folders that the server provides. If
you select this option, you need to specify the namespace to use.

6 Click Forward.

Sending Mail
Now that you have entered information about how you plan to get mail, Evolution needs
to know about how you want to send it.

• Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system.
Sendmail is more flexible, but is not as easy to configure, so you should select
this option only if you know how to set up a Sendmail service.

SMTP: Sends mail using a separate mail server. This is the most common
choice for sending mail. If you choose SMTP, there are additional configuration
options.
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SMTP Configuration

1 Type the host address in the Server field.

If you are not sure what your host address is, contact your system administrator.

2 Select if your server requires authentication.

If you selected that your server requires authentication, you need to provide the
following information:

2a Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported
types. Some servers do not announce the authentication mechanisms they
support, so clicking this button is not a guarantee that available mechanisms
actually work.

2b Type your username in the Username field.

2c Select if you want Evolution to remember your password.

3 Select if you use a secure connection (SSL or TLS).

4 Click Forward.

Account Management
Now that you have finished the e-mail configuration process you need to give the account
a name. The name can be any name you prefer. Type your account name on the Name
field, then click Forward.

6.2 Using Evolution: An Overview
Now that the first-run configuration has finished, you are ready to begin using Evolution.
Here is a quick explanation of what is happening in your main Evolution window.
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Figure 6.1 Evolution Window

Menu Bar
The menu bar gives you access to nearly all of Evolution features.

Folder List
The folder list gives you a list of the available folders for each account. To see the
contents of a folder, click the folder name. The contents are displayed in the e-mail list.

Toolbar
The toolbar gives you fast and easy access to the frequently used features in each
component.
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Search Tool
The search tool lets you search for e-mails either in the current account or in all accounts.
You can filter e-mails, contacts, calendar entries and tasks using different criteria. The
Search tool can also save frequently used searches to a search folder.

Message List
The message list displays a list of e-mails that you have received. The radio button
above the list lets you view massages according to predefined and custom labels. To
view an e-mail in the preview pane, select the e-mail.

Shortcut Bar
The shortcut bar lets you switch between folders. At the bottom of the shortcut bar there
are tool buttons that let you switch tools, and above that is a list of all the available
folders for the current tool. If you have the Evolution Connector forMicrosoft Exchange
installed, you have an Exchange button in addition to buttons for the other tools.

Status Bar
The status bar periodically displays a message, or tells you the progress of a task. This
most often happens when you are checking or sending e-mail. These progress queues
are shown in the previous figure. The Online/Offline indicator is here, too, in the lower
left of the window.

Preview Pane
The preview pane displays the contents of the e-mails that are selected in the e-mail
list.

88 Application Guide



6.2.1 The Menu Bar
The menu bar’s contents always provide all the possible actions for any given view of
your data. If you are looking at your Inbox, most of the menu items relate to e-mail.
Some content relates to other components of Evolution and some, especially those in
the File menu, relates to the application as a whole.

File: Anything related to a file or to the operations of the application usually falls
under this menu, such as creating things, saving them to disk, printing them, and quitting
the program itself.

Edit: Contains useful tools that help you edit text andmove it around. Lets you access
the settings and configuration options in the Edit menu.

View: Lets you decide how Evolution should look. Some of the features control the
appearance of Evolution as a whole, and others the way a particular kind of information
appears.

Folder: Contains actions that can be performed on folders. You can find things like
copy, rename, delete, etc.

Message: Contains actions that can be applied to a message. If there is only one
target for the action (such as replying to a message), you can normally find it in the
Message menu.

Search: Lets you search for messages, or phrases within a message. You can also
see previous searches you have made. In addition to the Search menu, there is a text
entry box in the toolbar that you can use to search for messages. You can also create a
search folder from a search.

Help: Opens the Evolution Help files.

6.2.2 The Shortcut Bar
Evolution’s most important task is to give you access to your information and help you
use it quickly. One way it does that is through the shortcut bar, which is the column on
the left side of the main window. The buttons, such as Mail and Contacts, are the
shortcuts. Above them is a list of folders for the selected Evolution tool.
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The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree,
similar to a file tree. Most people find one to four folders at the base of the tree, depend-
ing on the tool and their system configuration. Each Evolution tool has at least one,
called On This Computer, for local information. For example, the folder list for the e-
mail tool shows any remote e-mail storage you have set up, plus local folders and search
folders.

If you get large amounts of e-mail, you might want to create more folders than just your
Inbox. You can create multiple e-mail folders, address books, calendars, task lists, or
memo lists.

To create a new folder:

1 Click File > New >Mail Folder.

2 Type the name of the folder in the Folder Name field.

3 Select the location of the new folder.

4 Click Create.

Folder Management
Right-click a folder or subfolder to display a menu with the following options:

New Folder: Creates a new folder or subfolder in the same location.

Copy: Copies the folder to a different location.When you select this item, Evolution
offers a choice of locations to copy the folder to.

Move: Moves the folder to another location.

Delete: Deletes the folder and all contents.

Mark Messages As Read: Marks all the messages in the folder as read.

Rename: Lets you change the name of the folder.

Refresh: Refreshes the folder.

Disable: Disables the account.
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Properties: Checks the number of total and unread messages in a folder and, for
remote folders, lets you select whether to copy the folder to your local system for offline
operation.

You can also rearrange folders and messages by dragging and dropping them.

Any time new e-mail arrives in a e-mail folder, that folder label is displayed in bold
text, along with the number of new messages in that folder.

6.2.3 Email
Evolution e-mail is like other e-mail programs in several ways:

• It can send and receive e-mail in HTML or as plain text, and makes it easy to send
and receive multiple file attachments.

• It supports multiple e-mail sources, including IMAP, POP3, and local mbox or mh
spools and files created by other e-mail programs.

• It can sort and organize your e-mail in a wide variety of ways with folders,
searches, and filters.

• It lets you guard your privacy with encryption.

However, Evolution differs from other e-mail programs in some very essential ways.
First, it is built to handle very large amounts of e-mail. The junk e-mail, message filtering
and searching functions were built for speed and efficiency. There is also the search
folder, an advanced organizational feature not found in some e-mail clients. If you get
a lot of e-mail, or if you keep every message you get in case you need to refer to it later,
you will find this feature especially useful. Here is a quick explanation of what is hap-
pening in your main Evolution e-mail window. You can also run Evolution now in
Windows.

Message List
The message list displays all the e-mails that you have. This includes all your read and
unread messages and e-mail that is flagged to be deleted. With the Show radio button
above the message you can filter the message list view using several predefined and
custom labels.
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Preview Pane
This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole
window, or double click the message in the message list to have it open in a newwindow.
To change the size of a pane, drag the divider between the two panes.

As with folders, you can right click messages in the message list and get a menu of
possible actions, including moving or deleting them, creating filters or search folders
based on them, and marking them as junk mail.

Email-related actions, like Reply and Forward, appear as buttons in the toolbar and are
also located in the right-click menu and as keyboard shortcuts.

Templates
Evolution allows you to create and edit message templates that you can use at any time
to send mail with the same pattern.

6.2.4 The Calendar
To begin using the calendar, clickCalendars in the shortcut bar. By default, the calendar
shows today’s schedule on a ruled background. At the upper right, there is a Tasks list,
where you can keep a list of tasks separate from your calendar appointments. Below
that, there’s a list for memos.

Appointment List
The appointment list displays all your scheduled appointments.

Month Pane
The month pane is a small view of a calendar month. You can also select a range of
days in the month pane to display a custom range of days in the appointment list.
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Tasks
Tasks are distinct from appointments because they generally do not have times associ-
ated with them. You can see a larger view of your task list by clicking Tasks in the
shortcut bar.

Memos
Memos, like Tasks, do not have times associated with them. You can see a larger view
of your Memo list by clicking Memos in the shortcut bar.

6.2.5 The Contacts Tool
The Evolution contacts tool can handle all of the functions of an address book or phone
book. However, it is easier to update Evolution than it is to change an actual paper
book, in part because Evolution can synchronize with PalmOS* devices and use LDAP
directories on a network.

Another advantage of the Evolution contacts tool is its integration with the rest of the
application. For example, you can right-click on an e-mail address in Evolution mail
to instantly create a contact entry.

To use the contacts tool, clickContacts in the shortcut bar. By default, the display shows
all your contacts in alphabetical order, in a minicard view. You can select other views
from the Viewmenu, and adjust the width of the columns by clicking and dragging the
gray column dividers.

The largest section of the contacts display shows a list of individual contacts. You can
also search the contacts in the same way that you search e-mail folders, using the search
tool on the right side of the toolbar.

6.3 For More Information
Get more information about Evolution from the official knowledge base available via
F1. More useful information is available from the following links:

Official project homepage: http://projects.gnome.org/evolution/
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Wiki reference: http://www.go-evolution.org/Main_Page
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7GroupWise Linux Client:
E-Mailing and Calendaring
GroupWise® is a robust, dependable messaging and collaboration system that connects
you to your universal mailbox anytime and anywhere. This section gives you an intro-
ductory overview of the GroupWise client to help you start using the GroupWise cross-
platform client quickly and easily.

7.1 For More Information
You can learn more about GroupWise from the following resources.

7.1.1 GroupWise 8 Documentation Web
Page

For the latest version of the GroupWise user guide and for extensive GroupWise admin-
istration documentation, go to the GroupWise 8 area on the Novell DocumentationWeb
site (http://www.novell.com/documentation/gw8).

This user guide is also available from the GroupWise client by clicking Help > User
Guide.
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7.1.2 GroupWise Cool Solutions Web
Community

At GroupWise Cool Solutions, you’ll find tips, tricks, feature articles, and answers to
frequently asked questions (FAQs). In the Main Window, click Help > Cool Solutions
WebCommunity or go tohttp://www.novell.com/coolsolutions/gwmag.

7.1.3 Online Help
Complete user documentation is available in Help. In the Main Window, click Help >
Help Topics, then use the Contents tab, Index tab, or Search tab to locate the help topics
you want.
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8GNOME Pilot: Synchronizing
Your Handheld Devices
GNOME Pilot lets you integrate your GNOME desktop with handheld computers. You
can use it to set up and perform synchronization between PDAs and your GNOME
desktop.

Thegnome-pilot package, alongwith the optional conduits inevolution-pilot,
allows you to move information between your handheld device and your GNOME
desktop. You must run the setup tool before synchronizing. The setup tool starts the
GNOME Pilot daemon, gpilotd. If it is not running, you can start the daemon with
the/usr/lib/gnome-pilot/gpilotd command. You can also use the GNOME
Pilot applet to start the daemon.

To start the GNOME Pilot applet, click Computer >More Applications > System >
GNOME Pilot or start /usr/bin/gpilotd-control-applet.

8.1 GNOME Pilot Configuration Tool
To start the GNOME Pilot configuration tool, click Computer >More Applications >
System > GNOME Pilot.

There are three tabs in the Pilot Settings tool: PDAs, Devices, and Conduits. The first
time you run the GNOME Pilot tools, you will be guided through the initial setup by
an assistant.
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8.1.1 Prerequisites For Serial PDAs
This prerequisite is needed for serial PDAs only. Before proceeding further, add your
user to the group uucp that will use the handheld. Start YaST and choose the Security
and Users > User and Group Management module. Go to the Groups tab and select
from Set Filter the entry System Groups. Search for the uucp group, select Edit and
add all those users that are allowed to use the handheld. Proceed with Ok and Finish.

8.1.2 The GNOME Pilot Setup Assistant
The setup assistant guides you through getting your handheld device ready to synchronize
with your desktop system.

1 Click Computer >More Applications > System > GNOME Pilot. Proceed with
Forward to start the GNOME Pilot Setup Assistant.

2 Describe your handheld's cradle in the Device Settings dialog box. Proceed with
Forward.

See Section 8.1.4, “Adding or Editing an Entry On the Device Settings Tab”
(page 101) for more information about the information requested by this step.
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3 Decide if you need to syncronize your data on your PDA. Proceed with Forward.
Depending on your selection, press the hotsync button on your PDA.

If you have previously used synchronization software with this PDA, it will al-
ready have a synchronization ID that your desktop can get from it. If you have
not, you can set the username and ID on the PDA from your desktop. Proceed
with Forward to contact your PDA device.

4 Set the name and other information on the Initial Sync dialog box.
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Choose a name to use when referring to the PDA, and a directory on your desktop
system where you will store backups and other data. Proceed with Forward.

8.1.3 Adding or Editing a Handheld Entry
The PDAs tab lists the handheld devices you have configured. If you have not used the
Pilot Settings tool before, you will not have any items in this list, and the tool will open
a new window to walk you through the process of creating one. To add a new pilot,
click Add. To edit an existing pilot entry, select it and click Edit.

When editing or creating an entry, you will be asked for five pieces of information:

• Owner: This is the owner of your Pilot. If your pilot already has a name config-
ured, you can get it from the pilot by clicking the Get from PDA button. You can
also set it on the pilot by clicking the Send to PDA button.

• PDA ID: This is the user ID number from your pilot. You can get this value
from the handheld by clicking the Get from PDA button. You can also set it on the
handheld by clicking the Send to PDA button.

• Name of PDA: This is the name by which your handheld will be identified. For
example, you could call it MyPilot, or Palm5, or Roger.

• Local folder: This is the directory where you will store information backed up
from your handheld.

• Charset of PDA The character set (encoding) which is used on your PDA.
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8.1.4 Adding or Editing an Entry On the
Device Settings Tab

The Device Settings tab controls the way your desktop system looks at your handheld
as hardware. To add an entry to the list, click Add. To edit a device, select it, then click
Edit.

For each entry, you can specify the following options:

• Name: This is the name used to display the device in a list.

• Type: Select the type of connection you have: Serial, USB, IrDA (infrared), or
Network.

• Timeout: Specifies the amount of time to try to connect to the system, in seconds.
If there is no communication between the desktop and the handheld for this many
seconds, the system will stop trying.

• Device: In most cases, /dev/pilot is fine. Other possible values are /dev/
ttyS0 or /dev/ttyS1 for serial cradles.

If you have not chosen the correct device, you will get an error message when you
click OK.

• Speed: Select a number from the drop-down menu. The higher the number, the
faster you are asking the system to transfer information. Normally, you should not
change this option, because it is set by default for the fastest value that your con-
nection type can provide. If you experience problems at high speeds, reducing the
transfer speed might help.

8.1.5 Conduit Settings
AConduit is a specialized program that channels data between your computer and your
handheld. The gnome-pilot package includes several, and you can also install additional
conduits such as those for Evolution.

Each configured handheld might have its own set of conduits and conduit settings.
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If a conduit is disabled, that type of data will be ignored when you HotSync. If a conduit
is enabled, its data will be synchronized according to its settings. To enable or disable
a conduit, select it and click the Enable or Disable button on the right side of the list
of conduits.

To edit the settings, select a conduit and click the Settings button. Each conduit will
have at least two settings: an Action to perform whenever you synchronize, and a One
Time Action, performed only the next time you synchronize.

Not all conduits will have all of these actions. The list of possible actions includes the
following:

• Disabled: Do nothing.

• Synchronize: Ensures that data is the same in both places, copying new data
from the pilot to the desktop, and from the desktop to the computer.

• Copy to pilot: Copies all data from the desktop to the pilot. New data added on
the pilot will not be copied to the desktop.

• Copy from pilot: Copy all data from the pilot to the desktop. New data added
on the desktop will not be copied to the pilot.

Other settings might be available as well, includingConduit Priority, which determines
the order in which conduits will be used, and Sync Private Records, which determines
whether to copy private information as well as public, or just the public data.

8.2 The Pilot Applet
The GNOME Pilot panel applet sits in your panel until you are ready to synchronize
your handheld device. If the pilot access daemon is running, the applet will appear in
black and white. If it is not running, the applet will appear red and black. If the daemon
is paused, the applet will be yellow and black.

To add the applet to your panel, right-click on a free space on the panel and select Add
to Panel.... A window opens. Search for Pilot Applet and click on Add.

Click the applet button to start the GNOME Pilot configuration tool. The following
actions for the applet are available in the right-click menu:
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• Restore: If your PalmOS device has lost all data, select this item to restore it
from the backup you made earlier.

• Pause Daemon: Pauses the GNOME Pilot daemon gpilotd. If the daemon is
paused, this item will read Continue.

• Restart: Stops and restarts the daemon.

• Last Log: Displays the results of the last synchronization performed.

• Preferences: Click this item to select what happens when you click the applet,
and whether to display notices in dialog boxes.

GNOME Pilot: Synchronizing Your Handheld Devices 103





9KGpg: Signing and Encrypting
Data
You can sign or encrypt data with KGpg, a graphical user interface for GnuPG. This
program helps you to generate and manage all needed keys. Use its editor function for
the quick creation and encryption of files or use the applet in your panel to encrypt or
decrypt by dragging and dropping. Other programs, such as your mail program (Kontact
or Evolution), access the key data to process signed or encrypted contents. In the fol-
lowing sections, learn how to execute the following steps necessary for signing and
encrypting data with KGpg:

1. Generating a New Key Pair (page 106)

2. Exporting the Public Key (page 109)

3. Importing Public Keys from Others (page 109)

4. Encrypting Your Data (page 113)

9.1 Why Signing and Encrypting?
Signing

Signing means attaching electronic signatures to mails (or even software) to prove
its origin. To avoid someone writing mails using your name and to protect both
you and the recipients, you should sign your mails. Signatures help you to easily
check the sender of themails you receive and to distinguish authentic frommalicious
mails.
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Software developers sign their software so you are able to check its integrity. Even
if you have the software from an unofficial server, you can verify the package with
the signature.

Encrypting
You might have sensitive information you want to protect from other parties. En-
crypting helps you to transform data and make it unreadable for others. This is es-
pecially important for companies who must protect internal information as well as
the employees' privacy.

9.2 Generating a New Key Pair
To be able to exchange encrypted messages with other users, first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can use it to encrypt the files or e-mail messages they send. The other part of the
key pair—the private key—is used to decrypt the encrypted contents.

IMPORTANT: Private Key versus Public Key

Only you should have access to the private key. Do not grant other users access
to this data.

Your private key is protected with a passphrase. Choose the passphrase carefully:
do not use words from a dictionary, and mix alphabetic with non-alphabetic
characters.

To create a new pair, proceed as follows:

1 Start KGpg from the main menu or press Alt + F2 and enter kgpg. When you
start the program for the first time, a wizard appears, guiding you through the
configuration. Follow the instructions up to the point where you are prompted
to create a key.

2 Select Keys > Generate Key Pair, if you want to create a new key pair.
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Figure 9.1 KGpg: Creating a Key

3 Enter a name, an e-mail address, and optionally, a comment. If you do not like
the default settings provided, also set the expiration time for the key, the key
size, and the encryption algorithm used.

4 To generate a standard key, confirm your settings with OK. After clicking OK,
a dialog prompts you to enter a passphrase twice. The passphrase protects your
private key. The relative strength of your chosen password is measured and dis-
played by the Password strength meter. The key pair will be generated. This can
take some time.

NOTE: Expert Mode

If you are an experienced user, use the Expert Mode to define additional
options. This takes you to a terminal window where you can set the type
of key to be generated, the key size (in bits) and the date of expiration.
After entering your name and email address, you are prompted for a
passphrase to protect your private key.

5 After the key generation is finished, a summary will be displayed. Save and print
the revocation certificate and keep it in a save place. You will need the certificate
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to revoke your passphrase if you forgot it. After you have confirmed with OK,
KGpg displays its main window and you are finished.

Figure 9.2 KGpg Main Window: Key Management

The main window shows the keys that belong to your key ring: your own key and the
keys from other persons that you have already imported. As GnuPG uses a more sophis-
ticated implementation of key pairs, for each user name, several sub keys are displayed
but these can be neglected for the purpose of this chapter. Apart from some other details
(like expiration date or creation date of the key and the ID), the main windows also
shows the level of trust for each key, indicated by colors. White means that the trust
level is unknown, blue indicates a high level of trust. For more information, see Sec-
tion 9.4.2, “Trusting Keys” (page 111).

NOTE: KGpg Icon and Main Window

When you start KGpg in later sessions, only a small icon with a padlock appears
in the system tray. Click that icon to display the main KGpg window on your
desktop.
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9.3 Exporting the Public Key
After generating your key pair, make the public key available to other users. This enables
them to use it to encrypt or sign the messages or files they send you. For example, if
you want to encrypt a message for user tux, you encrypt it using tux' public key. To
decrypt the message, tux uses his private key. If tux wants to send you a message, he
encrypts it using your public key and you decrypt the message with your private key.

To make the public key available for others, select Keys > Export Public Keys. The di-
alog that opens offers four options:

Email
Your public key is sent to a recipient of your choice by email. If you activate this
option and confirm with OK, the dialog for creating a new email message with
your default mail program appears. Enter the recipient and click Send. The recipient
receives your key and can then send you encrypted contents.

Clipboard
You can place your public key here before continuing to process it.

Default Key Server
To make your public key available to a wide audience, export it to one of the key
servers on the Internet. For more information, refer to Section 9.5, “The Key
Server Dialog” (page 111).

File
If you prefer to distribute your key as a file on a data medium instead of sending
it by email, click this option, confirm or change the file path and name, and click
OK.

9.4 Importing Public Keys from
Others

If you receive a key in a file (for example, as an e-mail attachment), integrate it in your
key ring with Import Key and use it for encrypted communication with the sender. You
can also import keys from a public server if the person you want to communicate with
has stored his public key there. For more information, see Section 9.5, “The Key

KGpg: Signing and Encrypting Data 109



Server Dialog” (page 111). The procedure is similar to the procedure for exporting keys
already described.

9.4.1 Signing Keys
Keys can be signed like every other file to guarantee their authenticity and integrity. If
you are absolutely sure an imported key belongs to the individual specified as the
owner, express your trust in the authenticity of the key with your signature.

IMPORTANT: Establishing a Web of Trust

Encrypted communication is only secure to the extent that you can positively
associate public keys in circulation with the specified user. By cross-checking
and signing these keys, you contribute to the establishment of a Web of Trust.
For these reasons, make really sure you only sign keys you have personally
checked.

Before you can use your key, you need to sign it yourself.

Procedure 9.1 Signing A Key

1 In the Key Management window, select the key to sign in the key list.

2 Select Keys > Sign Keys.

3 In the following dialog, select the private key to use for the signature. An alert
reminds you to check the authenticity of this key before signing it. In the drop
down list, select how you carefully you have checked that the key belongs to the
person with whom you want to communicate.

4 Click Continue and enter your passphrase in the next step. With entering the
passphrase, you sign the key with your own private key. The signed key now
appears green in the trust column.

Other users can now check the signature by means of your public key.
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9.4.2 Trusting Keys
Normally, you are asked by the corresponding program whether you trust the key, or
rather, whether you assume it is really used by its authorized owner. This happens each
time a message needs to be decrypted or a signature has to be checked. To avoid this,
edit the trust level of the newly imported key. To trust a key and set a certain trust level,
do the following:

1 Right-click the key and select Key Properties.

2 In the Owner Trust drop-down list, adjust the trust level. This value indicates
how much you trust the owner of this key to correctly verify the identity of the
keys he signs.

3 Close the property dialog. If you have set the trust level to Fully or Ultimately,
the key now appears blue in the trust column.

The lower the trust level is, the less you trust the signer of the key to have checked the
true identity of the keys signed. You may be entirely sure about the signer's identity,
but this user may not check other people's identities properly before signing their keys.
Notice that the trust level does not trigger any automatic actions by KGpg.

9.5 The Key Server Dialog
Several Internet-based key servers offer the public keys of many users. To engage in
encrypted communication with a large number of users, use these servers to distribute
your public key. For this purpose, export your public key to one of these servers. Simi-
larly, KGpg enables you to search one of these servers for the keys of certain people
and import their public keys from the server. Open the key server dialog with File >
Key Server Dialog.
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9.5.1 Importing a Key from a Key Server
By means of the Import tab in the key server dialog, import public keys from one of
the Internet-based key servers. Select one of the preconfigured key servers and enter a
search string (e-mail address of the communication partner) or the ID of the key to find.
When you click Search, your system connects to the Internet and searches the specified
key server for a key that matches your specifications.

Figure 9.3 Search Screen for Importing a Key

If your search on the key server is successful, a list of all retrieved server entries is
displayed in a new window. Select the key to include in your key ring and click Import.
Confirm the following message with OK, then exit the key server dialog with Close.
The imported key then appears in the main overview of the key manager and is ready
for use.

9.5.2 Exporting Your Keys to a Key Server
To export your key to one of the freely accessible key servers on the Internet, select
the Export tab in the key server dialog. Designate the target server and the key to export
by means of two drop-down menus. Then start the export with Export.
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Figure 9.4 Exporting a Key to a Key Server

9.6 Encrypting Your Data
After you have generated your key pair, exported your public key and imported public
keys from others, you can also send or receive encrypted mails. Refer to Section 5.2.5,
“Signing and Encrypting emails” (page 64) to learn how to make use of those options
in KMail.

KGpg also offers the possibility to encrypt text. To open the integrated editor choose
File > Open Editor.

9.6.1 Encrypting and Decrypting from a File
Manager

KGpg is also integrated into file managers like Dolphin or Konqueror. Generally, PGP-
encrypted files are designated with the suffix asc. There are several options how to
encrypt or decrypt files inside a file manager:

Encrypt a File
To encrypt a file inside a file manager, right-click the file and select Actions > En-
crypt File. Choose one of the trusted keys in the dialog. After clicking OK in the
dialog, a new file with the asc suffix will be created in the same directory.

Decrypt a File on the fly
To decrypt an encrypted file instantly, right-click the file and select Open with
KGpg. If the original filename already exists, a dialog opens that asks how to name
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the file or if it should be overwritten. KGpg prompts for the password of your private
key and saves the decrypted file in the same directory.

Decrypt with the editor
To decrypt an encrypted file with the editor, right-click the file in the file manager
and select Actions > View file decrypted.

9.6.2 The KGpg Editor
Instead of creating contents for encryption in an external editor then encrypting the file
with one of the methods described above, you can use the integrated editor of KGpg.
To open the editor, select File > Open Editor. In the editor, enter the desired text (or
copy it into the editor from the clipboard or any file), and click Encrypt. Then select
the key to use and complete the encryption procedure. To decrypt files, use Decrypt
and enter the password associated with the key.

Generating and checking signatures is just as easy as encrypting directly from the editor.
Go to Signature > Generate Signature and select the file to sign from the file dialog.
Select the private key to use and enter the associated password. KGpg informs you of
the successful generation of the signature. Files can also be signed from the editor by
simply clicking Sign/Verify. To check a signed file, go to Signature > Verify Signature
and select the file to check in the following dialog. After you confirm the selection,
KGpg checks the signature and reports the result of the operation. Another possibility
is to load the signed file into the editor and click Sign/Verify.

9.7 For More Information
For comprehensive background information about the encryption method, refer to the
GnuPG project pages at http://www.gnupg.org/documentation/index
.en.html.

114 Application Guide

http://www.gnupg.org/documentation/index.en.html
http://www.gnupg.org/documentation/index.en.html


10Seahorse: Signing and
Encrypting Data
The GNOME Passwords and Encryption Keys program is an important component of
the encryption infrastructure on your system. With the help of this program, you can
create and manage PGP and SSH keys, import and export PGP and SSH keys, share
your keys with others, back up your keys and keyring, cache your passphrase, and en-
crypt and decrypt the clipboard. Start the program by choosing Computer >More Ap-
plications > Tools > Passwords and Encryption Keys

Figure 10.1 Password and Encryption Keys Main Window
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10.1 Signing and Encryption
Signing means attaching electronic signatures to email messages or even software to
prove its origin. To keep someone else from writing messages using your name, and
to protect both you and the people you send them to, you should sign your mails. Sig-
natures help you easily check the sender of the messages you receive and distinguish
authentic messages from malicious ones.

Software developers sign their software so that you can check the integrity. Even if you
get the software from an unofficial server, you can verify the package with the signature.

You might also have sensitive information you want to protect from other parties. En-
cryption helps you transform data and make it unreadable for others. This is important
for companies so they can protect internal information as well as their employees' pri-
vacy.

10.2 Generating a New Key Pair
To exchange encrypted messages with other users, you must first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can than use it to encrypt the files or email messages they send. The other part of
the key pair—the private key—is used to decrypt the encrypted contents.

IMPORTANT

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

10.2.1 Creating OpenPGP Keys
OpenPGP is a non proprietary protocol for encrypting email with the use of public key
cryptography based on PGP. It defines standard formats for encrypted messages, signa-
tures, private keys, and certificates for exchanging public keys.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.
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2 Click File > New > PGP Key.

3 Specify your full name, email address, and comment, if needed.

4 Click Advanced key options to specify the following advanced options for the
key.

Encryption Type
Specifies the encryption algorithms used to generate your keys.DSAElGamal
is the recommended choice because it lets you encrypt, decrypt, sign, and
verify as needed. Both DSA (sign only) and RSA (sign only) allow only
signing.

Key Strength
Specifies the length of the key in bits. The longer the key, the more secure
it is (provided a strong passphrase is used), but keep in mind that performing
any operation with a longer key requires more time than it does with a
shorter key. Acceptable values are between 1024 and 4096 bits. At least
2048 bits is recommended.

Expiration Date
Specifies the date at which the key will cease to be usable for performing
encryption or signing operations. You will have to either change the expira-
tion date or generate a new key or subkey after this amount of time passes.
Sign your new key with your old one before it expires to preserve your trust
status.

5 Click Create to create the new key pair.

The Passphrase for New PGP Key dialog box opens.

6 Specify the passphrase twice for your new key, then click OK.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.
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10.2.2 Creating Secure Shell Keys
Secure Shell (SSH) is a method of logging into a remote computer to execute commands
on that machine. SSH keys are used in key-based authentication system as an alternative
to the default password authentication system. With key-based authentication, there is
no need to manually type a password to authenticate.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Click File > New > Secure Shell Key.

3 Select Secure Shell Key, then click Continue.

4 Specify a description of what the key is to be used for.

You can use your email address or any other reminder.

5 Optionally, click Advanced key options to specify the following advanced options
for the key.

Encryption Type Specifies the encryption algorithms used to generate your
keys. Select RSA to use the Rivest-ShamirAdleman (RSA) algorithm to create
the SSH key. This is the preferred and more secure choice. SelectDSA to use the
Digital Signature Algorithm (DSA) to create the SSH key.

Key Strength Specifies the length of the key in bits. The longer the key, the
more secure it is (provided a strong passphrase is used), but keep in mind that
performing any operation with a longer key requires more time than it does with
a shorter key. Acceptable values are between 1024 and 4096 bits. At least 2048
bits is recommended.

6 Click Just Create Key to create the new key, or click Create and Set Up to create
the key and set up another computer to use for authentication.

7 Specify the passphrase for your new key, click OK, then repeat.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.
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10.3 Modifying Key Properties
You can modify properties of existing OpenPGP or SSH keys.

10.3.1 Editing OpenPGP Key Properties
The descriptions in this section apply to all OpenPGP keys.

1 Click Computer >More Applications > Tools > Passwords and Encryption Keys
and switch to theMy Personal Keys tab.

2 Double-click the PGP key you want to view or edit. (or select the key, then click
on Properties in toolbar).

3 Use the options on theOwner tab to add a photo to the key or to change the
passphrase associated with the key.

Photo IDs allow a key owner to embed one or more pictures of themselves in a
key. These identities can be signed just like normal user IDs. A photo ID must
be in JPEG format. The recommended size is 120×150 pixels.

If the chosen image does not meet the required file type or size, Passwords and
Encryption Keys can resize and convert it on the fly from any image format
supported by the GDK library.

4 Click the Names and Signatures tab to add a user ID to a key.

See Section “Adding a User ID” (page 121) for more information.

5 Click the Details tab, which contains the following properties:

Key ID: The Key ID is similar to the Fingerprint, but the Key ID contains
only the last eight characters of the fingerprint. It is generally possible to identify
a key with only the Key ID, but sometimes two keys might have the same Key
ID.

Type: Specifies the encryption algorithm used to generate a key. DSA keys
can only sign. ElGamal keys are used to encrypt.
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Strength: Specifies the length, in bits, of the key. The longer the key, the
more security it provides. However, a long key will not compensate for the use
of a weak passphrase.

Fingerprint: A unique string of characters that exactly identifies a key.

Created: The date the key was created.

Expires: The date the key can no longer be used (a key can no longer be used
to perform key operations after it has expired). Changing a key's expiration date
to a point in the future re-enables it. A good general practice is to have a master
key that never expires and multiple subkeys that do expire and are signed by the
master key.

Override Owner Trust: Here you can set the level of trust in the owner of
the key. Trust is an indication of how sure you are of a person's ability to correctly
extend the web of trust. When you are faced with a key you have not signed, the
validity of that person's key will be determined based on the signatures they have
collected and how well or not you trust the people who have made those signa-
tures.

Export Complete Key: Exports the key to a file.

Subkeys: See Section “Editing OpenPGP Subkey Properties” (page 121) for
more information.

6 Click Close.
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Adding a User ID
User IDs allow multiple identities and email addresses to be used with the same key.
Adding a user ID is useful, for example, when you want to have an identity for your
job and one for your friends. They take the following form:

Name (comment) <e-mail address>

1 Click Computer >More Applications > Tools > Passwords and Encryption Keys
and switch to theMy Personal Keys tab.

2 Double-click the PGP key you want to view or edit (or select the key, then click
Properties in the toolbar).

3 Click the Names and Signatures tab, then click Add Name.

4 Specify a name in the Full Name field.

You must enter at least five characters in this field.

5 Specify an email address in the Email Address field.

Your email address is how most people will locate your key on a key server or
other key provider. Make sure it is correct before continuing.

6 In the Key Comment field, specify additional information that will display in the
name of your new ID

This information can be searched for on key servers.

7 Click Close.

Editing OpenPGP Subkey Properties
Each OpenPGP key has a single master key used to sign only. Subkeys are used to en-
crypt and to sign as well. In this way, if your sub key is compromised, you don't need
to revoke your master key.

1 Click Computer >More Applications > Tools > Passwords and Encryption Keys
and switch to theMy Personal Keys tab.
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2 Double-click the PGP key you want to edit (or select the key, then clickProperties
in the toolbar).

3 Click the Details tab, then click Subkeys.

4 Use the button to on the left of the dialog box to add, delete, expire, or revoke
subkeys.

Each subkey has the following information:

ID: The identifier of the subkey.

Type: Specifies the encryption algorithm used to generate a subkey. DSA
keys can only sign, ElGamal keys are used to encrypt, and RSA keys are used
to sign or to encrypt.

Created: Specifies the date the key was created.

Expires: Specifies the date the key can no longer be used.

Status: Specifies the status of the key.

Strength: Specifies the length, in bits, of the key. The longer the key, the
more security it provides. However, a long key will not compensate for the use
of a weak passphrase.

5 Click Close.
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10.3.2 Editing Secure Shell Key Properties
The descriptions in this section apply to all SSH keys.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Double-click the Secure Shell key you want to view or edit (or select the key,
then click Properties in the toolbar).

3 Use the options on the Key tab to change the name of the key or the passphrase
associated with the key.

4 Click the Details tab, which contains the following properties:

Algorithm: Specifies the encryption algorithm used to generate a key.

Strength: Indicates the length in bits of a key. The longer the key, the more
security it provides. However, a long key does not make up for the use of a weak
passphrase.

Location: The location where the private key has been stored.

Fingerprint: A unique string of characters that exactly identifies a key.

Export Complete Key: Exports the key to a file.

5 Click Close.
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10.4 Importing Keys
To import keys:

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Click File > Import.

3 Select a file containing at least one ASCII armored public key.

4 Click Open to import the key.

You can also paste keys inside Passwords and Encryption Keys:

1 Select an ASCII armored public block of text, then copy it to the clipboard.

2 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

3 Click Edit > Paste

10.5 Exporting Keys
To export keys:

1 Click Computer >More Applications > Tools > Passwords and Encryption Keys
and switch to theMy Personal Keys tab.

2 Select the keys you want to export.

3 Click File > Export.

4 Specify a filename and location for the exported key.

5 Click Save to export the key.

You can also export keys to the clipboard in an ASCII armored block of text:
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1 Click Computer >More Applications > Tools > Passwords and Encryption Keys
and switch to theMy Personal Keys tab.

2 Select the keys you want to export.

3 Click Edit > Copy.

10.6 Signing a Key
Signing another person's key means that you are giving trust to that person. Before
signing a key, carefully check the key's fingerprint to ensure that the key really belongs
to that person.

Trust is an indication of how sure you are of a person's ability to correctly extend the
web of trust. When you are faced with a key you have not signed, the validity of that
person's key will be determined based on the signatures they have collected and how
well or not you trust the people who havemade those signatures. By default, an unknown
key will require three signatures with marginal trust value or one fully trusted signature.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Select the key you want to sign from theMy Personal Keys or Other Keys tabs.

3 Click File > Sign.

4 Select how carefully the key has been checked, then indicate if the signature
should be local to your keyring, and if your signature can be revoked
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5 Click Sign.

10.7 Encryption Preferences
Functionality of the Password and Encryption Keys tool can be customized. Possible
options are described in this section.

10.7.1 Password Keyrings
You can use password keyring preferences to create or remove keyrings, to set the default
keyring for application passwords or to change unlock password of a keyring. To create
a new keyring, follow these steps:

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Click File > New > Password Keyring, then click the Continue.

3 Enter new keyring's name and press Add.

4 Set and confirm new keyring's Password and click Create.
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To change unlock password of an existing keyring, click on the keyring in the Passwords
tab and press Change Password. You have to provide the old password to be able to
change it.

To change the default keyring for application passwords, click on the keyring in the
Passwords tab and press Set as Default.

10.7.2 Key Servers
You can keep your keys up-to-date by syncing keys periodically with remote keyservers.
Syncing will ensure that you have the latest signatures made on all of your keys, so that
the web of trust will be effective.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Click Edit > Preferences, then click the Key Servers tab.

Passwords and Encryption Keys provides support for HKP and LDAP keyservers.

HKP Servers: HKP keyservers are ordinary Web-based keyservers such as
the popular hkp://pgp.mit.edu:11371, also accessible at http://pgp.mit
.edu.

LDAPKeyservers: LDAP keyservers are less common, but use the standard
LDAP protocol to serve keys. ldap://keyserver.pgp.com is a good LDAP server.
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You can Add or Remove keyservers to be used using the buttons on the left. To
add a new keyserver, set its type, host and port, if necessary.

3 Set whether you want to automatically publish your public keys and which key-
server to use. Set whether you want to automatically retrieve keys from keyservers
and whether to synchronize modified keys with keyservers.

4 Click Close.

10.7.3 Key Sharing
Key Sharing is provided by DNS-SD, also known as Bonjour or Rendezvous. Enabling
key sharing adds the local Passwords and Encryption Keys users' public key rings to
the remote search dialog box. Using these local key servers is generally faster than ac-
cessing remote servers.

1 ClickComputer >More Applications > Tools > Passwords and Encryption Keys.

2 Click Edit > Preferences, then click the Key Sharing tab.

3 Select Share my keys with others on my network.

4 Click Close.
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11BasKet: Taking Notes
BasKet is a note-taking application that allows you to collect and sort all kind of data.
It helps with writing down your ideas, making to do lists, and allocating your contacts.
You can sort the data in hierarchies and share it with other people. If needed, you can
even protect some of your baskets with passwords.

11.1 Creating Baskets
A basket is a document in which you can place notes. Create baskets that include dif-
ferent topics, contents, or projects and give each its own layout.

1 To start BasKet, open a shell with Alt + F2 and enter basket.

2 To create a basket, select Basket > New > New Basket.

3 Enter a name for your basket and select a template for its column structure.

4 The basket tree on the left side shows all your baskets.

Right-click a basket in the tree and selectProperties to give it a special appearance
(background color or image and text color), change its disposition (column for-
mat), or create a shortcut for it.
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Figure 11.1 Basket in Use

NOTE: Saving your Baskets

There is no need to save your work. It is saved automatically.

To assure a clearly arranged structure, you may want to create sibling baskets or sub-
baskets as well. You can do this by selecting Basket > New > New Sub-Basket. The
sub-basket appears one level down the parent basket. By selecting Basket >New >New
Sibling-Basket you create a basket in the same level as the parent basket. In both cases
the new baskets inherit the appearance and disposition from their parent baskets.

11.2 Working with Baskets
After creating your baskets and sub-baskets, fill them with different notes. Notes can
include different types of data, for example text, images, URLs, application launchers
as well as links, e-mail addresses, files and colors.
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11.2.1 Filling and Personalizing your Baskets
To insert notes into baskets, just right-click the area on the right side and choose the
type of data you need to add. You can import screen shots or colors picked from the
screen into your baskets. For a screen shot, select Insert > Grab from screen. To select
a screen color, use Insert > Color from Screen.

You may want to assign tags to your notes to structure them. Tags are marks that repre-
sent the priority, preference, or progress of a note. Select Tags and simply check or
uncheck the tags to assign or remove them from the selected notes. Customize the
available tags by selecting Tags > Customize.

Figure 11.2 Customizing Tags

To group notes that belong together select the ones you want to group, right-click on
them and selectGroup. To break up a group of notes, make sure you selected the whole
group of notes, then right-click and select Ungroup.
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You can move a note within a group of notes by selecting Note >Move Up. If you want
to move a note from within a group of notes outside it, select Note >Move On Top.

11.2.2 Importing and Exporting Baskets
If you worked with other note-taking applications in the past and do not want to lose
the collected information, import these files to BasKet. You can import data from the
applications KNotes, KJots, and StickyNotes. To do that, right-click either in the tree
structure on the left side or directly on the basket into which you want to import the
notes and select Import.

After collecting and sorting a lot of data, you might want to share it with other people.
There are two ways to prepare your notes for sharing:

• Export a basket into HTML files by right-clicking the basket you want to export
and selecting Export > HTML Web Page.

• For others to be able to open and modify your baskets, export them into basket
archives. Right-click the basket you want to export and select Export > Basket
Archive.

11.2.3 Protecting Baskets
There might be baskets that you want to protect with a password so you are the only
person who can access them. To protect a basket using a password or private and public
keys Right-click the basket and select Password.

11.2.4 Finding Data
Once you have several baskets, finding specific data can be challenging. You have
different possibilities to find the information you are looking for very quickly even
without remembering its exact title:

• Find notes by simply typing a word or two in the filter box.

• If you are searching for notes with a certain tag assigned to them, select the desired
tag in the tag box.
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• The icon on the right applies a filter to every basket.

The numbers in the basket tree on the left indicate how many notes match your search
options. The lock icon indicates that the basket is currently locked, so has not been
searched. For more information, see Section 11.2.3, “Protecting Baskets” (page 132).

11.2.5 Creating and Restoring Backups
Basket can backup your data for you. Select Basket > Backup & Restore... to open a
dialog box. It shows you where your baskets are stored in. You can select a different
folder when you select the buttonsMove to Another Folder... or Use Another Existing
Folder..., depending on your need. Start the backup process with Backup... and give
your archive a name. A previously backup can be restored with Restore a Backup...
and select the respective archive.

11.3 For More Information
The official home page of BasKet is http://basket.kde.org/index.php.
This site offers a tour through the application, news of the latest versions, and a collection
of screen shots showing different use cases.
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12Tomboy: Taking Notes
Tomboy is a GNOME note-taking application that enables you to organize the ideas
and information you deal with every day. Among other things, it can help you collect
and sort all kind of data, write down your ideas, allocate your contacts and make to-do
lists.

Tomboy also has some useful editing features to help you customize your notes, includ-
ing:

• Highlighting search text

• Inline spell checking

• Auto-linking Web and email addresses

• Undo/redo support

• Font styling and sizing

• Bulleted lists

Tomboy is located on the GNOME panel, and by default is started automatically when
you log into GNOME. You can also access Tomboy by clicking Computer >More

Applications > Tools > Tomboy Notes.
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12.1 Creating Notes
To create a new note, click the Tomboy Notes icon in your GNOME Panel, then select

Create New Note.

Figure 12.1 A New Tomboy Note

To edit the note, click the content area, then use the keyboard to add and remove content.
The first line of the note contains its title. By default, this is populated with the text
New Note #. You can change the title by clicking the line and using the keyboard.
By default, focus is given to the content area upon creation of a new note, so you can
immediately start editing the note without clicking the content area. For more information
on formatting the contents of a note, see Section 12.5, “Formatting Text in Notes”
(page 139).

Your note is saved automatically.

You can then organize the notes you create by linking related notes and ideas together.
Fore more information, see Section 12.3, “Linking Notes” (page 137).

12.2 Searching All Notes
To get an overview of all your notes, click and then select Search All Notes. By default,
the Search All Notes dialog box displays your notes in the order they were last modified.
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Click the Note or Last Changed column headings to change the sort order. Click the

column heading a second time to toggle between ascending and descending order.

Figure 12.2 Search All Notes Dialog Box

You can find specific notes by entering text into the Search field. The list of notes au-
tomatically updates to list only the notes that contain matching text.

To open a note listed in the Search All Notes dialog box, do any of the following:

• Double-click a note.

• Select a note, then click File > Open.

• Right-click a note, then select Open.

• Select a note, then press Ctrl + O.

12.3 Linking Notes
You can link notes in Tomboy by highlighting text in your current note, then clicking
the Link button in the toolbar. This creates a new note and underlines the note's title in
the current note.

For example, if your current note contains the phrase “resume,” you can select this text,
then click Link to create a new note with the title “resume.” A link is also created in
the current note which you can click to open the new “resume” note.
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Figure 12.3 Links in Tomboy Notes

If you change the title of a note, the links in other notes to that note are automatically
updated. Typing the name of another note in your current note automatically links that
note for you. To see what other notes link to the current note, click Tools >What links
here?

12.4 Accessing Your Notes
To access your notes, click the Tomboy icon on the GNOME panel, then select one of
the notes you recently viewed or created from the menu, or search for older notes (see

Section 12.2, “Searching All Notes” (page 136) for more information).

To force a note to always appear in the panel menu regardless of when you last accessed
it, click the thumbtack icon to the right of the note to “pin” it to the menu. Notes that
are pinned to the panel menu have a thumbtack icon that look like this: . Notes that
are not pinned to the panel menu have thumbtack icons that look like this: .
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12.5 Formatting Text in Notes
You can use the Text button on the Tomboy toolbar to format text within your notes.
The Text button displays a drop-down menu with the following options:

Undo
Allows you to revert previous changes made to your note during the current session.
To undo your last change using the keyboard, press Ctrl + Z.

Redo
Allows you to put back changes that were removed using theUndo feature. To redo
your last change using the keyboard, press Shift + Ctrl + Z.

Bold
To make text within your note bold, select the text you want to modify, then select
the Bold option from the Text drop-down menu. You can also press Ctrl + B after
selecting text.

Italic
To make text within your note italic, select the text you want to modify, then select
the Italic option from the Text drop-down menu. You can also press Ctrl + I after
selecting text.

Strikeout
Puts a line through the selected text. To add a strikeout, select the text you want,
then select the Strikeout option from the Text drop-down menu. You can also press
Ctrl + S after selecting text.

Highlight
Puts a yellow background around the selected text. To add a highlight, select the
text you want, then select the Highlight option from the Text drop-down menu.
You can also press Ctrl + H after selecting text.

Fixed Width
The fixed width style allows text to use a fixed width font. To change existing text,
select the text you want to modify, then select the Fixed Width option from the Text
drop-down menu. You can also select the Fixed Width option from the Text drop-
down menu before you start typing to have the text you type be in a fixed width
style.
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Font Size
There are four options in this part of the menu: Small, Normal, Large, and Huge.
Each of these options represents a font size you can use for the selected text in the
note. To modify the font size, select the text you want to modify, then select one
of the Font Size options from the Text drop-down menu.

Bullets
Select the Bullets option from the Text drop-down menu in order to begin or end
a bulleted list. If your cursor is inside a bulleted list, the Increase Indent and De-
crease Indent options are enabled.

For more information on bullets, see Section 12.5.1, “Using Bulleted Lists”
(page 140).

Increase Indent
With the cursor on a bulleted list line, select this option to shift the current line to
the right.

Decrease Indent
With the cursor on a bulleted list line, select this option to shift the current line to
the left.

Find in This Note
Lets you search for text within the current note. Selecting this option causes a Find
bar to open at the bottom of the note. To open the Find bar using the keyboard,
press Ctrl + F.

Enter the text you want to find. After entering text, all matches are highlighted.
Click Next to highlight the next match and place the cursor there. Click Previous
to move to the previous match.

To close the find bar, click X on the far left or press the Escape key.

12.5.1 Using Bulleted Lists
Tomboy's bulleted lists are useful for creating hierarchically-structured content. Creation
and formatting of bulleted lists is described in this section.
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Beginning a Bulleted List
To begin a bulleted list, use any of the following methods:

• Select Bullets from the Text drop-down menu.

• Write a line of text immediatelly after the automatically created bullet, then press
Enter.

Ending a Bulleted List
To end a bulleted list, do any of the following:

• Select Bullets from the Text drop-down menu.

• Press Enter on a blank bulleted line.

• Select Decrease Indent from the Text drop-down menu until the current line is no
longer part of the bulleted list.

• Press Shift + Tab until the current line is no longer part of the bulleted list.

Increasing Indentation
To increase the line indentation in a bulleted list, select Increase Indent from the Text
drop-down menu, or press the Tab key.

Decreasing Indentation
To decrease the line indentation in a bulleted list, select Decrease Indent from the Text
drop-down menu, or press Shift + Tab.

12.6 Exporting Notes to HTML
You can create an HTML (Hypertext Markup Language) document from one or more
notes.
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1 In the note you want to export, select the Export to HTML option from the Tools
drop-down menu.

2 Specify where to save the HTML file.

3 If you want to export any notes for which a link exists in the current note, select
Export linked notes. To export all notes for which a link exists in any of the notes,
select Include all other linked notes.

4 Click Save.

12.7 Deleting Notes
To delete a note, click the Delete button on the Tomboy toolbar. You will see a dialog
box asking if you want to permanently delete the note and its contents. Click Delete to
discard the note permanently, or click Cancel to abort the process.

Links to this note from other notes will still exist, but will re-create the note upon acti-
vation.

12.8 Printing Notes
Select the Print option on the Tools drop-down menu to print the current note. You will
be presented with the standard GNOME print dialog box.

12.9 Configuring Tomboy Preferences
To modify preferences for Tomboy, right-click the Tomboy icon ( ) on the GNOME
panel, then select Preferences. You can set preferences related to Editing, Hotkeys,
Synchronization and Add-ins on relevant tabs.

12.9.1 Editing Preferences
The Editing tab of the Preferences dialog lets you set options related to editing of notes.
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Figure 12.4 Tomboy Editing Preferences

The Editing preferences include the following:

Spell check while typing
Underlines misspellings in red, and provides suggestions in the right-click context
menu.

Highlight WikiWords
Creates links for phrases ThatLookLikeThis. Clicking the link creates a new
note with the title corresponding to the link text.

Use custom font
Sets a custom font to be used in your notes. If this option is disabled, the default
system font will be used.

New note template
Sets the default text that is used for any newly-created note.
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12.9.2 Hotkey Preferences
The Hotkeys tab of the Preferences dialog lets you set global key combinations to per-
form different functions in Tomboy. To set key combinations, the Listen for Hotkeys
checkbox must be selected. Press Alt + H to toggle this option on or off.

Figure 12.5 Tomboy Hotkey Preferences

The Hotkey preferences include the following:

Show notes menu
Specify the key combination to open the notes menu.

Open “Start Here”
Specify the key combination to open the “Start Here” note, which is pre-installed
with Tomboy.

Create new note
Specify the key combination to create a new note.

Open “Search All Notes”:
Specify the key combination to open the Search All Notes dialog box.
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12.9.3 Synchronization Preferences
The Synchronization tab of the Preferences dialog lets you share notes, announce notes,
receive announcements, and get notes from other instances of Tomboy. This can be
useful, for example, if you want to work on a single set of notes in separate instances
of Tomboy running on your desktop and your laptop.

Figure 12.6 Tomboy Synchronization Preferences

The Synchronization preferences include the following:

Service
Specify the location of the synchronized files. By default, you can select a local
folder or WebDAV server. To synchronize to a remote location, click the Add-ins
tab, select Synchronization > SSH Sync Service Add-in, then click Enable. This
adds an SSH (sshfs FUSE) option to the Service drop-down list.

Specify the information required for the Service you selected, then click Save.

Advanced
Specify what happens when a conflict is detected between a local note and a note
on the configured synchronization server. You can choose to be prompted when a
conflict occurs, to rename the local note, or to replace the local note with the note
on the synchronization server.
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Clear
Clears your current synchronization settings. If you choose to clear your synchro-
nization settings, you might have to synchronize your notes again when you save
new settings.

To synchronize your notes, click Tools > Synchronize Notes in any open note.

12.9.4 Add-ins Preferences
The Add-ins tabbed page lets you enable and configure Tomboy add-ins (formerly
called plugins). Tomboy comes with several pre-installed add-ins, such as Backlinks,
Bugzilla Links, Evolution Mail Integration, Export to HTML, Fixed Width, Note of
the Day, Printing Support, and Sticky Notes Importer.

The list of installed add-ins is shown on the left of the Add-ins tabbed page. To enable
or disable an add-in, select the plugin you want, then click Enable or Disable.

Figure 12.7 Tomboy Add-ins Preferences

Additional add-ins can be found in the Tomboy Add-ins [http://live.gnome
.org/Tomboy/PluginList] page. Place new add-ins in the $HOME/.tomboy/
addins folder.
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13Kopete: Instant Messaging
Kopete is an online messenger application allowing multiple partners connected to the
Internet to chat with each other. Kopete currently supports all common messenger
protocols, such as AOL* Instant Messenger (AIM), GroupWise® Messenger, ICQ,
Jabber*, SMS, Skype*, WinPopup and Yahoo!*.

13.1 Configuring Kopete
Before you can chat with your friends, you need to create an account:

1 Open Kopete by pressing Alt + F2 and entering kopete. If Kopete does not
start, check if the package kopete is installed.

2 Select Settings > Configure and click Add Accounts.... The configuration wizard
appears.

3 Select your messaging service. Generally, this is mostly determined by what
service your friends are using.

4 If the messaging services requires registration but you do not have an account
for this service yet, click Register New Account. In the browser window that
opens, enter your user data to register.

5 Switch back to Kopete and enter the data received on registration with the mes-
saging service. This usually consists of the nickname or email address and a
password. Complete the configuration of your account by clicking Finish.
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After you have configured your account you need to add contacts to chat with them. If
you have already created an account on another PC, this data is imported and automat-
ically added to your contact list after login. To manually create a contact entry, click
File > Add Contact. A new assistant appears to help with creation. However, you must
be online and connect with Kopete to the selected messaging service to add a contact
to your list.

13.2 Chatting with Friends
It is necessary to be connected to the Internet to be able to chat with other participants.
When this is done, you should set your status by clicking File > Set Status > Online.
This establishes a connection between Kopete and the selected messaging service. After
the successful login, you are visible to others.

The main application windows features a list of contacts. You must have contacts to
chat with others. To add a new contact, click on File > Add Contact and choose your
identity. After you have entered the relevant data (which can vary depending on your
account) you see your new contact. When you right-click a contact marked as online,
a menu opens with various options. Send that person amessage or start a chatting session.
A chat allows the invitation of additional participants for real-time discussion. Connec-
tion to all participants is closed when the creator of the chat session closes it.
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Figure 13.1 Chat Window

If you want to see your previous chat session, select a contact and go to Tools > Latest
History. This menu item shows your chat sessions with this person. Conversely, you
can select Edit > View History. This opens a window where you can see an overview
of all contacts and there saved messages.

You can view other options by right-clicking a username. A pop-up menu opens. An
important option is Start Chat to start a chatting session. With Rename Contact and
Remove Contact, you can run the relevant action. The pop-up menu also contains a
submenu item with the username where you can block the user or get user information.

TIP: Scrolling Through Old Chat Sessions

If you want to know what you wrote during one of the last chat sessions with
a person, click a contact to open the chat window again and press Alt + ← or
Alt + → to scroll through your sessions. Alternatively, use the arrow icons in
the toolbar to scroll back and forth.
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13.3 Customizing Kopete
Kopete offers numerous options to customize it according to your needs. Find some
examples in the following sections.

13.3.1 Adding Groups
Grouping contacts in your list can give a better overview. Click File > Create New
Group. Name the group and confirm this with OK. A new folder appears in the contact
list that can be used to store the desired contacts. Drag and drop contacts into the desired
folder.

Figure 13.2 The Main Kopete Window

Empty groups can be disabled by activating Settings >Hide Empty Groups. To customize
a special group only, right-click the relevant entry and select Properties in the popup
window that opens. Now change the icons or your notifications.

152 Application Guide



13.3.2 Using an Identity
Kopete canmanage several accounts, which is helpful if you have friends using different
messenger protocols. Each account can be associated with a different identity. This is
useful for privacy or business reasons. To create a new identity, proceed as follows:

1 In Kopete, select Settings > Configure and go to the Accounts tab. The configu-
ration window appears.

2 Select Add Identity... and enter a name, nickname, and other information.

3 If you want to use the new identity for different accounts, simply move your ac-
count into your new identity.

13.3.3 Configuring Notifications
Kopete allows you to configure notifications for events such as contacts coming online
or going offline or an incoming message for you. This can be done globally, for a spe-
cific group or a single contact.

To activate the notifications option proceed as follows:

1 Make sure all your contacts are shown in the Kopete window. If not, select Set-
tings > Show Offline Users.

2 Right-click your preferred contact and select Properties. The notification dialog
appears, see Figure 13.3
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Figure 13.3 Notification Dialog in Kopete

3 Go to the Custom Notification tab and select Contact Gone Online.

4 Decide which action should be executed for this event: Play a Sound, Show a
Message in a Popup, Log to a File, Mark Taskbar Entry, or Run Command.

5 Click OK to confirm your settings.

To modify the default notification options, select Settings > Notifications. Select which
event is important for you and change the notification settings. For example, if you
want to be informed by a sound when any of your contacts has come online, select A
contact has come online and activate Play a sound. Select the sound and click OK to
close the configuration dialog.
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13.3.4 Configuring Kopete Plug-ins
Kopete offers some nice extensions for you chat sessions which can be accessed from
Settings > Configure Plugins. For example, you can auto replace text, encrypt outgoing
messages, highlight text (if the message contains some interesting words), render LaTeX
formulas, or translate messages.

13.4 For More Information
More information about Kopete and chats can be found on the following Web sites:

• Kopete Home Page [http://kopete.kde.org]

• Common Abbreviations Used in Chat Sessions [http://www.webopedia
.com/quick_ref/textmessageabbreviations.asp]

• KDE Forum [http://www.kde-forum.org]
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14Pidgin: Instant Messaging
Pidgin (formerly called Gaim) is an instant messaging (IM) client that allows you to
connect to multiple accounts simultaneously. Chat live with your contacts in one tabbed
interface, regardless of which IM system they use. Pidgin supports the following instant
messaging protocols: AOL* Instant Messenger (AIM), Bonjour, Gadu-Gadu, Google
Talk, GroupWise Messenger, ICQ, IRC, Jabber/XMPP, MSN Messenger, Microsoft
Live Communication Server (LCS/OCS), MySpaceIM, QQ, SILC, SIMPLE, Yahoo!*,
and Zephyr*. Pidgin also supports many features of the various networks, such as file
transfer, away messages, and typing notification.

In the following, learn how to set up Pidgin and how to communicate with your contacts.

14.1 Configuring Accounts
To use Pidgin, you must already have accounts on the systems you want to use. For
example, to use Pidgin for your AIM account, you must first have an AIM account.
Once you have those accounts, set them up in the Pidgin Add Account dialog.

Procedure 14.1 Adding and Editing Accounts

1 Start Pidgin from the main menu or press Alt + F2 and enter pidgin. If Pidgin
does not start, check if the package pidgin is installed.

If you start Pidgin for the first time, a message appears, prompting you to config-
ure an account. Otherwise, Pidgin opens the Buddy List window, showing your
contacts.
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2 To add or edit an account from there, select Accounts >Manage Accounts.

3 In the Accounts dialog, click Add to add a new account or select an existing ac-
count and clickModify.

4 On the Basic tab, select the protocol. The dialog to add or modify accounts differs
for each protocol, depending on what setup options are available for that protocol.

5 Enter the data received on registration with the messaging service. This usually
consists of the username or email address and a password. Your protocol might
support additional options, such as a buddy icon, alias, login options, or others.

6 On the Advanced tab, enter the Server and Port you got from your messaging
service or system administrator.

7 Click Save.

8 If needed, add accounts for each additional protocol, as described above.

After an account is added, you can log in to that account by entering your password in
the Pidgin login dialog box. Use the Accounts menu to view and enable or disable ac-
counts that you have configured.
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14.2 Managing Your Contacts
Use the Buddy List to manage your contacts, also known as buddies. You can add and
remove buddies from your Buddy List, and you can organize your buddies in groups
so they are easy to find.

After your accounts are set up, all buddies who are online appear in your Buddy List.
If you want your buddies who are not online to appear in the Buddy List, click Buddies
> Show Offline Buddies.

Figure 14.1 Pidgin Buddy List

To add a buddy to your Buddy List, click Buddies > Add Buddy, then enter the informa-
tion about that buddy.

NOTE: Adding Contacts for Certain Protocols

For some protocols, you cannot add a buddy in the Pidgin interface. You must
use the client for those protocols if you want to add to your buddy list. After
you have added a buddy in the protocol’s client, that buddy appears in your
Buddy List.

To remove a buddy from the list of contacts, right-click on that buddy’s name in the
Buddy List and click Remove.

14.3 Chatting with Friends
It is necessary to be connected to the Internet to be able to chat with other participants.
After a successful login, you are usually marked as Available in the Buddy List, and
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thus visible to others. To change your status, click the drop-down list at the bottom of
the Buddy List and select another option.

To open a chat session, double-click a buddy name in the Buddy List. The Chat screen
opens. Type your message, then press Enter to send.

Each chat session you open appears as a tab in the Chat screen. Click on a buddy’s tab
to chat with that buddy. Close a chat session by closing the tab for that buddy.

Figure 14.2 Pidgin Chat Session

14.4 For More Information
This chapter explained the Pidgin options you need to know about to set up Pidgin and
communicate with your contacts. It does not explain all of Pidgin features and options.
For more information, open Pidgin, then click Help > Online Help or press F1.
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15Ekiga: Using Voice over IP
Modern telecommunication means far more than just making a phone call. It is also
about text messaging and sometimes even video conferencing. Roaming enables you
to be reachable under one phone number all across the world. Ekiga brings these features
to your Linux desktop, allowing you to communicate over broadband Internet.

Before starting, make sure that the following requirements are met:

• Your sound card is properly configured.

• A headset or a microphone and speakers are connected to your computer.

• For dialing in to regular phone networks, a SIP account is required. SIP (Signaling
protocol for Internet Telephony) is the protocol used to establish sessions for audio
and video conferencing or call forwarding. There are many VoIP providers all over
the world. For a quick start, have a look at the service that the Ekiga project provides
at http://www.ekiga.net.

• For video conferencing, a webcam is connected to your computer.

15.1 Configuring Ekiga
On first start, Ekiga opens a configuration assistant that requests all data needed to
configure Ekiga. Proceed as follows:
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1 Enter your full name (name and surname).

2 Enter your ekiga.net account data or choose not to sign up with http://
www.ekiga.net.

To add other accounts later, configure them using Edit > Accounts.

3 Enter your Ekiga Call Out Account data or choose not to sign up with
http://www.ekiga.net.

4 Determine your connection type.

5 Choose the audio ringing, output and input device driver. ALSA is a safe default
option which guarantees the best sound quality. Other sound systems, like OSS,
are also available on SUSE Linux Enterprise Desktop.

By default, there is no ringing device set. If you want a ring tone, change this to
one of your available audio devices.

6 Choose the video input device, if available.

7 Check the summary of your settings and apply them.

8 If registration fails after making changes to your configuration, just restart Ekiga.

Ekiga allows you to maintain multiple accounts. To configure an additional account,
proceed as follows:

1 Open Edit > Accounts.

2 Choose Accounts > Add <account type>. If unsure, select Add a SIP Account.

3 Enter the Registrar to which you want to register. This is usually an IP address
or a host name that will be given to you by your Internet Telephony Service
Provider. Enter User, and Password according to the data provided by your
provider.

4 Leave the configuration dialog with OK and activate the account. The status of
your account displayed in the Ekiga main window changes to Registered.
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15.2 The Ekiga User Interface
The Ekiga user interface has several tabs available. The first tab isContacts, the second
isDialpad and the last one isCall History. In addition, there is aCall Panel tab available,
which displays pictures and videos of local or remote webcams.

Figure 15.1 Ekiga User Interface

The user interface has different modes. To switch between views, use the tab line. By
default, Ekiga opens theContacts tab. There, a local addressbook lets you quickly open
connections to often-used numbers. To get a full view with webcam support and audio
controls, activate the Call Panel with View > Show Call Panel.

At the bottom of the Call Panel, there are icons for several controls like Audio Settings,
Video Settings, Video Display andHold Call. All icons provide a tool tip that is activated
by the mouse pointer hovering over the icon. Some settings like the Audio settings may
only be changed during a phone call.

Many of the functions of Ekiga are available with keyboard shortcuts. Table 15.1,
“Keyboard Shortcuts for Ekiga” (page 164) summarizes the most important ones.
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Table 15.1 Keyboard Shortcuts for Ekiga

DescriptionCtrl Sequence

Initiate a call with the current number.Ctrl + O

Hang up.Esc

Add a contact to your address book.Ctrl + N

Open the Address Book dialog.Ctrl + B

Hold the current call.H

Transfer the current call to another party.T

Suspend audio stream of the current call.M

Suspend video stream of the current call.P

Close the Ekiga user interface.Ctrl +W

Quit Ekiga.Ctrl + Q

Start the account manager.Ctrl + E

Activate Call Panel on the main user interface.Ctrl + J

Zoom in to the picture from the Web cam.Ctrl + +

Zoom out on the picture from the Web cam.Ctrl + -

Return to the normal size of the Web cam display.Ctrl + 0

Use full screen for the Web cam.F11
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15.3 Making a Call
Once Ekiga is properly configured, making a call is easy.

1 Start Ekiga using the menu or the command line.

2 Enter the SIP address of the party to call at the SIP address prompt. The address
should look like:

• for direct local calls: sip:username@domainname or
username@hostname

• sip:username@domainname or userid@sipserver

3 Click Call or press Ctrl + O and wait for the other party to pick up the phone.

4 To end the call, click Hang up or press Esc.

If you need to tweak the sound parameters during a call, click on the Audio Settings
icon in the Call Panel. A window with the Audio options for Playback level and
Recording level is displayed. Use the sliders to adjust the levels to fit your needs.

15.4 Answering a Call
Ekiga can receive calls in two different ways. First, the user may be called directly with
sip:user@host, or via SIP provider. Most SIP providers enable you to get calls
from a normal land-line to your VoIP account. Depending on the mode in which Ekiga
is run, there are several ways in which you are alerted to an incoming call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already running. You
can hear the ring sound on your headset or your speakers. If Ekiga is not running,
the call cannot be received.
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Panel Applet
Normally, the Ekiga panel applet would run silently without giving any notice of
its existence. This changes as soon as a call comes in. The main window of Ekiga
opens and you hear a ringing sound on your headset or speakers.

Once you have noticed an incoming call, just click Accept to answer the call then start
talking. If you do not want to accept this call, click Reject. It is also possible to transfer
the call to another SIP address.

15.5 Using the Address Book
Ekiga has the ability to manage your SIP contacts. All of the contacts are displayed in
the Contacts tab, shown in the main window after startup. To add a contact or a new
contact group, run Chat > Add Contact.

If you want to add a new group, enter the group name into the bottom input field and
press Add. The new group is then added to the group list and preselected.

The following entries are required for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here.

Address
Enter a valid SIP address for your contact.

Groups
If you have many different contacts, add your own groups.

To call a contact from the address book, double-click this contact. The call is initiated
immediately.

15.6 For More Information
The official home page of Ekiga is http://www.ekiga.org/. This site offers
answers to frequently asked questions as well as more detailed documentation.
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For information about the support of the H323 teleconferencing protocol in Linux, see
http://www.voip-info.org/wiki/view/H.323. This is also a good starting
point when searching for projects supporting VoIP.

To set up a private telephone network, you might be interested in the PBX software
Asteriskhttp://www.asterisk.org/. Find information about athttp://www
.voip-info.org/wiki-Asterisk.
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16Konqueror: Browsing the Web
Konqueror is a modern Web browser, but can also be used as a file manager. However,
to manage your files and directories, it is recommended using Dolphin. If you start the
browser with the icon in the panel, Konqueror opens with the Web browser profile. As
a browser, Konqueror offers tabbed browsing, the possibility of savingWeb pages with
graphics, Internet keywords, bookmarks, and support for Java and JavaScript.

Figure 16.1 The Browser Window of Konqueror

Start Konqueror from the main menu or by entering the command konqueror. If
Konqueror does not start, check if the package kde4-konqueror is installed. To
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load a Web page, enter its address in the location bar, for example http://www
.opensuse.org. Konqueror now attempts to reach the address and displays the
page. Entering the protocol at the beginning of the address (http:// in this case) is
not strictly required. The program is able to complete the address automatically, but
this only works reliably withWeb addresses. For an FTP address, always enter ftp://
at the beginning of the input field.

16.1 Tabbed Browsing
If you often use more than oneWeb page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window. The ad-
vantage is that you keep more control over your desktop because you only have one
main window. After logout, the KDE session management allows you to save your
Web session in Konqueror. The next time you log in, Konqueror loads the exact URLs
visited last time.

To open a new tab, selectWindow > New Tab or press Ctrl + T. To change the behavior
of tabs, go to Settings > Configure Konqueror. In the dialog box that opens, select
General and enableOpen links in new tab instead of in new window. You can also hide
the tab bar with Hide the tab bar When only one tab is open.

16.2 Automatic Scrolling
In general, scrolling with the mouse is the normal way to view information further down
a page. However, there are occasions when it is preferable not to use a mouse. It can
be very convenient to use key combinations instead of removing your hands from the
keyboard.

To scroll down automatically, use Shift + ↓. This scrolls down the page without further
intervention. Increase the speed by pressing Shift + ↓ again. Pressing Shift + ↑ slows
down. To stop scrolling, use ↓.
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16.3 Profiles
Section 16.1, “Tabbed Browsing” (page 172) described how to handle tabs in Konqueror.
You can save your tabs with URLs and the position of the window in a profile. This
differs from the session management already mentioned.With profiles, your saved tabs
are at hand without the intensive start-up time of session management.

To create a profile, do the following:

1 Go to Settings > Configure View Profiles.

2 In the dialog box that appears, insert a name in Profile Name.

3 To save your URLs, select Save URLs in Profile.

4 Approve with Save.

The next time you need your tab collection, go to Settings > Load View Profile and find
the name listed in the menu. After you select it, Konqueror restores your tabs.

16.4 Saving Web Pages and Graphics
As in other browsers, you can save Web pages. To do this, select File > Save As and
specify a name for your HTML file. However, images are not saved. To archive an
entire Web page including the images, select Tools > Archive Web Page. Konqueror
suggests a filename that you can usually accept. The filename ends with .war, the
extension for Web archives. To view the saved Web archive later, simply click the rel-
evant file and the Web page is displayed in Konqueror along with images.

16.5 Searching with Konqueror
Searching with Konqueror is very convenient. You can use the search bar or Web
shortcuts.
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16.5.1 Using the Search Bar
Konqueror contains a search bar where you can choose from many search engines. If
you want to search for a specific term, proceed as follows:

1 Locate the search bar in Konqueror. It is on the right side after the location bar.

2 Click the icon inside the search bar. Choose a search engine from the pop-up
menu.

3 Insert your search term and press Enter. The result is displayed in Konqueror.

If you need a search engine that is not listed in the pop-up menu, add it as follows:

Procedure 16.1 Adding More Search Engines

1 In Konqueror, click the icon in the search bar.

2 Choose Select Search Engines....

3 Make sure that Enable web shortcuts is activated.

4 Enable the relevant search engine and close the dialog with OK. You can see
your selected search engine when you click the icon in the search bar.

16.5.2 Using Web Shortcuts
Each search engine defined is attached to a web shortcut. This shortcut can be entered
in the location bar.

To see which search engines are already defined, go to Settings > Configure Konqueror
>Web Browsing >Web Shortcuts. You can see the names of the search providers and
the shortcuts. Konqueror defines many search engines: Google, Yahoo, Lycos, and a
number of less common resources like an acronym database, the Internet movie database,
and KDE application searches.

If you do not find your preferred search engine here, you are able to define a new one
very easily. For example, to search our home page for some interesting articles, go to
http://en.opensuse.org/, enter your query and look for the appropriate results.
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Procedure 16.2 Creating New Web Shortcuts

1 Go to the search bar, click the icon, and select Select Search Engines.

2 Make sure that Enable web shortcuts is activated.

3 Click New.

4 Create a new web shortcut:

4a Assign your web shortcut a name in Search provider name.

4b Enter the search URI. For example, if you want to search in openSUSE, use
http://en.opensuse.org/Special:Search?search=\{@}.
The search query is specified as \{@}. Get more information by clicking in
the text field labeled with Search URI and pressing Shift + F1.

4c Enter your abbreviations in URI Shortcuts. There you can enter more than
one, separated by commas.

5 Proceed with OK.

After creating a new Web shortcut, you can use it in the location bar. The result is dis-
played in the current window.

TIP: Using Shortcuts Directly without Opening Konqueror

You do not need to open Konqueror and enter the Web shortcut. You can use
it directly: select Run Command from the main menu or press Alt + F2. After
the dialog box appears, enter your shortcut, a colon (:), and your search term.

16.6 Bookmarks
Instead of remembering and reentering addresses for sites visited often, you can book-
mark these URLs using the Bookmark menu. As well as Web page addresses, you can
also bookmark the directories of your local disk in this way.
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To create a new bookmark in Konqueror, click Bookmarks > Add Bookmark. Any pre-
viously added bookmarks are included as items in the menu. It is a good idea to arrange
the bookmark collection by subjects in a hierarchical structure, so that you do not lose
track of the different items. Create a new subgroup for your bookmarks with New
Bookmark Folder. Selecting Bookmarks > Edit Bookmarks opens the bookmark editor.
Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape,Mozilla, or Firefox as additional browsers, it is not necessary
to recreate your bookmarks. File > Import > Import Netscape Bookmarks in the book-
mark editor enables you to integrate your Netscape and Mozilla bookmarks into your
most current collection. The reverse is also possible via Export as Netscape Bookmarks.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which
to select the desired action (cut, copy, delete, etc.).When you are satisfied with the result,
save the bookmarks with File > Save. If you only want to change the name or link, just
right-click the entry in the bookmark toolbar and select Properties. Change the name
and location and confirm with Update.

To save your bookmark list and have instant access to it, make your bookmarks visible
in Konqueror. Select Settings > Toolbars >Bookmark Toolbar (Konqueror). A bookmark
panel is automatically displayed in the current Konqueror window.

16.7 Java and JavaScript
Do not confuse these two languages. Java is an object-oriented, platform-independent
programming language from SunMicrosystems. It is frequently used for small programs
(applets), which are executed over the Internet for things like online banking, chatting,
and shopping. JavaScript is an interpreted scripting language mainly used for the dy-
namic structuring of Web pages, for example, for menus and other effects.

Konqueror allows you to enable or disable these two languages. This can even be done
in a domain-specific way, which means that you can permit access for some hosts and
block access for others. Java and JavaScript are often disabled for security reasons.
Unfortunately, some Web pages require JavaScript for correct display.
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16.8 Enabling Advertisement Blockers
Some Web pages open annoying advertisements. With the help of Konqueror, these
windows can be blocked. Proceed as follows:

Procedure 16.3 Blocking Advertisements

1 Select Settings > Configure Konqueror >Web Browsing > AdBlock Filters in
Konqueror.

2 Activate Enable filters.

3 Enter an expression for the Web page to filter. For example:
http://www.example.com/*

This filters everything that comes from that URL.

4 Click Insert.

If you need the entries on another computer, click Export, save the file, move it to your
other computer and import it there in Konqueror from the same dialog box.

16.9 For More Information
For any questions or problems that arise when working with Konqueror, refer to the
application's handbook, which is available from the Help menu. Konqueror also has a
Web page, located at http://www.konqueror.org.
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17Firefox: Browsing the Web
Included with your SUSE® Linux Enterprise Desktop is the Mozilla Firefox Web
browser. With features like tabbed browsing, pop-up window blocking and download
and imagemanagement, Firefox combines the latest browsing and security technologies
with an easy-to-use interface. Using tabs, you can view more than one Web page in a
single window. You can suppress annoying advertisements and disable images for faster
browsing. Firefox's easy access to different search engines helps you find the information
you need.

Start Firefox from the main menu or by entering the command firefox. The main
program features are described in the following sections.

17.1 Navigating Web Sites
Firefox has much of the same look and feel as other browsers. It is shown in Figure 17.1,
“The BrowserWindow of Firefox” (page 180). The navigation toolbar includesForward
and Back, the smart location bar for a Web address, and the search bar. Bookmarks are
also available for quick access from the bookmarks toolbar. For more information about
the various Firefox features, use the Help menu.

Firefox: Browsing the Web 179



Figure 17.1 The Browser Window of Firefox

17.1.1 The Smart Location Bar
When typing into the location bar, an auto-completion drop-downmenu opens, showing
the addresses matching what you have typed. The phrase that is matched is highlighted
with bold letters. The drop-downmenu shows all matching addresses, bookmarks, page
titles and tag names from your browsing history and your bookmarks list. Matching
even works across word boundaries. Entries visited most frequently and recently are
listed first.

List entries from the bookmark list are marked with a star. Bookmarks with tags are
marked with an additional label followed by the tag names. List entries from the
browsing history are not marked.

Use ↑ and ↓ or the mouse wheel to scroll through the list. Press Enter or click on an
entry to go to the selected page. Del removes an entry from the list if it is an entry from
the history. Bookmarked entries can only be removed by deleting the associated book-
mark.

17.1.2 Zooming
Firefox offers two zooming options: page zoom, the default, and text zoom. Page view
zooms the entire page as is, with all elements of a page, including graphics, expanding
equally while text zoom only changes the text size.
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To toggle between page and text zoom, choose View > Zoom > Zoom Text Only. To
zoom in or out either use the mouse wheel while holding the Ctrl key, or use Ctrl + +
and Ctrl + -. Reset the zoom factor with Ctrl + 0

17.1.3 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing makes it easier to
switch between pages. It allows you to load Web sites in separate tabs within one win-
dow.

Opening tabs
To open a new tab, select File > New Tab or press Ctrl + T. This opens an empty
tab in the Firefox window. To open a link on a web page or a bookmark in a tab,
middle-click it. Alternatively, right-click a link and select Open Link in New Tab.
You may also open an address in the location bar in a new tab with a middle-click
or by pressing Ctrl + Enter.

Closing Tabs
Right-click on a tab to open a context menu, giving you access to tab managing
options such as closing, reloading, or bookmarking. To close a tab, you may also
use Ctrl +W or click the close button. Any closed tab can be restored by choosing
from History > Recently Closed Tabs. In order to reopen the last closed tab either
choose Undo Close Tab from the context menu or press Ctrl + Shift + T.

Sorting Tabs
By default, tabs are sorted in the order you opened them. Rearrange the tab order
by dragging and dropping a tab to the desired position. If you have opened a large
number of tabs, they will not all be displayed in the tab bar. Use the arrows at the
ends of the bar to move left or right-click on the down arrow at the right end of the
tab bar to get a list of all tabs.

Dragging and Dropping
Drag and drop also works with tabs. Drag a link onto an existing tab to open it in
that tab or drag and drop a link on an empty space in the tab bar to open a new tab.
Drag and drop a tab to the desktop to open it in a new browser window.
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17.1.4 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or browsing history.
Extensions may add new ways to use the sidebar as well. To display the sidebar, select
View > Sidebar and select the desired contents.

17.2 Finding Information
There are two ways to find information in Firefox: use the search bar to search the In-
ternet with a search engine or the find bar to search the page currently displayed.

17.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines like Google, Yahoo, or
Amazon. For example, if you want to find information about SUSE using the current
engine, click in the search bar, type SUSE, and hit Enter. The results appear in your
window. To choose your search engine, click the icon to the left of the search bar. A
menu opens with a list of available search engines.

Customizing the Search Bar
If you want to change the order, add, or delete a search engine, establish an Internet
connection and proceed as follows.

1 Click the icon to the left of the search bar.

2 SelectManage Search Engines from the menu.

3 Click Remove to delete an entry andMove Up/Down to change the order.

To add a search engine, click Get More Search Engines. Firefox displays a Web
page with available plug-ins. You can choose from Wikipedia, IMDB, Flickr,
and numerous others. Click Download Now to install it.
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Figure 17.2 Manage Search Engines

Some Web sites offer search engines that you can add directly to the search bar.
Whenever you enter such a Web site, the icon to the left of the search bar turns blue.
Click on the icon and select the “Add” entry from the menu.

Adding Smart Keywords to Your Online Searches
Firefox lets you define your own smart keywords: abbreviations to use as a URL
shortcut for a particular search engine. If you define ws as a smart keyword for the
Wikipedia search for example, you can now type ws SEARCHTERM into the location
bar to search Wikipedia for SEARCHTERM.

To assign a shortcut for a search engine from the search bar, click the icon to the left
of the search bar and open theManage Search Engines dialog. Mark a search engine
and open the Edit Keyword dialog.

It is also possible to define a smart keyword for any search field on aWeb site. Proceed
as follows:

1 Right-click on the search field and choose Add a Keyword for this Search from
the menu that opens. The Add Bookmark dialog appears.
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2 In Name, enter a descriptive name for this smart keyword.

3 Enter your Keyword for this search.

4 Choose the location where to save this smart keyword with Create In.

5 Finalize with Add.

TIP: Smart Keywords for Regular Web sites

Using smart keywords is not restricted to search engines. You can also add a
smart keyword to a bookmark (via the bookmark's properties). For example,
if you assign nov to the Novell home page bookmark, you can open it by just
typing nov into the location bar.

17.2.2 Searching in the Current Page
To search inside a Web page, click Edit > Find in This Page or press Ctrl + F. The find
bar opens. It is usually displayed at the bottom of a window. Type your query in the
input field. Firefox finds the first occurrence of this phrase as you type. You can find
other occurrences of the phrase by pressing F3 or the Next button in the find bar.
Clicking theHighlight All button will highlight all occurrences of the phrase. Checking
theMatch Case option makes the query case-sensitive.

Firefox also offers two quick-find options. Click anywhere you like to start a search on
aWeb page, type the key / immediately followed by the search term. The first occurrence
of the search term will be highlighted as you type. Use F3 to find the next occurrence.
It is also possible to limit quick-find to links only. This search option is available by
typing the key '.

17.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. Firefox
not only makes it very easy to add new bookmarks with just one mouse click, it also
offers multiple ways to manage large bookmark collections. You can sort your book-
marks into folders, create filtered views (called smart bookmarks) that will be updated
on the fly, or you can classify bookmarks with tags.
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Add a bookmark by clicking on the star in the location bar. The star will turn yellow
to indicate the page is bookmarked. Clicking once will save the bookmark in the Un-
sorted Bookmarks folder under the page title. Double clicking on the star opens a menu
which lets you choose a location where to save the bookmark and lets you enter a name
and tags. Bookmarking tabs is done via the context menu. Right-click in a tab and
choose whether to Bookmark This Tab or to Bookmark All Tabs. In the latter case
Firefox asks you to create a new folder for the tab links. To remove or edit a bookmark,
open it and click on the star in the location bar.

17.3.1 Organizing Bookmarks
The Library can be used to manage the properties (name and address location) for each
bookmark and organize the bookmarks into folders and sections. It resembles Fig-
ure 17.3, “The Firefox Bookmark Library” (page 185).

Figure 17.3 The Firefox Bookmark Library

To open the Library, click Bookmark > Organise Bookmarks. The library window is
split into two parts: the left pane shows the folder tree view, the right pane the subfolders
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and bookmarks of the selected folder. Use Views to customize the right pane. The left
pane contains three main folders:

History
Contains your complete browsing history. You cannot alter this list other than by
deleting entries from it.

Tags
Lists bookmarks for each tag you have specified. See Section 17.3.2, “Tags”
(page 187) for more information on tags.

All Bookmarks
This category contains the three main bookmark folders:

Bookmarks Toolbar
Contains the bookmarks and folders displayed beneath the location bar. See
Section 17.3.6, “The Bookmarks Toolbar” (page 189) for more information.

Bookmarks Menu
Holds the bookmarks and folder accessible via the Bookmarks entry in the
main menu or the bookmarks side menu.

Unsorted Bookmarks
Contains all bookmarks created with a single click on the star in the location
bar. This folder is only visible in the library and the bookmarks sidebar.

Organize your bookmarks using the right pane. Choose actions for folders or bookmarks
either from the context menu that opens when you right-click on an item or from the
Organise dialog. The properties of a chosen folder or bookmark can be edited in the
bottom part of the right pane. By default, only Name, Location, and Tags are displayed
for a bookmark. ClickMore to gain access to all properties.

Use drag and drop to rearrange your bookmarks. Left-click a bookmark and drag it to
a new position while holding the mouse button pressed. Drop it by releasing the mouse
button. You can use this technique to move a bookmark or a folder to a different folder,
or to change the order of bookmarks in a folder.
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17.3.2 Tags
Tags offer a convenient way to file a bookmark under several categories. You can tag
a bookmark with as much terms as you want. For example, to access all sites tagged
with suse enter suse into the location bar. Whats more, a smart bookmark folder for
each tag is automatically created in the tags folder of the library. Drag and drop a smart
bookmark for a tag onto your bookmark toolbar or into a folder of your bookmarks
menu to easily access it.

To add tags to a bookmark, open the bookmark in Firefox and click on the yellow star
in the location bar. The Edit This Bookmark dialog opens where you can add a comma
separated list of tags. It is also possible to add tags via the bookmark's properties dialog
which you can open in the library or by right-clicking on a bookmark in the menu or
the toolbar.

17.3.3 Importing and Exporting Bookmarks
If you used a different browser in the past, you probably want to use your old bookmarks
in Firefox, too. Firefox can automatically import bookmarks from other browsers in-
stalled on your system, such as Netscape or Opera. You also can import bookmarks
from a file exported from a browser on different computer or from a backup.

To import bookmarks from another browser or from a file in HTML format, open the
library by choosing Bookmarks > Organise Bookmarks. Start the Import Wizard by
choosing Import and Backup > Import HTML... and choose an import location. Start
the import by clickingNext. Bookmarks from another browser are imported to a separate
folder under the bookmarks menu named FromBrowser Name. Imports from an
HTML file are imported as is.

Exporting bookmarks is also done via the Import and Backup dialog in the library
window. To save your bookmarks as an HTML file, choose Export HTML.... In order
to create or restore a backup of your bookmarks, choose Backup... or Restore. Firefox
uses the JavaScript Object Notation file format (.json) for backups.
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17.3.4 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites. Live bookmarks update automatically.

Many sites and blogs support this format. AWeb site indicates this by showing an orange
icon in the right part of the location bar. Click the icon and choose Subscribe Now in
the page that opens. A dialog box opens in which to select the name and location of
your live bookmark. Confirm with Add. This page also lets you choose alternative ap-
plications to subscribe to, such as Bloglines, or My Yahoo.

17.3.5 Smart Bookmarks
Smart bookmarks are virtual bookmark folders that are dynamically updated. By default,
three smart bookmark folders are already predefined: theMost Visited links are available
from your bookmarks toolbar, Recently Bookmarked links and Recent Tags are located
in the bookmarks menu. You can create new smart bookmarks by searching for certain
entries in your library.

To create a new smart bookmark, open the library by choosing Bookmarks > Organise
Bookmarks and proceed as follows:

1 Either select one of the main folders (History, Tags, All Bookmarks) or a specific
bookmarks folder.

2 Enter a search term into the input field, for example Linux. This will do a case
insensitive search for all links containing the phrase Linux in either the Web
page title, the tags, or the URL.

3 Save the search to create a new smart bookmark. A smart bookmark will always
be saved to the bookmarks menu folder—drag and drop it to the desired location.

TIP

Creating a smart bookmark from your saved bookmarks creates an up-to-date
filtered view on your bookmarks that only changes when you add or delete
bookmarks matching the search term.
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A smart bookmark folder based on your browsing history dynamically changes
as you surf the Web. Every time you browse a site that matches the search
term, it gets “added” to your smart bookmark. For this reason, it is recommend-
ed to use search terms that are as specific as possible. If you are interested in
links to SUSE Linux-specific topics as opposed to general Linux topics, use SUSE
Linux rather than Linux.

WARNING

Clearing the private data also deletes the browsing history (unless configured
otherwise) and so will also clear history based smart bookmarks!

17.3.6 The Bookmarks Toolbar
The Bookmarks Toolbar is displayed beneath the location bar and lets you
quickly access bookmarks. You can also add, organize, and edit bookmarks directly.
By default, theBookmarks Toolbar is populatedwith a predefined set of bookmarks
organized into several folders (see Figure 17.1, “The Browser Window of Firefox”
(page 180)).

To manage the Bookmarks Toolbar you can use the library as described in Sec-
tion 17.3.1, “Organizing Bookmarks” (page 185). Its content is located in the Bookmarks
Toolbar Folder. It is also possible to manage the toolbar directly. To add a folder,
bookmark, or separator, right-click on an empty space in the toolbar and choose the
appropriate entry from the pop-up menu. To add the current page to the bar use drag
and drop: left-click on the Web page's icon in the location bar and drag it to the desired
position on the bookmarks toolbar while pressing the mouse button. Hovering over an
existing bookmark folder will automatically open it, enabling you to place the bookmark
within this folder.

To manage a certain folder or bookmark, right-click on it. A pop-up menu opens which
lets you Delete it or change its Properties. To move or copy an entry, choose Cut, or
Copy and Paste it to the desired position.
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17.4 Using the Download Manager
Keep track of your current and past downloads with the help of the download manager.
It automatically opens every time you download a file. To manually start the download
manager, click Tools > Downloads. While downloading a file, a progress bar indicates
the download status. If necessary, pause the download and resume it later. To open a
downloaded file with the associated application, click Open. To open the location to
which the file was saved, choose Open Containing Folder. Remove From List only
deletes the entry from the download manager, it does not delete the file from the hard
disk.

By default, all files are downloaded to the Download folder in your home directory.
To change this behavior, open the download manger's configuration window from Edit
> Preferences and go to theMain tab. In the Download area, either choose another lo-
cation or Always Ask Me Where to Save Files.

TIP: Resuming Downloads

If your browser crashes or is closed while downloading, all pending downloads
will automatically be resumed in the background when starting Firefox the next
time. A download that was paused before the browser was closed can manually
be resumed via the download manager.

17.5 Security
Since browsing the Internet has become more risky, Firefox offers various measures
to make browsing safer. It automatically checks whether you are trying to access a site
known to contain harmful software (malware) or a site known to steal sensitive data
(phishing) and stops you from entering these sites. The Instant Web Site ID lets you
easily check a site's legitimacy, and a password manager and the pop-up blocker offer
additional security. With Private Browsing you can surf the Internet without Firefox
recording any data on your computer.
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17.5.1 Instant Web Site ID
Firefox allows you to check the identity of a Web page with a single glance. The color
of the Web site's icon (also called favicon) in the location bar to the left of the address
indicates which identity information is available and whether communication is encrypt-
ed or not:

Gray
The site does not provide any identity information and communication between
Web server and browser is not encrypted. This is fine as long as you do not exchange
sensitive information with this site. Most web sites will be “gray”.

Blue
This site is from a domain that has been verified by a certificate, so you can be sure
that you are really connected to the very site it claims to be. Communication with
a “blue” server is always encrypted.

Green
This site completely identifies itself by a certificate that ensures a site is owned by
the person or organization it claims to be. This is especially important when ex-
changing very sensitive data (for example when doing money transactions over the
Internet). In this case you can be sure to be on your bank's Web site when it sends
complete identity information. Communication with a “green” server is always
encrypted.

To view detailed identity information, click the Web site's icon in the location bar. In
the opening pop-up click onMore Information... to open the Page Info Window. Here,
you can view the site's certificate and the encryption level, as well as information about
stored passwords and cookies.

With the Permissions view you can set per-site permissions for image loading, pop-
ups, cookies and installation permissions. TheMedia view lists all images, background
graphics and embedded objects from a site and displays further information on each
item together with a preview. It also lets you save each individual item.
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Figure 17.4 The Firefox Page Info Window

17.5.2 Password Management
Each time you enter a username and a password on a Web site, Firefox offers to store
this data. A new toolbar on top of the page opens, asking you whether you want Firefox
to remember the password. If you accept by clicking Remember, the password will be
stored on your hard disk in an encrypted format. The next time you access this site,
Firefox will automatically fill in the login data.

To review or manage your passwords, open the password manager by clicking Edit >
Preferences > Security > Saved Passwords.... The password manager opens with a list
of sites and their corresponding usernames. By default, the passwords are not displayed.
You can click on Show Passwords to display them. Delete single or all entries from the
list using Remove or Remove All, respectively.

To protect your passwords from unauthorized access, you can set a master password
that is required when managing or adding passwords. Open the Security tab on the
Preferences dialog and check Use a Master Password.
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17.5.3 Private Browsing
By default, Firefox keeps track of your browsing history by storing content and links
of visited websites, cookies, downloads, passwords, search terms and formula data.
Collecting and storing this data makes browsing faster and more convenient. However,
when you use a public terminal or a friend's computer, for example, you might want to
turn it off. In Private Browsing mode Firefox will not keep track of your browsing
history nor will it cache the content of pages you have visited.

Enable the Private Browsing mode by either clicking Tools > Start Private Browsing
or by pressing Ctrl + Shift + P. The current website and all open tabs will be replaced
by the Private Browsing information screen. As long as you will browse in private
mode, the string (Private Browsing) will be displayed in the window's title bar.

Disable Private Browsing by either clicking Tools > Stop Private Browsing or by
pressing Ctrl + Shift + P. Your previous session will be restored.

To make Private Browsing the default mode, open the Privacy tab in the Preference
window as described in Section 17.6.1, “Preferences” (page 194), set Firefox will: to
Use custom settings for history and then choose Automatically start Firefox in a private
browsing session.

WARNING: Bookmarks and Downloads

Downloads and bookmarks you made during Private Browsing mode will be
kept.

17.6 Customizing Firefox
Firefox can be customized extensively. You can not only change the way Firefox behaves
(by altering its preferences), but also add additional functionality (by installing exten-
sions) or change the look and feel (by installing new themes). With the Add-ons man-
ager, Firefox offers a convenient way to manage extensions, themes and plugins.
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17.6.1 Preferences
Firefox offers a wide range of configuration options available via Edit > Preferences,
see Figure 17.5, “The Preferences Window” (page 194). Each option is described in
detail in the online help, which can be accessed by clicking the Help button.

Figure 17.5 The Preferences Window

Session management
By default, Firefox automatically restores your session—windows and tabs— only after
it has crashed, or after a restart when having installed an extension. However, it can be
configured to restore a session every time it is started: Open the Preferences dialog as
described in Section 17.6.1, “Preferences” (page 194) and go to theMain tab. SetWhen
Firefox Starts: to Show My Windows and Tabs from Last Time.

When you have multiple windows open they will only be restored the next time when
you close all of them at once with File >Quit or with Ctrl +Q. If you close the windows
one by one, only the last window will be restored.
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Language Preferences for Web Sites
When sending a request to a Web server, the browser always sends the information
about which language is preferred by the user. Web sites that are available in more than
one language (and are configured to evaluate this language parameter) will display their
pages in the language the browser requests. On SUSE Linux Enterprise Desktop, the
preferred language is preconfigured to use the same language as the desktop. To change
this setting, open the Preferenceswindow as described in Section 17.6.1, “Preferences”
(page 194), go to the Content tab and Choose your preferred language.

Spell Checking
When typing into multiple-line input fields, Firefox, by default, spell-checks what you
type.Misspelled words are underlined in red. To correct a word, right-click it and choose
the correct spelling from the context menu. Youmay also add the word to the dictionary,
if it is correct.

To change or add a dictionary, right-click anywhere in a multi-line input field and
choose the appropriate option from the context menu. Here you may also disable spell-
checking for this input field. If you want to globally disable spell checking, open the
Preferences window as described in Section 17.6.1, “Preferences” (page 194) and go
to the Advanced tab. Uncheck Check My Spelling As I Type.

17.6.2 Add-ons
Extensions let you personalize Firefox to exactly fit your needs. With the help of exten-
sions you can change Firefox's look and feel, enhance existing functionality (such as
the download manager or tabbed browsing), and add functions (such as a blog editor,
Bit Torrent support or even a music player). Certain extensions also assist Web devel-
opers, while others increase security by dynamically blocking active content. More
than 5000 extensions are available for Firefox. With the add-ons manager you cannot
only install new extensions, but also disable, enable, or delete them. It also finds updates
for installed extensions.

If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser.
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Installing Add-ons
To add an extension or theme, start the add-ons manager with Tools >Add-Ons. It opens
with the Get Add-Ons tab either displaying a choice of recommended add-ons or the
results of your last search. Use the Search All Add-Ons field to search for specific add-
ons. Click on an entry in the list to view a short description and a screenshot. Install
the add-on by clicking Add to Firefox... or open a Web page with detailed information
by clicking the Learn More link.

Figure 17.6 Installing Firefox Extensions

If you just want to browse all available add-ons or would like to use advanced search
options, click Browse All Add-Ons. This opens the Firefox add-onsWeb page. To install
an extension, click on the Add to Firefox button on the page describing the add-on.

In order to activate freshly installed extensions or themes, Firefox needs to be restarted
via the Restart Firefox button in the add-ons manager. Restarting the browser with this
button ensures that the complete session will be restored.

Managing Add-ons
The Add-onsManager also offers a convenient interface to manage extensions, themes,
and plugins. Extensions can be enabled, disabled or uninstalled. If an extension is con-
figurable, its configuration options can be accessed via the Preferences button. In the
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Themes tab you may Uninstall a theme, or activate a different theme by clicking on
Use Theme. Pending extension and theme installations are also listed. Select Cancel to
stop the installation. Although you cannot install Plug-Ins as a user, you may disable
or enable them with the Add-ons manager.

Actions like uninstalling or disabling an add-on require a browser restart. Each time
you perform such an action, the Restart Browser button is displayed in the add-ons
manager.

17.6.3 Disabling Features
For special-use cases (for instance when using SUSE Linux Enterprise Desktop as an
Internet terminal) it is recommended to disable (lockdown) certain features, such as
saving or printing a page, viewing the page source or disabling the cache. This can be
achieved by using the GConf system. See Section “Desktop Lock Down Features”
(Chapter 4, GNOME Configuration for Administrators, ↑Administration Guide) for
detailed information.

17.7 Printing from Firefox
Before you actually print a Web page, you can use the print preview function to control
how the printed page will look like. Choose File > Print Preview. Configure paper size
and orientation per printer with File > Page Setup.

To print a Web page either choose File > Print or press Ctrl + P. The Printer dialog
opens. To print with the default options just click Print.

The Printer dialog also offers extensive configuration options to fine-tune the printout.
On the General tab, choose a printer, the range to print, the number of copies and the
order. Page Setup lets you specify the number of pages per side, the scaling factor as
well as paper source and type. You can also activate double-sided printing here if the
printer supports it. Control how frames, backgrounds, header and footer are printed on
the Options tab. You may also specify Job options, such as printing at a specific time,
and the Image Quality in this dialog.
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17.8 Opening MHTML Archives
Microsoft* Word and Internet Explorer (as well as Opera) allows for the saving of a
Web page as a single MHTML file, called Web archive. Such an archive encapsulates
all the resources necessary to display a Web page into a single archive file that can be
viewed offline. By default, MHTML archives are not supported by Firefox. The package
mhtml-firefox installs the Firefox extension MHTML Archive Reader for all
users, and also binds MHTML archives (ending in either .mht or .mhtml) to Firefox
in the desktop shell.

17.9 Displaying Microsoft Silverlight
Content

TheMicrosoft Silverlight technology is a platform for rich Internet applications featuring
interactive animations, vector graphics and audio-video playback. Novell has developed
an open-source implementation of Silverlight called Moonlight. Moonlight not only
provides development tools for Silverlight applications, but a browser plugin for Firefox
as well. This plugin is installed by default and enables Firefox to display Silverlight
applications.

17.10 For More Information
Get more information about Firefox from the official knowledge base available via F1.
More useful information is available from the following links:

Support forum: http://support.mozilla.com/forum
MainMenu reference:http://support.mozilla.com/kb/Menu+reference
Preferences reference:http://support.mozilla.com/kb/Options+window
Keyboard shortcuts: http://support.mozilla.com/kb/Keyboard
+shortcuts
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18gFTP: Transferring Data From
the Internet
GNOME FTP (gFTP) is a multithreaded file transfer client. It supports FTP, FTPS
(control connection only), HTTP, HTTPS, SSH, and FSP protocols. Furthermore, it
allows the transfer of files between two remote FTP servers via FXP. To start GNOME
FTP, press Alt + F2 and enter gftp.

Figure 18.1 GNOME FTP
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18.1 ASCII vs. Binary Transfers
There are two common ways of transferring files via FTP: ASCII and binary. ASCII
mode transfers files as text. ASCII files are .txt, .asp, .html, and .php files, for
example. Binary mode transfers files as raw data. Binary files are .wav, .jpg, .gif,
and mp3 files, for example.

To change the transfer mode click FTP and choose Binary or Ascii.

When transferring ASCII files from Linux/Unix to Windows or vice versa, check the
option FTP > Options > FTP > Transfer Files in ASCII Mode to ensure that newline
characters are correctly converted. This option will automatically be disabled in Binary
mode.

18.2 Connecting to a Remote Server
To connect to a remote server, do the following:

1 In GNOME FTP, click Remote > Open URL....

2 Specify a URL to connect to, then enter a username and password. Leave the
username blank to log in as an anonymous user.

3 Click Connect.

If connection is successful, a list of the files on the remote server appears in the
right part of the GNOME FTP window (the file list on the left side is your local
computer's directory of files). You can now upload and download files via drag
and drop or by using the arrow buttons.

To bookmark a site you access frequently, click Bookmarks > Add Bookmark. Specify
a name for the bookmark, then click Add. The new bookmark is added to your list of
bookmarks.
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18.3 Transferring Files
In the following figure, the file list on the right contains the remote server's directory
of files. The file list on the left side contains your local computer's directory of files
(on your hard drive or network).

Figure 18.2 gFTP File Transfer

To download files, select the files you want to download in the remote list of files, then
click the left arrow button. The progress of each download is listed in the field in the
middle of the window. If the transfer is successful, the files appear in the directory
listing on the left.

To upload a file, select the files you want to upload in your local directory listing on
the left, then click the right arrow button. The progress of each download is listed in
the field in the middle of the window. If the transfer is successful, the files appear in
the remote directory listing on the right.

To modify preferences for your downloads, click FTP > Options.

18.4 Setting Up an HTTP Proxy Server
To set up an HTTP proxy server, do the following:
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1 In GNOME FTP, click FTP > Options, then select the FTP tab.

2 Enter the Proxy hostname and Proxy port. If applicable, also provide your login
credentials for the proxy server. ChooseHTTP Proxy from the Proxy Server Type
drop-down list.

3 Click theHTTP tab, and enter the same proxy server information as above in the
dialog box. Note that port numbers for ftp and http proxy may differ. If in doubt,
ask your system administrator.

4 Click OK.

18.5 For More Information
You can find more information about gFTP at http://www.gftp.org.
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19GIMP: Manipulating Graphics
GIMP (the GNU Image Manipulation Program) is a program for creating and editing
raster graphics. In most aspects, its features are comparable to those of Adobe Photoshop
and other commercial programs. Use it to resize and retouch photographs, design
graphics for Web pages, create covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, GIMP is developed as a cooperative effort of devel-
opers worldwide who volunteer their time and code to the project. The program is under
constant development, so the version included in your system may vary slightly from
the version discussed here. The layout of the individual windows and window sections
is especially likely to vary.

GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 19.7, “For More Information”
(page 220) for ideas of where to find more information about the program.

19.1 Graphics Formats
There are twomain types of graphics—raster and vector. GIMP is intended for working
with raster graphics, which is the normal format for digital photographs or scanned
images. Raster image is a collection of pixels—small blocks of color that together create
the entire image. High resolution images contain large number of pixels and image files
can easily become quite large because of this. It is also not possible to increase the size
of a pixel image without losing quality. GIMP supports all the common formats of
raster graphics, like JPEG, PNG, GIF, BMP, TIFF, and more.
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Unlike raster graphics, vector graphics do not store information for all individual pixels.
Instead, it uses geometrical primitives such as points, lines, curves, and polygons.
Vector images can be scaled very easily and image files can be smaller. The disadvanage
of vector graphics is that it is not good at representing complex images with many dif-
ferent colors such as photographs. There are many specialized applications for vector
graphics, for example Inkscape. GIMP has only a very limited support for vector
graphics. For example, GIMP can open and rasterize vector graphics in SVG format
or work with vector paths.

GIMP 2.6 still supports only limited selection of color spaces. It supports indexed images
and grayscale or RGB images with 8 bits per channel (24 bits per pixel in RGB images
without alpha channel). Many high-end digital cameras can produce image files with
higher color depths. If you import such an image to GIMP, you will lose some color
information.

19.2 Starting GIMP
Start GIMP from the main menu. Alternatively, enter gimp & in a command line.

19.2.1 The Default Windows
Three windows appear by default. The toolbox, an empty image window with the main
GIMP menu, and a window containing several docked dialogs. They can be arranged
on the screen and, except the toolbox and the last image window, closed if no longer
needed. Closing the toolbox or the last image window open closes the application. In
the default configuration, GIMP saves your window layout when you exit. Dialogs left
open reappear when you next start the program.

The Image Window
Every new, opened, or scanned image appears in its own window. If there is more than
one open image, each image has its own image window. There is always at least one
image window open. If there is currently no image open, the image window is empty,
containing only the main GIMP menu and drop area, which can be used to open any
file by dragging and dropping it there. Closing the last image window exits the applica-
tion.
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Themenu bar in the top of the window provides access to all image functions. Converse-
ly, access the menu by right-clicking the image or clicking the small arrow button in
the left corner of the rulers.

The File menu offers the standard file operations, such as New, Open, Save, Print and
Close. Quit exits the application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current windowwith Zoom. When Fit Image
in Window is selected, the image window is resized to fit the current image display
exactly.

The Toolbox
The toolbox contains important controls of the application. Closing it exits the applica-
tion. At the very top, there is a drop area which can be used to open any image file by
simply dragging and dropping it there. Below that, find icons for the various tools.
Hover the mouse over an icon to display information about it.

Figure 19.1 The Toolbox

The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
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bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

Under the toolbox, a dialog shows options for the currently selected tool. If it is not
visible, open it by double-clicking the tool's icon in the toolbox.

Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Information is available in Section 19.5.6, “Layers” (page 219). Channels
shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.
Its use is described in Section 19.5.5, “Undoing Mistakes” (page 218).

19.3 Getting Started
Although GIMP can be a bit overwhelming for new users, most quickly find it easy to
use once they work out a few basics. Crucial basic functions are creating, opening, and
saving images.

19.3.1 Creating a New Image
To create a new image, select File >New or press Ctrl +N. This opens a dialog in which
to make settings for the new image. If desired, select a predefined setting called a
Template. To create a custom template, selectWindows >Dockable Dialogs > Templates
and use the controls offered by the window that opens.

In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
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is opened. A resolution of 72 pixels per inch corresponds to common screen display.
It is sufficient for Web page graphics. A higher resolution should be used for print im-
ages. For most printers, a resolution of 300 pixels per inch results in an acceptable
quality.

In Color space, select whether the image should be in color (RGB) or Grayscale. For
detailed information about image types, see Section 19.5.7, “ImageModes” (page 219).
In Fill With select the color the image is filled with. You can choose betweenForeground
Color and Background Color set in the toolbox,White or Transparency for a transparent
image. Transparency is represented by a gray checkerboard pattern. You can enter a
comment for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

19.3.2 Opening an Existing Image
To open an existing image, select File >Open or press Ctrl +O. In the dialog that opens,
select the desired file. You can also press Ctrl + L and type directly the path to the desired
image. Then click Open to open the selected image or press Cancel to skip opening an
image.

19.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File > Create > XSane: Device dialog.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a binary (black and white without shades of
gray), grayscale, or color image and the required scan resolution. The higher the reso-
lution you choose, the better is the quality of the scanned image. However, this also
results in a correspondingly larger file and the scanning process can take a very long
time at higher resolutions. The size of the final image (both in pixels and bytes) is shown
in the lower part of the dialog.
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In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
These sliders are not available in binary mode. Changes are visible in the preview im-
mediately. Once all settings have been made, click Scan to scan the image.

19.4 Saving Images
No image function is as important as File > Save. It is better to save too often than too
rarely. Use File > Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set toBy Extension. With that setting, GIMP determines
the file type based on the extension appended to the filename. The following file types
are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications. Infor-
mation about layers is available in Section 19.5.6, “Layers” (page 219).

JPEG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compressionmethod enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. See Section 19.5.7, “ImageModes” (page 219)
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for information about indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered byGIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save an image in the chosen format, press Save. To abort, press Cancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.

19.5 Editing Images
GIMP provides a number of tools for making changes to images. The functions described
here are those most interesting for home users.

19.5.1 Changing the Image Size
Once an image is scanned or a digital photograph is loaded from the camera, it is often
necessary to modify the size for display on a Web page or for printing. Images can
easily be made smaller either by scaling them down or by cutting off parts of them.
Enlarging an image is muchmore problematic. Because of the nature of raster graphics,
quality is lost when an image is enlarged. It is recommended to keep a copy of your
original image before scaling or cropping.

Cropping an Image
Cropping an image works like cutting the edges off a piece of paper. Select the crop
tool from the toolbox (it resembles a scalpel) or with Tools > Transform Tools > Crop.
Click a starting corner and drag to outline the area to keep.
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A rectangle showing the crop area will appear. To adjust the size of the rectangle, move
your mouse pointer above any of the rectangle's sides or corners, click and drag to resize
as desired. If you want to adjust both width and height of the rectangle, use a corner.
To adjust only one dimension, use a side. To move the whole rectangle to a different
position without resizing, click anywhere near its center and drag to the desired position.

When you are satisfied with the crop area, click anywhere inside to crop the image or
press Enter. To cancel the cropping, click anywhere outside the crop area.

Advanced options for the crop tool are available in the Tool Options dialog.

Scaling an Image
Select Image > Scale Image to change the overall size of an image. Select the new size
by entering it inWidth or Height. To change the proportions of the image when scaling
(this distorts the image), click the chain icon to the right of the fields to break the link
between them. When those fields are linked, all values are changed proportionately.
Adjust the resolution with X resolution and Y resolution.

The Interpolation option controls the quality of the resulting image. The default Cubic
interpolation method is a good standard to use in most cases.

When finished adjusting the size, press Scale to scale the image. Reset restores the
original values. Cancel aborts the procedure.

Changing the Canvas Size
Changing the canvas size is like putting a mat around an image. Even if the mat is
smaller, the rest of the image is there, but you can only see part of it. If the mat is larger,
you see the original image with extra space around it. To do this, select Image >Canvas
Size.

In the dialog that opens, enter the new size. By default, the width and height maintain
the same proportions as the current image. To change this, click the chain icon.

After adjusting the size, determine how the existing image should be positioned in
comparison to the new size. Use the Offset values or drag the box inside the frame at
the bottom. When satisfied with the changes, click Resize to change the canvas size.
Click Reset to restore the original values or Cancel to cancel the canvas resize.
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19.5.2 Selecting Parts of Images
It is often useful to perform an image operation on only part of an image. To do this,
the part of the image with which to work must be selected. Areas can be selected using
the select tools available in the toolbox, using the quick mask, or combining different
options. Selections can also be modified with the items under Select. The selection is
outlined with a dashed line, called marching ants.

Using the Selection Tools
The main selection tools are rather easy to use. The paths tool, which can also be used
for more than selecting, is more complicated so is not described here. In the tool options
for the other selection tools, use one of the icons in theMode row to determine whether
the selection should replace, be added to, be subtracted from, or intersect with an existing
selection.

Rect Select
This tool can be used to select rectangular or square areas. To select an area with
a fixed aspect ratio, width, height or size, activate the Fixed option and choose the
relevant mode in the Tool Options dialog. To create a square, hold Shift while se-
lecting a region.

Ellipse Select
Use this to select elliptical or circular areas. The same options are available as with
the rectangular selection. To create a circle, hold Shift while selecting a region.

Free Select (Lasso)
With this tool, you can create a selection based on a combination of freehand
drawing and polygonal segments. To draw a freehand line, drag the mouse over
the image with the left mouse button pressed. To create a polygonal segment, release
the mouse button where the segment should start and press it again where the seg-
ment should end. To complete the selection, hover the pointer above the starting
point and click inside the circle.

Fuzzy Select (Magic Wand)
This tools selects a continuous region based on color similarities. Set the maximum
difference between colors in the tool options dialog in Threshold. By default, the
selction is based only on the active layer. To base the selection on all visible layers,
check Sample merged.
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Select by Color
With this, select all the pixels in the image with the same or similar color as the
clicked pixel. The maximum difference between colors can be set in the tool options
dialog in Threshold. The important difference between this tool and Fuzzy Select
is that Fuzzy Select works on continuous color areas while Select by Color selects
all pixels with similar colors in the whole image regardless of their position.

Intelligent Scissors
Click a series of points in the image. As you click, the points are connected based
on color differences. Click on the first point to close the area. Convert it to a regular
selection by clicking inside it.

Foreground Selection Tool
The Foreground Selection tool lets you semiautomatically select an object in a
photograph with minimal manual effort.

If you want to use the Foreground Selection tool, follow these steps:

1 Activate the Foreground Selection tool by clicking on its icon in the Toolbox or
choosing Tools > Selection Tools > Foreground Select from the menu.

2 Roughly select the foreground object you want to extract. Select as little as pos-
sible from the background but include the whole object. At this point, the tool
works like the Fuzzy Select tool.

When you release the mouse button, the non selected part of the image is covered
with dark blue mask.

3 Draw a continuous line through the foreground object going over colors which
will be kept for the extraction. Do not paint over background pixels.

When you release the mouse button, all background is covered with dark blue
mask. If parts of the object are also masked, paint over them. The mask will
adapt.

4 When you are satisfied with the mask, press Enter. The mask will be converted
to a new selection.
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Using the Quick Mask
The quick mask is a way of selecting parts of an image using the paint tools. A good
way to use it is to make a rough selection using the intelligent scissors or the lasso (the
free selection tool). Then activate the quick mask by pressing the small icon with the
dashed box in the lower left corner.

The quick mask displays the selection using an overlay of red. Areas shaded with red
are not selected. Areas appearing as they did before the mask was activated are selected.
To modify the selection, use the paint tools. Painting with white selects the painted
pixels. Painting with black deselects pixels. Shades of gray (colors are treated as shades
of gray) are a partial selection. Partial selection allows smooth transitions between se-
lected and unselected areas.

To use a different color for displaying the quickmask, right-click the quickmask button
then select Configure Color and Opacity from the menu. Click the colored box in the
dialog that opens in order to select a new color.

After using the paint tools to adjust the selection as desired, convert from the quick
mask view back to the normal selection view by clicking the icon in the lower left corner
of the image window (currently displaying a red box). The selection is again displayed
with the marching ants.

19.5.3 Applying and Removing Color
Most image editing involves applying or removing color. By selecting a part of the
image, limit where color can be applied or removed. When you select a tool and move
the cursor onto an image, the cursor's appearance changes to reflect the chosen tool.
With many tools, an icon of the current tool is shown along with the arrow. For paint
tools, an outline of the current brush is shown, allowing you to see exactly where you
will be painting in the image and how large of an area will be painted.

Selecting Colors
Paint tools use the foreground color. To select the color, first click the display box of
the foreground color in the Toolbox. A dialog with five tabs opens. These tabs provide
different color selection methods. Only the first tab, shown in Figure 19.2, “The Basic
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Color Selector Dialog” (page 216), is described here. The new color is shown inCurrent.
The previous color is shown in Old.

Figure 19.2 The Basic Color Selector Dialog

The easiest way to select a color is by using the colored areas in the boxes to the left.
In the narrow vertical bar, click a color similar to the desired color. The larger box to
the left then shows available nuances. Click the desired color. It is then shown inCurrent.
If that color is not what you want, try again.

The arrow button to the right of Current enables the saving of a number of possible
colors. Click the arrow to copy the current color to the history. A color can then be se-
lected by clicking it in the history. A color can also be selected by directly entering its
hexadecimal color code in HTML Notation.

The color selector defaults to selecting a color by hue, which is usually easiest for a
new user. To select by saturation, value, red, green, or blue, select the corresponding
radio button to the right. The sliders and number fields can also be used to modify the
currently selected color. Experiment a bit to find out what works best for you.

When the desired color is shown in Current, click OK. To restore the original values
shown when the dialog was opened, click Reset. To abort changing the color, click
Cancel.

To select a color that already exists in your image, use the eye dropper tool. With the
tool options, set whether the foreground or background color should be selected. Then
click a point in the image that shows the desired color. When the color is right, click
Close to close the tool's dialog.
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Painting and Erasing
To paint and erase, use the tools from the toolbox. There are a number of options
available to fine-tune each tool. Pressure sensitivity options apply only when a pressure-
sensitive graphics tablet is used.

The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The
ink tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill
is a method of coloring areas of an image. It fills based on color boundaries in the image.
Adjusting the threshold modifies its sensitivity to color changes.

Adding Text
With the text tool, easily add text to an image. With the tool options, select the desired
font, font size, color, justification, indent, and line spacing. Then click a starting point
in the image. A small dialog opens in which to enter your text. Enter single or multiple
lines of text then press Close.

The text tool creates text in a special layer. To work with the image after adding text,
read Section 19.5.6, “Layers” (page 219). When the text layer is active, it is possible to
modify the text by clicking in the image to reopen the entry dialog. Change the settings
by modifying the tool options.

Retouching Images—The Clone Tool
The clone tool is ideal for retouching images. It enables you to paint in an image using
information from another part of the image. If desired, it can instead take information
from a pattern.

When retouching, it is usually a good idea to use a small brush with soft edges. In this
way, the modifications can blend better with the original image.

To select the source point in the image, press and hold Ctrl while clicking the desired
source point. Then paint with the tool, as usual. When you move the cursor while
painting, the source point, marked by a cross, moves as well. If the Alignment is set to
None (the default setting), the source resets to the original when you release the left
mouse button.
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19.5.4 Adjusting Color Levels
Images often need a little adjusting to get ideal print or display results. In many programs
designed for inexperienced users, the brightness and contrast levels are modified. This
can work and is also available in GIMP, but better results can be obtained by adjusting
the color levels.

To do this, selectColors > Levels. A dialog opens for controlling the levels in the image.
Good results can usually be obtained by clicking Auto. To make manual adjustments
to all channels, use the dropper tools in All Channels to pick areas in the image that
should be black, neutral gray, and white.

To modify a channel individually, select the desired channel in Channel. Then drag the
black, white, and middle markers in the slider in Input Levels. Conversely, use the
dropper tools to select points in the image that should serve as the white, black, and
gray points for that channel.

If Preview is checked, the image window shows a preview of the image with the mod-
ifications applied. When the desired result is achieved, press OK to apply the changes.
With Reset, restore the original settings. Cancel aborts level adjustment.

19.5.5 Undoing Mistakes
Most modifications made in GIMP can be undone. To view a history of modifications,
use the undo dialog included in the default window layout or open one from the image
window menu withWindows > Dockable Dialogs > Undo History.

The dialog shows a base image and a series of editing changes that can be undone. Use
the buttons to undo and redo changes. In this way, you can work back to the base image.
If you undo a modification then make a new one, the undone modification cannot be
redone.

Changes can also be undone and redone with the Edit menu. Alternatively, use the
shortcuts Ctrl + Z and Ctrl + Y.
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19.5.6 Layers
Layers are a very important aspect of GIMP. By drawing parts of your image on separate
layers, change, move, or delete those parts without damaging the rest of the image. To
understand how layers work, imagine an image created from a stack of transparent
sheets. Different parts of the image are drawn on different sheets. The stack can be re-
arranged, changing which parts are on top. Individual layers or groups of layers can
shift position, moving sections of the image to other locations. New sheets can be added
and others set aside.

Use the Layers dialog to view the available layers of an image. The text tool automati-
cally creates special text layers when used. The active layer is highlighted. The buttons
at the bottom of the dialog offer a number of functions. More are available in the menu
opened when a layer is right-clicked in the dialog. The two icon spaces before the image
name are used for toggling image visibility (eye icon when visible) and for linking
layers. Linked layers are marked with the chain icon and moved as a group.

19.5.7 Image Modes
GIMP has three image modes—RGB, Grayscale, and Indexed. RGB is a normal color
mode and is the best mode for editing most images. Grayscale is used for black-and-
white images. Indexed limits the colors in the image to a set number. It is mainly used
for GIF images. If you need an indexed image, it is normally best to edit the image in
RGB then convert to indexed right before saving. If you save to a format that requires
an indexed image, GIMP offers to index the image when saving.

19.5.8 Special Effects
GIMP includes a wide range of filters and scripts for enhancing images, adding special
effects to them or making artistic manipulations. They are available in Filters. Experi-
menting is the best way to find out what is available.
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19.6 Printing Images
To print an image, selectFile > Print from the imagemenu. If your printer is configured
in the system, it should appear in the list. You can configure printing options on Page
Setup and Image Settings tabs.

Figure 19.3 The Print Dialog

When satisfied with the settings, press Print. Cancel aborts printing.

19.7 For More Information
The following resources are very useful for users of GIMP. They contain much more
information about GIMP than this chapter. If you want to use GIMP for more advanced
tasks, you should not miss these resources.

• http://www.gimp.org is the official home page of The GIMP. News about
GIMP and related software are regularly posted on the frontpage.

• Help provides access to the internal help system including extensive GIMP User
Manual. The package gimp-help has to be installed. This documentation is also
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available online in HTML and PDF formats at http://docs.gimp.org.
Translations into many languages are available.

• A collection of many interesting GIMP tutorials is maintained at http://www
.gimp.org/tutorials/. It contains basic tutorials for complete beginners
as well as tutorials for advanced or expert users.

• Printed books about GIMP are published regularly. You will find selection of the
best ones with short annotations at http://www.gimp.org/books/.

• GIMP functionality can be extended with scripts and plug-ins. Many such scripts
and plug-ins are distributed in GIMP package, but other can be downloaded from
the Internet. At http://registry.gimp.org/, you will find a database of
GIMP scripts and plug-ins.

You can also use mailing lists or IRC channels to ask questions about GIMP. Please
always try to find answers in the documentation mentioned above or in mailing list
archives before asking your question. The time of experienced users present on GIMP
lists and channels is limited. Be polite and patient. It may take some time before your
question is answered.

• There are a number of mailing lists about GIMP. You will find them at http://
www.gimp.org/mail_lists.html. GIMP User list is the most appropriate
place to ask user questions. If you do not want to subscribe to the list but want to
read its archives, visit http://lists.xcf.berkeley.edu/lists/
gimp-user/.

• There is a whole IRC network dedicated to GIMP and GNOME desktop environ-
ment—GIMPNet. You can connect to GIMPNet with your favourite IRC client by
pointing it at irc.gimp.org server. The #gimp-users channel is the right place to ask
question about using GIMP. If you want to listen to developer's discussion, join
the #gimp channel.
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20DigiKam: Managing Your
Digital Image Collection
Managing digital photographs in Linux is very straightforward. KDE's digiKam
downloads your images directly from your camera. It helps you organize andmanipulate
your images to get the best possible results. The application includes several useful
plug-ins that can convert your images to various different formats. Image improvement
plug-ins also include red eye reduction, speck removal and hot pixel removal. Various
filter and effect plug-ins help create little works of art from your digital images.

20.1 About DigiKam
Start digiKam from the main menu or by pressing Alt + F2 and entering digikam.
digiKam will ask you to choose a location to store your images and albums. On start-
up, digiKam shows a window with two main areas: a list of your albums to the left and
the images in the current album to the right. See Figure 20.1, “The Main Window of
digiKam” (page 224). The far right edge of the window has a number of tabs attached
which can be used to display important information about your images, or to manipulate
certain image-related data:

Properties
Use this tab to access properties assigned to your images, such as file properties
(permissions, ownership, modification date, etc.), image properties (dimensions,
file format, etc.), and photograph properties (basic model, exposure and aperture
information).
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Metadata
Use this tab to access the various kinds of metadata associated with your images,
such as EXIF, IPTC and XMP data..

Colors
Use this tab to access color management-related data and to analyze the histograms
associated with your images.

Geolocation
Use this tab to search for the location stored in the picture.

Caption/Tags
Use this tab to assign comments, tags or ratings to your images.

Tag Filters
Use Tag Filter to filter the amount of images displayed in the main view, using
tagging information. For details about tagging in digiKam, refer to Section 20.5,
“Managing Tags” (page 228).

Figure 20.1 The Main Window of digiKam

20.2 Configuring Your Camera
To download images from your digital camera, simply connect the camera to the USB
port of your computer using the USB cable provided by the camera manufacturer. De-
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pending on your camera model, you may need to switch your camera to a special data
transfer mode. Consult the camera's manual about this.

There are four possibilities for accessing the pictures on the camera:

1. USBMass Devices If your camera can be switched to a USB mass storage de-
vice, select this option. After you connect the camera to the USB port of your
computer and turn the camera on, the new USB device is automatically detected
and mounted. KDE lets you select the action to take in the event of any such device
being mounted. You can choose to start digiKam or any other image viewing or
processing application whenever a device of this type is mounted.

2. PTP (Picture Transfer Protocol, also Known as PictBridge) If your camera
can be switched to PTP, select this option. Normally your camera is not automati-
cally mounted in PTP mode, but can be accessed through digiKam.

3. Special Drivers and Gphoto2 If your camera supports neither USB mass
storage nor PTP, try the special drivers provided by gphoto2, see Section 20.12,
“Troubleshooting” (page 244)

4. CardReaders Nowadays cameras can use different non-volatile memory cards.
For example, SD memory cards, compact flash (CF), memory sticks, to name a
few. Some new computers have a card reader on board with different slots, to
support all these formats. If you do not want to deal with cables, protocols, or
drivers, select this option, as it simplifies a lot. Normally, card readers are detected
as removeable devices and are automatically mounted in KDE.

To set up a camera in digiKam, select Import > Cameras > Add Camera. First, try to
detect the camera automatically with Auto-Detect. If this fails, browse the list of sup-
ported cameras for your model with Add. If your camera model is not included in the
list, try an older model or use USB/IEEE mass storage camera and confirm with OK.

20.3 Downloading Pictures from the
Camera

To download images from a camera that has been properly configured, attach the
camera to your computer and select the camera from theCameramenu. digiKam opens
a window and begins to download thumbnails and display them as in Figure 20.2,
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“Downloading Pictures from a Camera” (page 226). Right-click an image to open a pop-
up menu with the options to View the image, to Download, or Delete the image. Select
the Settings tab to the right of the download window to rename the image files using
Renaming Options. Review the EXIF data associated with the selected image using the
Metadata tab.

Figure 20.2 Downloading Pictures from a Camera

TIP: Renaming Images

Mass renaming of your images comes in handy if your camera's filenames are
not meaningful enough for your purpose. Provide a unique prefix, add an op-
tional date, and let digiKam provide a sequence number.

Select all images to download from the camera by pressing the left mouse button or by
clicking individual images with Ctrl pressed, or by using one of the select modes pro-
vided by the Images menu at the bottom of the download window. Click Download
and select the destination from the list, or create a new album with New Album (which
automatically suggests a filename with the current date). Confirm with OK to start the
download process.

TIP: Downloading Images from the Storage Medium

To save your camera's battery power, you can also attach a USB hub to your
computer (providing an appropriate slot for your storage medium) and down-
load the files from there. Once the USB hub is connected to your computer,
the KDE media handler dialog opens and offers to download the images from
the medium you attached.
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20.4 Managing Albums
By default, digiKam creates a folder calledMy Albums to hold all root albums, called
collections. Collections can store albums, while albums store sub albums and images.
The first collection was created on first start with the First-run Wizard dialogue.

The albums can be sorted by directory layout, by collection name set in the album
properties, or by the date that the albums were first created (this date can also be changed
in the properties of each album).

To create a new album, use one of these methods:

• Upload new images from the camera and create the target album during the down-
load.

• Create a new album by selecting a collection folder first and then Album > New
Album from the main menu or via right-click.

• Import an existing folder of images from your hard disk (select Import > Add
Folders...).

• Right-click a collection folder and select New Album.

To create a new collection, go to Settings > Configure digiKam, Collections menu and
choose Add Collection.

Once you have chosen to create a new album, provide some basic administrative infor-
mation about the new album, such as an album title. Optionally, choose a category, insert
some comments, and select an album date. Categories are a way of organizing your
albums by a common label. This label is used when you select View > Sort Albums >
By Category. The comment is shown in the banner at the top of the main window. The
album date is used when you select View > Sort Albums > By Date.

digiKam uses the first photograph in the album as the preview icon in theMy Albums
list. To select a different one, right-click the respective photograph and select Set as
Album Thumbnail from the context menu.
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20.5 Managing Tags
Managing a high number of different images across various albums can be very difficult.
To manage your images by custom categories and across albums, digiKam provides
theMy Tags system. Tags categorize images, and more than one tag can be assigned
to an image.

For example, assume that you took several pictures of animals and distributed them
across various albums. Now you are looking for an easy way to generate an overview
of all pictures ever taken of animals. Using digiKam's tags, proceed as follows for this
scenario:

1 Select Tag > New Tag in the upper menu bar and enter a name for the new tag,
in this case animals.

The dialog box allows you to create hierarchical tags, too. For example, to have
a bear tag which is underneath a animals tag, insert animals/bear into
the text field. Provide an optional icon and leave this dialog with OK.

2 Go to each album and tag all images showing some animals by right-clicking
the image and selecting Assign Tag > animals > Assign this Tag. To tag more
then one picture at once, use the Ctrl key.

If you need to process a huge number of images, an easier way to do the tagging would
be using the Captions/Tags tab from the tab bar at the right edge of the main window.
This interface allows you to assign tags to this image, enter an optional descriptive
comment, and rate this image.When you are done with the first image, stay in this dialog,
click the right arrow button, and click Apply when finished to apply your settings. Do
it with all your images of this album. Proceed similarly with all other albums and images.

To retrieve all images in your entire collection that carry a certain tag (in this case
animals), proceed as follows:

1 Open the Tags tab in the left tab bar.

2 Unfold theMy Tag item.

3 Select the animals tag.

As a result, all images in your entire collection carrying this tag are displayed.
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Figure 20.3 Display Tagged Images Only

The Tag Filter in the far right edge of the main window limits the number of images
displayed for the current album to those marked by the tag or tags selected here.

20.6 Creating Powerful Search Filters
Any image collection soon becomes unmanageable if you do not find a means to easily
search for the images you need and find them. To help you organize your collection,
digiKam offers you two search options:

Simple Search
A basic search. Select Tools > Search and enter a text string that might be associated
with your image (image or tag name or comment) and hit OK. You can save this
search for future use, and edit other existing searches listed under Searches on the
left edge of your digiKam window.

Advanced Search
Complex search filter. Select Tools > Advanced Search, provides a wide spectrum
of search criteriums, which are:

File, Album, Tags
Search for names of albums, tags or the filenames of pictures.

Picture Properties
Search for image properties like date, rating, file size, color depth and a lot more.
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Caption, Comment, Title
Search for comments, author and IPTC information.

Photograph Information
Search for photograph information like focal length, sensitivity and so on..

With the Add Search Group button it is possible to combine several search criteria.
Searches.

The following example illustrates how to create an Advanced Search using rating or
tag information to search for images:

1 Select Tools > Advanced Search from the main menu.

2 Select Picture Properties criterion. Now select Rating from 2 to 5 stars.

3 Select the Add Search Group button. Another search board appears. It is possible
to combine search parameters with And orOr and the four options. Click onMeet
any of the following conditions.

4 Select the File, Album, Tags criterion and choose a tag from the tags list.

5 Select the Picture Properties criterion. Choose JPEG as file format and press the
Ok button. The results of your search are displayed in the digiKam window.

6 To save the search for future use, click on Searches tab on the left side. Specify
a name for this search and Save Current Search by clicking the save button.
Leave the Advanced Search dialog with another click on the Searches tab.
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Figure 20.4 Creating an Advanced Search Filter

20.7 Exporting Image Collections
digiKam provides several export options that help archive and publish your personal
image collections. It offers archiving to iPod, HTML export, and export to a remote
gallery.

digiKam comes with some customized export functions for the most known online
archives and the general export function Export >HTMLGallery. To create an HTML
export of your image collection, proceed as follows:

1 Select Export > HTML Gallery.

2 Determine which part of your collection should be archived by selecting albums
or tags in Collection and click Next.

3 Use Theme dialog to set the appearance of your HTML gallery and click Next.

4 Specify size, compression and file type for the thumbnails used for gallery navi-
gation in Image Settings and click Next.

5 Determine the location of the gallery on disk with Output and click Finish.
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To export your collection to an external image gallery on the Internet, proceed as
follows:

1 Get an account for an external Web site to host your gallery.

2 Select Export > Export to Gallery and provide the URL, username, and password
for the external site when asked. digiKam establishes a connection to the site
specified and opens a new window called Gallery Export.

3 Determine the location of your new album in the gallery.

4 Click New Album and provide the information requested by digiKam.

5 Upload the images to the new album with Add Photos.

20.8 Managing Geolocation
Some cameras store GPS (Global Positioning System) coordinates within the pho-
tographs when they take a picture. With this information digiKam is able to illustrate
and search photographs by their location and display them on a globe. To make use of
Geolocation, proceed as follows:

Search the Map
Click on theMap Searches tab on the left side. Press Shift ctrl and the left mouse
button to choose an area on the map. Use the mouse wheel to zoom in and out.
Every image matching the coordinates of the area will be displayed inside the main
window.

Show Geolocation
Click on theGeolocation tab on the right side to open the globe. Select one or more
pictures with the left mouse button. Every picture containing GPS information will
be displayed on the map. To zoom in/out use the mouse wheel.

Adding Geolocation
Choose a picture in the main window and select Image > Geolocation > Edit Co-
ordinates . Choose the location on the map or enter the coordinates manually and
pressOk. The coordinates are now stored in the image’s EXIF tags. To edit several
pictures at once press the Ctrl key while choosing the desired pictures.
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Figure 20.5 Watching picture locations on the map

20.9 Viewing and Editing Images
digiKam comes with a comprehensive image viewing and editing suite consisting of
various plug-ins. To enter digiKam's viewing or editing mode, right-click an image
thumbnail and select View or Edit from the context menu. To use the plug-ins, install
the digikamimageplugins package.

To view one or more images you have the following options:

• To view a single image, browse to your album or collection and click on your image
to display it. Another click brings you back to the previous view.

• To start a slide show with all images, use View > Slideshow > All.

• To start a slide show with selected images only, hold down the Ctrl key, select your
images, and choose View > Slideshow > Selection.

To edit a selected image, use Edit from the main menu. This opens a window which
contains some of the most frequently used basic editing options:

• Use the back/forward buttons to browse your album without having to go back to
the full album view.

• Use the undo/redo menus to selectively undo or redo certain operations.

DigiKam: Managing Your Digital Image Collection 233



• Use the zooming options to zoom in or out, or to fit the image view to the window
size you are using. Use the looking glass icon to selectively zoom into a particular
area of the image.

• Flip the image clockwise or counter-clockwise.

• Activate a slide show or full screen view of the selected image.

20.9.1 Applying Image Decorations
The editing mode contains more useful features. Use theDecoratemenu to superimpose
various kinds of graphics and text effects onto your images without having to bother
about filters and their fine-tuning:

Apply Texture
Select the type of texture you want to apply to your image and determine how
prominent this texture should be (Relief). digiKam applies the texture and saves
the changes to the original copy of your image.

Add Border
Select the type of border. Depending on the type of border you have selected,
choose one or two colors to be used for the border and set the width of the border
around your image. digiKam creates the border and saves the changes to the original
copy of your image.

Insert Text
Enter the text you want to superimpose on the image. Choose font, font style and
size. Select the text justification and decide whether the text should be rotated (and
to what degree). Add an optional border and semi-transparency. digiKam adds your
text layer to the original image.

Template Superimpose
Just as you can superimpose any text on your image, you can also apply ready-
made templates to create funny greeting cards, posters and the like.
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20.9.2 Manipulating Color Settings
The Color menu allows you to manage all kinds of different color-related settings. Its
capabilities range from simple auto correction mechanisms to full-blown color manage-
ment via color profiles:

Auto Color Correction
If aiming for a straightforward color and exposure correction of your image, try
this option. Choose from various preset modes and apply the one that matches best.
Use the histograms to determine whether the result matches your needs.

Brightness/Contrast/Gamma
This tool offers a simple way of fixing over or underexposed images.

Hue/Saturation/Lightness
This tool helps you to optimize images that have been taken under very bright
lighting conditions and appear somewhat washed out. Bring color saturation back
to these images by manipulating the hue and saturation sliders. Depending on the
level of color, you might also want to adjust the lightness to prevent the image from
registering too dark. Of course, you can also use this tool to achieve the opposite
effect if you need to brighten up an image that has been taken at low light conditions
and contains far too much color saturation.

Color Balance
Depending on the lighting conditions under which an image was taken or the
quality of an image scan, the colors may appear somehow out of balance. Using
the color balance tool, you can try to shift the balance towards another end of the
color spectrum.

Invert
Invert the color values.

Black & White
Transform your color image into black and white. Use the Film, Lens Filters, Tone,
and Lightness to tweak the end product. The Film tab offers you to emulate the ef-
fects various black and white films. To emulate color filters used with the camera
lens, use the Lens Filters tab. Note that you can only apply one filter at a time.
Using the Tone tab you can have your black and white image tinted in a particular
way (sepia, for example).
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Depth
Determine the color depth (in bits). Transform 8-bit into 16-bit images and vice
versa.

Color Management
Color management via ICC color profiles helps you maintain color fidelity across
multiple output devices (camera, display, printer).

Levels Adjust
Use this option to control multiple levels and to check the resulting image in just
one tool. It lets you save the chosen level settings and thus enables you to apply
the same corrections to multiple images, if needed. This comes in handy if you
know that your camera tends to use the same faulty color settings all the time, and
you would like to be able to correct them with just a single click.

Color Effects
This tool offers a selection of color effects like edge finding, solarizing, etc.

White Balance
Every source of light registers differently on your digital camera's chip. Depending
on the light source, the color temperature tends to register either warmer (towards
the red end of the spectrum) or cooler (towards the blue end of the spectrum) than
standard daylight. Most cameras ship with preset white balance schemes that try
to compensate these effects. If the resulting images registers faulty, use the white
balance adjustment provided by digiKam. Either manipulate the color temperature
directly by using the Kelvin slider, or choose one of the preset white balance
schemes.

Curves Adjust
This tool allows you to basically perform any operation available through the
Brightness/Contrast/Gamma and the Levels Adjust tools, but in one tool and using
free-function mapping. Therefore this tool is more powerful and flexible than the
other two, but it may take some time to get used to.

Channel Mixer
The channel mixer tool provides an alternative way of converting colored images
to black and white. Using theMonochrome option and the channel sliders, you can
selectively determine how much each of the color channels contributes to the
overall image. The channel mixer option is much more flexible than the standard
conversion to black and white, because you can manage each color channel sepa-
rately.
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20.9.3 Fixing and Tweaking Your Images
Use the Enhance menu to address a number of common defects related to digital im-
agery:

Blur, Sharpen
Tweak the sharpness of your image or smooth it.

Red Eyes
Reduce or eliminate red eyes caused by use of a flash.

Inpainting
“Heal” defective areas of your image.

Noise Reduction
Remove artifacts, such as those caused by dust on your lens or sensor. Compensate
for pixel noise caused by high ISO settings of your digital camera and reduce noise
and artifacts in low quality scans.

Hot Pixels
Detect and erase problem pixels of your image caused by defective pixels of your
camera's sensor.

Lens > Distortion
Compensate for barrel and pincushion distortion of your images caused by the use
of strong wide-angle or telephoto lenses.

Lens > Vignetting Correction
Compensates circular shades (vignettes) at the edges or in the center of your image
that were caused by the use of strong wide-angle or telephoto lenses.

Lens > Vignetting Correction
Compensates circular shades (vignettes) at the edges or in the center of your image
that were caused by the use of strong wide-angle or telephoto lenses.

Restoration
Provides an all-inclusive treatment to images exhibiting various digital defects,
such as noise and scratches.
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To observe the functionality of the Fix options, look at Inpainting, for example. Assume
some dust or scratch on your lens ruined an image. To remove this kind of blemish,
proceed as follows:

1 Open your image.

2 Use the mouse cursor to select the area to which to apply the fix.

3 Select Enhance > Inpainting or press Ctrl + E.

4 Determine the method to use to remove the blemish:

• Choose one of the Preset options (Remove Small Artifact, Remove Medium
Artifact, or Remove Large Artifact) and proceed with Step 6.

• Set the filter parameters on your own. Proceed with Step 5.

5 If you opted against using any of the preset filters (in the Preset tab), open the
General and Advanced Settings tabs and adjust the settings to your needs.

6 Click OK to apply your settings and modify the image accordingly.

TIP: Creating and Reusing Your Own Filter Settings

If you need to use the same set of settings more than once (for example,
if a scratch on the lens ruined an entire series of images), create your
set of filter settings. Save them for later use by clicking Save As and saving
them to a text file. For subsequent images, open the Image Inpainting
dialog, click Load, then select the text file and apply the filter settings
with OK.
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Figure 20.6 Using Inpainting to Remove Artifacts

20.9.4 Applying Image Transformations
To scale or rotate an image, use the Transform menu:

Rotate, Flip, Free Rotation
Rotate your image to a certain degree. Rotate rotates by multiples of 90 degrees.
With Free Rotation, specify any angle you want.

Crop, Aspect Ratio Crop
Crop your image. Crop cuts to any rectangular selection on top of your image.
Aspect Ratio Crop crops the image following various sophisticated design principles.

Perspective Adjustment
Adjust the perspective of an image. For example, if you notice some odd angles in
shots containing vertical or horizontal lines, use this tool to correct them. Grab any
of the four handles to the corners of your image and move them as needed. Use the
Crop tool to remove the resulting black edges of your image, and to trim it down.

Shear
Shift one part of your image to one direction and the other to the opposite direction,
either horizontally or vertically. Specify the angles for vertical and horizontal shear
and use Crop to trim the resulting image.

Resize
Scale your image. Resize offers a simple interface allowing you to manipulate your
image size by pixel or percentage. Select whether to keep the aspect ratio. If you
select Restore photograph, you can fine-tune the algorithms used on your resized
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image and improve the quality of the end product. Note that this option might be
considerably slower than a simple resize operation.

Assuming you have an image that is otherwise perfect, but you are not entirely satisfied
with the composition yet or need to crop your image to match a certain paper format
for reproduction. Use Aspect Ratio Crop and proceed as follows:

1 Open your image.

2 Select Transform > Aspect Ratio Crop.

3 Determine the orientation and aspect ratio to use:

None
Specify a free crop of the image using the X, Width, and Y, Height sliders.

Custom
Select a custom ration of width versus height instead of using one of the
preset values.

X:Y Ratio
These ratios matchmost of the common paper sizes used to print photographs.
Pick the one that suits your purpose best.

Golden Ratio
A ratio (1:1.618) that is traditionally used by artists and architects to create
harmonious results.

Use theMax. Aspect button to set the crop area to the maximum possible size of
the specified ratio.

4 After determining the size of your crop selection, optionally apply compositional
rules to it. The Composition Guide helps to create a crop selection that results in
a visually pleasing image. Dotted lines are displayed that guide you to a better
composition of your image.

5 If the position of your crop does not follow the compositional rule to your satis-
faction, move it.

6 Click OK to apply your crop selection and trim your image.
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Figure 20.7 Creating a Custom Crop Using Aspect Ratio Crop

20.9.5 Applying Filters and Effects
You can select from a variety of basic effects and filters to apply to your images, giving
them a more artistic or over-the-top look:

Raindrops
Apply raindrop effects to your image. Determine the size and number of the drops
and specify the degree of distortion caused by the drops (Fish eyes).

Infrared Film
Simulate the use of infrared film to achieve a slightly surreal effect. The result is
strikingly different from the original image. Add additional film grain and tweak
the sensitivity (ISO) to achieve a more artistic feel.

Oil Paint
Simulate an oil painting. Determine the brush size and the degree of smoothing to
apply to your image.

Emboss
Pretend your image had been embossed to a sheet of paper. Choose an appropriate
depth.

Distortion Effects
Apply various strange distortion effects, such as fish eyes, to your image. Determine
type, level, and repetition.
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Add Film Grain
Add film grain to your image to give it a rough look.

Blur Effects
Blur your image to simulate the image being out of focus or to mimic any kind of
movement that was not there when you took the image.

Charcoal Drawing
Transform your image into a black and white charcoal drawing. Choose an appro-
priate pencil size and determine the degree of smoothing to apply to the image.

Figure 20.8 Simulating IR Photography

20.10 Useful Tools
digiKam offers several little helpers for organizing your image collection and for pro-
cessing your images. Find them in the Tools menu. Some highlights:

Find Duplicates
If you suspect that your collection contains a number of duplicates, use this option
to find and delete them. First, determine which album or tag to include in the scope
of your search. Click OK to initiate the search. If your collection contains any du-
plicates, you get a split screen showing both images and can select one of them for
deletion.

Create Calendar
Create a simple calendar using a standard layout by selecting the images to use and
by selecting paper size and fonts.
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20.11 Batch Processing
If you need to perform certain actions on a large number of files at once, use batch
processing. Add borders, edit colors, apply various effects and filters, rename and resize
images, recompress them, or perform a RAW conversion.

To find out whether your camera's RAW format is supported by the digiKam converter
plug-in, checkHelp > Supported RAWCameras. UseBatch >Convert Images to convert
images from one format to another, for example from jpg to png.

An example of batch processing of images could involve applying a solarizing effect
to a number of images. To queue images for batch processing and perform the actual
processing, proceed as follows:

1 Select Batch > Image Effects or right-click the album's name and select Batch
Processes > Image Effects.

2 Set the effect to Solarize and click Options to determine the degree of the effect
to be applied and display an optional preview.

3 Decide whether to rename or overwrite the original images, or even have them
removed after the transformation has taken place.

4 Set the target folder to hold the resulting images. If you do not want the new
images to be written to the original folder, select New and add a new folder or
subfolder. Select the new folder with your mouse pointer.

5 Accept or modify the list of images queued for the transformation.

6 Click Start to initiate the transformation.

digiKam informs you about the progress and the success of the transformation.
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Figure 20.9 Batch Processing: Solarizing Images

20.12 Troubleshooting
Although SUSE Linux Enterprise Desktop and digiKam support a broad range of
cameras, you might occasionally hit one of the following problems when using your
digital camera with SUSE Linux Enterprise Desktop:

Downloading Images from Your Camera Fails
If downloading your images fails no matter which protocol you have chosen (PTP
or USB), try using the command line instead of digiKam. The gphoto2 --P
command initializes the camera and downloads the images if gphoto2 supports this
camera.

Your Camera is not Officially Supported by digiKam
Try gphoto2 --list-cameras and the information at http://www
.gphoto.org/ to obtain more information about the status of your camera's
support by Linux.

If the camera is not listed there, remove the storage medium from the camera and
use a card reader device (either an external or internal one). As soon as the medium
is detected, it is mounted automatically and you can import the images to your
digiKam collection with Import > Add Images or Import > Add Folders.
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20.13 For More Information
For more information about using digital cameras with Linux, refer to the following
Web sites:

• http://www.digikam.org>—The official homepage of digiKam

• http://www.digikam.org/drupal/docs—Theofficial digiKamHandbook

• http://www.gphoto.org—Information about gPhoto2

• http://www.gphoto.org/proj/libgphoto2/support.php—A
comprehensive list of supported cameras
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21F-Spot: Managing Your Digital
Image Collection
F-Spot is a management tool for your collection of digital images tailored for the
GNOME desktop. It allows you to assign different tags to your images in order to cat-
egorize them and offers various image editing options. For example, you can remove
red-eye, crop, and adjust brightness and colors. F-Spot supports sixteen common file
types, including JPEG, BMP, GIF, TIFF, and RAW.

You can import photos from your hard drive, your digital camera, or your iPod. You
can also use F-Spot to view slide shows, create photo CDs, generate a Website gallery,
or export your photos to your Flickr, 23, Picasa Web, or SmugMug account.

To access F-Spot, click Computer > F-Spot Photo Browser. The first time you run F-
Spot, you can tell it where to find the images you want to import into your collection.
If you already have a collection of images stored on your hard drive, enter the path to
the relevant directory and optionally include subfolders. F-Spot imports these images
into its database.
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Figure 21.1 F-Spot Main Window

Thumbnails of your images are displayed in the right part of the window, and detailed
information for a selected image is displayed in a sidebar to the left. By default, your
photos are displayed in reverse-chronological order, so your newest photos are always
at the top. You can sort your photos in chronological order or reverse-alphabetical order
by clicking View > Reverse Order.

TIP: Contents of the Sidebar

At the top of the sidebar, change its contents from Tags to Metadata, Edit, or
Folders. If the sidebar is not visible at all, press F9 or click View > Components
> Sidebar to make the sidebar visible.

A menu bar at the top of the window allows you to access the main menus. A toolbar
below the menu bar offers the following options (move the mouse over the icons to see
the tooltip, if there is an icon without descriptive text):

Table 21.1 F-Spot Toolbar

DescriptionIcon

Use this shortcut to change an image's orientation.Rotate (Left or Right)
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DescriptionIcon

The Browse mode allows you to view and search your
entire collection or tagged subsets of it. You can also use
the time line to search images by creation date.

Browse

This mode allows you to select one image and do some
basic image processing. Details are available in Sec-
tion 21.7, “Basic Photo Editing” (page 260).

Edit Image

Switch to fullscreen display mode.Fullscreen

Start a slide show.Slideshow

21.1 Importing Photos
You can import photos from your hard drive or from your digital camera (see Sec-
tion 21.2, “Downloading Pictures fromYour Camera” (page 251) for more information).
F-Spot automatically makes copies of photos imported from your hard drive. If you do
not want to copy images, uncheck Copy files to the Photos folder on the Import dialog
box, or press Shift when dragging photos into F-Spot.
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Figure 21.2 Importing Images into F-Spot

By default, F-Spot copies your photos to the Photos directory in your home directory.
You can change the directory F-Spot uses by clicking Edit > Preferences.

If all the photos you are importing are from a particular event, or if they have some
other characteristic in common, you can create a tag for them so you can easily find
them at a later time. Enter the tags that you want to associate on the import of all new
photos (separated by commas) in the Attach Tags field.

To import photos:

1 Click Photo > Import.

2 Select an Import Source, then click Open.

3 After the photos are finished loading, click Import.

The photos are added to your catalog.
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21.2 Downloading Pictures from Your
Camera

You can import new images from your digital camera by connecting it to the USB port
of your computer. The camera type is detected automatically. When you import photos
from your camera, F-Spot makes copies of them so that you can clear your camera's
memory.

1 Click Photo > Import.

2 Select your camera as the import source.

F-Spot launches a preview window displaying all the images that are available
for download from your camera. The files are copied to the target directory
specified viaCopy files to. If Import files after copy is selected, all images copied
from the camera are automatically imported to F-Spot's database. Tagging can
be done on import, if you select the appropriate tag with Select Tags. If you do
not want to import all the images on your camera to your database, just deselect
the unwanted ones in the preview window.
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3 Click Copy.

4 When the photo transfer is complete, click OK.

The photos are added to your catalog.

21.3 Getting Photo Information
When you select an image, some basic statistical information is displayed in the lower-
left part of the window. This includes the filename, its version (copy or original image),
the date of creation, size, and the exposure used in creating this particular photo.

To viewmore detailed information on a photo (including the EXIF data associated with
the file), selectMetadata below the Import button, then click Extended Metadata.

21.4 Managing Tags
Use tags to categorize any of your photos to createmanageable subsets of your collection.
F-Spot comes with default tags, but you can change them and add new ones. If, for
example, you want to organize your collection of portrait shots of your loved ones, do
the following:
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Figure 21.3 Creating Tags in F-Spot

1 Select the Browse mode of F-Spot.

2 Activate the Tags view in the sidebar to the left.

3 In the sidebar, right-click the People category, then select Create New Tag.

3a Create a new tag called Friends.

3b Create a new tag called Family.

The new tags appear as subcategories below the People category.

4 Attach tags to images or groups of selected images.

Right-click an image, select Attach Tag, then select the appropriate tag for this
image. To attach a tag to a sequence of images, click the first one, then press
Shift and select the other ones without releasing the Shift key. To attach a tag to
a group of selected images, press and hold Control and select the images. Right-
click for the tag menu and select the matching category.

You can also use the following methods to tag photos:
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• Drag and drop a photo onto a tag.

• Drag and drop a tag onto a photo.

• Use the options on the Tags menu.

• Select a photo, then press t to display the Tags entry bar.

The first photo you associate with a tag is used for that tag's icon. To edit a tag's name,
parent tag, or icon, right-click the tag, then select Edit Selected Tag.

You can change a tag's parent by dragging and dropping it where you want. You can
also edit the name of a tag by selecting it and pressing F2.

After your photos have been tagged, you can browse your collection by tags. Using our
earlier example, clicking People > Family limits the displayed collection to the photos
tagged Family. Searching your collection by tag is also possible through Find > Find
Selected Tag. The result of your search is displayed in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching
them. The tag editing functions are also accessible on the Tags menu in the top menu
bar.

21.5 Searching and Finding Photos
Asmentioned in Section 21.4, “Managing Tags” (page 252), tags can be used as a means
to find certain images. Another way to find images is to use the Timeline below the
toolbar. By dragging the little frame along this time line, you can limit the images dis-
played in the thumbnail overview to those taken in a selected time frame. F-Spot starts
with a default time line, but you can edit the time span by moving the sliders to the
right and left of the time line.

You can also start a search by clicking Find > Show Find Bar. With the find bar dis-
played, you can drag tags from the tag view to the find bar.
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Figure 21.4 Show Find Bar in F-Spot

To find photos that are tagged with more than one tag, select the first tag in the tag view
(or drag the tag onto the Find bar), then drag the second tag and drop it on top of the
first. You can also right-click the second tag in the tag view, or click Find > Find Se-
lected Tag With, then select the first tag (or group of tags).

You can search for photos that do not have a particular tag by double-clicking a tag in
the Find bar. Photos that do not have that tag (or any tag at all) are displayed. You can
also right-click a tag in the Find bar, then select Exclude.

To remove a tag from the search, drag it away from the Find bar, or right-click the tag
and select Remove.

By default, photos tagged Hidden will not be shown. You must explicitly include the
Hidden tag in your search to show such photos.

There is also a type-to-find entry. Press the forward slash (/) to open it. It cannot be
used at the same time as the Find bar. You can type queries such as “TagA and (TagB
or (TagC and TagD))”. At any point, if F-Spot recognizes what you have typed as a
valid query, it will update your search. The not operator is not yet supported.
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Figure 21.5 Type-to-find Search

21.6 Exporting Image Collections
F-Spot offers a range of export functions for your photo collections: Section 21.6.1,
“Generating a Website Gallery” (page 256), Section 21.6.2, “Exporting Photos to CD”
(page 257), Section 21.6.3, “Exporting Photos to a Folder” (page 258), and Section 21.6.4,
“Posting to a SmugMug, Flickr, 23hq, Zooomr, or Picasa Web Albums Account”
(page 259).

21.6.1 Generating a Website Gallery
If you use the PHP software known as Gallery [http://gallery.sourceforge
.net], you can post your photos to your existing album. Ensure that the Remote
module in your Gallery installation is enabled (Site Admin > Plugins (Get More Plugins)
> Remote).
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PennAve [http://pennave.sourceforge.net/] is another dynamic photo
gallery application. It is designed to be used in conjunction with F-Spot to organize and
manage your photos.

1 Select the photos you want to export.

2 Click Photo > Export to >Web Gallery.

3 Select the gallery you want to export your images to, or click Add to add a new
gallery.

F-Spot establishes a connection to theWeb location entered for your web gallery.

4 Select the album you want to export the images to, then specify whether to resize
and rotate the images automatically and export titles and comments.

5 Click Export.

21.6.2 Exporting Photos to CD
1 Select the photos you want to burn to CD.

2 Click Photo > Export to > CD, then click Export.
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F-Spot copies the files and opens theWrite to Disc dialog—in case of trouble it
just tries to write an ISO file via the Location for Image File dialog. Click Burn
to confirm the operation.

3 Assign a name to your image disk, then select the writing speed.

4 ClickWrite to start the CD writing process.

21.6.3 Exporting Photos to a Folder
1 Select the photos you want to export.

2 Click Photo > Export to > Folder.
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3 Choose from the following export methods:

Create standalone web gallery: Export your photos to an interactiveWebsite,
ready for you to upload.

Save the files only: Export your photos as files within directories, without
putting them into a gallery.

Create gallery using “Original”: Export your photos ready for use with
Jakub Steiner's Original Photo Gallery [http://jimmac.musichall.cz/
original.php] software.

4 Click Export.

21.6.4 Posting to a SmugMug, Flickr, 23hq,
Zooomr, or Picasa Web Albums
Account

If you use SmugMug [http://www.smugmug.com/], Flickr [http://www
.flickr.com/], 23hq [http://www.23hq.com/], Zooomr [http://www
.zooomr.com/], or PicasaWebAlbums [http://picasaweb.google.com/],
you can post your files directly from F-Spot to your account.

1 Select the photos you want to export.

2 Click Photo > Export to > SmugMug, Flickr, 23hq, Zooomr, or Picasaweb.

3 Select or unselect the options you want in the Export dialog box.

The options displayed on the Export dialog box depend on the type of account
you are exporting to. For example, Flickr and 23hq exports require authorization
in order to upload photos. To do this, click Authorize to open a Web browser,
then log in to your account.

4 Click Export.
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21.7 Basic Photo Editing
F-Spot offers several basic image editing functions, such as the ability to crop, remove
red-eye, and adjust color and brightness.

When you edit a photo, a new copy (called a version) is created, so your original photo
is never altered. After your first edit to a photo, subsequent edits modify the same ver-
sion. If you want to create multiple versions of a photo (for example, with different
cropping or coloring), click Photo > Create New Version. To access a photo's original
version, click Photo > Version > Original.

1 Select the photo you want to edit.

2 To enter edit mode, click the Edit Image icon in the toolbar, double-click the
image, or press Enter.

3 Choose from the following edit functions, using the buttons of the sidebar to the
left or the entries from the Edit menu:

DescriptionFunction

Cropping an image is a great way to improve the
quality of a photograph by improving how it is

Crop
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DescriptionFunction

framed. You crop a photo by selecting the part of
the photo you want to keep. If you want your
photo to be the exact dimensions necessary for a
certain print size, you can constrain the kind of
selection F-Spot will allow you to draw by choos-
ing the appropriate size from the Constraint drop-
down list. See the description of the Remove Red-
Eye function for details on making a selection on
your photo.

After youmake your crop selection, click theCrop
icon beneath the photo to finalize the crop. If you
are working with the original photo, cropping
creates a new version of your photo.

To remove red-eye from a photo, select a zone
containing the eyes. You might want to zoom in

Red-Eye Reduction

on the image to accurately select the eyes in the
photo. You should be able to correct both eyes on
the same person at once, or even the eyes from
multiple people at once. If this does not work, or
if the selected zone contains some vivid red parts
(such as lips), you will probably have to correct
one red eye at a time.

To make your selection, click one corner of the
rectangle that will be your selection, then drag
your mouse to the diagonal corner and release it.
You can resize your selection by dragging its
edges, and you can move it by clicking in the
middle of it and dragging it to where you want it.

After you have selected a zone, remove the red by
clicking the Red-eye icon beneath the photo.

Converts the photo to black and white.Desaturate
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DescriptionFunction

Converts the photo to sepia tones.Sepia Tone

The Straighten effect helps you level a photo and
is useful when editing landscapes taken without a

Straighten

tripod (when the imaginary line of horizon is not
at 0°). This tool rotates a photo by a specified angle
and automagically crops the resulted image so that
you always see a perfect rectangle.

Sharpening one region of a picture while blurring
all the rest is a way to emphasize a particular area

Soft Focus

and grab attention. The soft focus effect is a way
to emulate a lens that allows shooting with a short
distance in front of and beyond the subject that
appears to be in focus.

Choose the central point of the area you want to
be in focus, then click the Soft Focus icon beneath
the photo. Adjust the amount of blurring, then click
Apply.

This effect automatically adjusts color levels to
make a color-balanced picture. It works best for

Auto Color

pictures taken with automatic white balance. Click
the Automatically adjust the colors icon to access
this feature.

To adjust the brightness, contrast, and colors of a
photo, click the Adjust the photo colors icon to

Adjust Colors

open the adjustment dialog box. Change the set-
tings you want, then click OK.

Access this function by clicking Edit > Adjust
Time. Adjust date and time, then click OK.

Adjust Time

262 Application Guide



DescriptionFunction

Access this function by clicking Edit > Sharpen.
Adjust the values for Amount, Radius, and
Threshold to your needs, then click OK.

Sharpen

You can add a description or a comment to a photo
by clicking the text entry box below the photo and
entering text.

Comment

4 (Optional) If you want to edit another photo, use the arrow keys on the toolbar
at the right to switch to a new photo.

5 To exit the edit mode, click Browse on the toolbar.

TIP

Professional image editing can also be done with GIMP. For more information,
see Chapter 19, GIMP: Manipulating Graphics (page 205).

21.8 Sharing Photos
You can use either of the following methods to share your photos using F-Spot. Both
methods share only the photos you have selected when you run them.

• Section 21.8.1, “E-mailing Photos” (page 263)

• Section 21.8.2, “Printing Photos” (page 264)

21.8.1 E-mailing Photos
You can e-mail your photos directly from F-Spot, sending them as-is (original size) or
resizing them.

1 Select the photos you want to e-mail.
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2 Click Photo > Send by Mail.

3 Select a size for your photos.

4 Click Create Mail.

Your default e-mail program opens, with your photos attached to a new mail
message.

21.8.2 Printing Photos
1 Select the photos you want to print.

2 Click Photo > Print.
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3 Select the print options you want, such as the printer you want to use or the page
orientation, then click Print to print your photos.

21.9 The Preferences Dialog
Click Photo > Preferences to open the F-Spot Preferences dialog.
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In the preferences dialog you can configure where to store your imported photos, where
to store the tags, color profiles and the F-Spot appearance.
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Part VI. Multimedia





22Amarok, Kaffeine and More:
Playing Music and Movies
During installation, YaST normally identifies and configures the sound cards of your
computer automatically. Otherwise (or if you installed a new sound card), start YaST
and configure the sound card manually in the Sound module. For details, refer to Sec-
tion “Setting Up Sound Cards” (Chapter 5, Setting Up Hardware Components with
YaST, ↑Deployment Guide).When your sound card has been configured, you can control
the volume and balance with a mixer and start other sound applications.

Linux includes a wide range of sound and multimedia applications. Some of these ap-
plications are installed on your Linux system by default. With the applications described
here you can control the volume and balance of playback and play CDs, music and
movie files.

In case one of the listed applications is not installed by default on your system, use
YaST to install the missing packages. Use the search function of the YaST package
management tool to find the package names. For details on installing software, see
Chapter 6, Installing or Removing Software (↑Deployment Guide).

22.1 Mixers
Mixers provide a convenient means of controlling the volume and balance of the sound
output and input of computers.

The main difference between the various mixers is the outward appearance of the user
interface. However, there are a number of mixers that are designed for specific hardware.
From the mixers available, select the one that best suits your needs.
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The default KDE mixer application is KMix. If the mixer icon (a loudspeaker symbol)
is not visible in the panel of your desktop, press Alt + F2 and enter kmix or start the
mixer from themainmenu. By default, clicking the KMix icon in the system tray shows
the master controller with which to control the overall volume. To fine-tune your sound
settings for several channels, right-click the KMix icon and select ShowMixerWindow.

You can mute and increase or decrease the volume for all of the channels separately.
If you need or want to change the channel to be used as master channel, right-click the
KMix icon and click Select Master Channel. If you want more or less channels to appear
in the mixer window, select Settings > Configure Channels and select the ones you
want to show.

Figure 22.1 KMix Mixer Window

TIP: Starting the Mixer

Generally, it is advisable to open a mixer application before opening other
sound applications. Use the mixer to test and adjust the control settings for
the input and output of the sound card.

22.2 Playing Music Files
In Linux, find a variety of programs for playing music files, such as Ogg Vorbis or
WAV. Ogg Vorbis is a free audio compression format that is now supported by the
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majority of audio players and even portable MP3 players. The file types supported by
the applications depend on the engine used.

22.2.1 Amarok Music Player
The Amarok music player allows you to play various audio formats, create playlists,
and to listen to streaming audio broadcasts of radio stations on the Internet. The file
types supported depend on the engine used.

To start Amarok, press Alt + F2 and enter amarok.

Amarok Main Window
By default, the Amarokmain window is divided into three main parts: the browser pane
on the left, the context view in the middle and the playlist on the right side. Both the
browser pane and the context view include several tabs. Click a tab to switch views
and to access the information available there. Clicking a tab twice in the browser pane
hides the browser pane and expands the context view to the left.

Figure 22.2 Amarok—Main Window
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Browser Pane
Includes the following tabs:

Collection: Shows your personal music collection. The search field on top allows
you to create filters to search for certain artists or titles. Click the wrench icon at
the right of the browser pane, if you want to configure the way your collection is
displayed, or to reorganize the collection. For more information about customizing
the Collection tab, refer to Procedure 22.8, “Customizing the Collection Tab”
(page 283).

Internet: Shows the Internet services configured for Amarok. For details on
how to configure the services, refer to Section “Configuring Amarok” (page 281).
Click an entry to access the respective service. To get back to the list of services,
click the arrow icon in the top left corner.

Playlists: Lets you generate Dynamic Playlists based on certain criteria. To
access and organize any playlist you have saved before, clickMy Playlist. From
the playlist tab, you can also add or update Podcasts. For more information about
playlists, refer to Procedure 22.3, “Saving and Exporting Playlists” (page 275). To
learn more about podcasts, refer to Procedure 22.1, “Subscribing and Listening to
Podcasts” (page 273).

Filelists: Shows a file browser that corresponds to the standard KDE file man-
ager. This view is designed to find audio files you want to play, but not to add them
to your collection. Use the icons at the top to navigate the file system, change the
view or to create bookmarks.

Context View
Shows information about the currently played track. Depending on your configura-
tion of this view the following tabs are available: Albums, Bookmarks, Current
Track, Lyrics,Media Devices, Services, andWikipedia. To change views, click one
of the tabs. To learn how to configure the context view, refer to Procedure 22.9,
“Customizing the Context View” (page 284).

Playlist
Shows the list of tracks that has been added there to be played. This can include
tracks from your music collection, streams from the Internet, or podcasts . The
currently played track is highlighted in the list. Use the icons at the bottom of the
playlist to clear, modify, save or export the current playlist or click the wrench icon
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to configure the playlist layout. For more information about playlists, refer to Section
“Using Playlists” (page 275).

Listening to Music and Podcasts
With Amarok, you can listen to music from various sources—whether from your music
collection on hard disc or streams from the Internet.

To fill the playlist area, just drag and drop items from the browser pane on the left to
the playlist pane on the right (or double-click to move them to the playlist). This works
for items on the Collection, the Internet or the Files tab. To select multiple items, keep
Shift or Ctrl pressed while selecting the items. Alternatively, right-click an item on one
of the tabs and select if to append it to the playlist or if to replace the current playlist
with this item.

Double-click an item in the playlist to play it. Alternatively, use the control buttons in
the upper part of the Amarok main window to play, pause, stop or skip items in the
playlist.

For example, to listen to the music of your Last.fm neighbors, select Internet > Last.fm
>My Neighborhood, add this entry to the playlist and start playing.

Usually, Amarok plays all tracks displayed in the playlist pane from top to bottom and
stops after the last track. To modify play mode and behavior, select Playlist > Random
or Playlist > Repeat and select the desired options. Instead of manually adding items
to the playlist and then playing them in random order, you can also let Amarok create
dynamic playlists as described in Procedure 22.4, “Creating Dynamic Playlists”
(page 276).

Procedure 22.1 Subscribing and Listening to Podcasts

Podcasts are series of audio (or video) files that are released periodically and can be
downloaded automatically by subscribing to a Web feed. You can add and manage
podcasts on the Playlist tab of the browser pane. If the Podcast DirectoryWeb service
is configured for Amarok, you can also access a huge number of podcasts from there.

1 To add a podcast channel that you already know the URL of, switch to the
Playlists tab and click Add Podcast.

2 Copy or enter the podcast URL into the next dialog and confirm with OK.
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3 Right-click a podcast channel to open a context-menu allowing you to append
or load the podcast to the playlist, to download an episode, to configure the
podcast, to remove your subscription or to update the podcast channel.

4 If you want Amarok to automatically scan for updates on this podcast channel
or to automatically download new episodes, right-click the podcast channel and
select Configure. In the podcast configuration dialog you can also define the lo-
cation to where Amarok should save this podcast or limit the number of episodes
stored.

5 To use the integrated Web service to browse for available podcasts, switch to
the Internet tab and click Podcast Directory. For more information about the
AmarokWeb services, refer to Procedure 22.7, “Defining Basic Amarok Settings”
(page 282).

When clicking Podcast Directory for the first time, Amarok automatically
fetches the list of podcasts, which takes a few seconds. Otherwise click Update
to enforce a reload of the list. The available podcasts are sorted into categories.

6 Browse the list of podcasts or enter a term in the search field to filter for certain
podcasts.

7 To get automatic updates for a podcast, select the podcast and click Subscribe.

8 View and manage the podcasts that you have subscribed to as described in steps
Step 1 (page 273) to Step 1 (page 273) above.

Procedure 22.2 Listening to Web Radio

When listening toWeb radio streams, Amarok also displays the current title and track
played by the station.

1 To listen to a certain stream (like for example, a Web radio channel), select
Playlist > Add Stream.

2 Copy or enter the stream URL into the next dialog and confirm with OK. The
stream is automatically added to the playlist pane on the right.

3 Double-click the stream entry in the playlist to start listening. Alternatively, use
the control buttons in the upper part of the Amarok main window to play, pause,
or stop the stream.
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Using Playlists
If you have added several items form your music collection to the playlist pane on the
right, you can also save and export the current tracks as playlist for later reuse.

Instead of manually adding items to the playlist pane and setting a certain play mode,
Amarok can also make use of dynamic playlists. Dynamic playlists allow you to play
tracks from your collection in a random order or to define how Amarok should mix the
music an then turn the dynamic mode on.

Procedure 22.3 Saving and Exporting Playlists

If you save a playlist, it can be played again later with Amarok by accessing it from
the Playlists tab. In contrast to this, exporting a playlist allows you to store and use
it also outside of Amarok.

1 To save a playlist, either click the Save Playlist icon at the bottom of the playlist
pane.

The browser pane automatically switches to the Playlists tab. It shows the newly
added playlist belowMyPlaylists and prompts you to enter a name for the playlist.
If you do not enter a name, date and time of creation are automatically set as
name for the playlist.

2 To create folders inMy Playlists, click the Add Folder icon.

3 You can also modify an already saved playlist by dragging and dropping new
items from the playlist pane on the right onto the playlist entry shown belowMy
Playlists.

4 To load, rename or delete a playlist, right-click the playlist and select the appro-
priate menu item from the context menu.

5 To use a playlist in players other than Amarok, click the Export Playlist icon at
the bottom of the playlist pane.

NOTE: Sharing Playlists with Other Players

Save playlists in m3u format, so you can share them with any other
players using this format.
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6 Select or enter a location and filename for your playlist and click Save.

Procedure 22.4 Creating Dynamic Playlists

With dynamic playlists, Amarok lets you either play tracks from your collection in a
random order or lets you create biased playlists according to probability-driven criteria
(“biases”). You can create weighted random playlists that adhere to certain criteria
exactly (Proportional Bias) and to certain criteria approximately (Fuzzy Bias). It is
possible to mix both types of biases when configuring a dynamic playlist.

1 Click the Playlists tab at the left side of the Amarok main window and select
Dynamic Playlist.

2 To create a random playlist without matching any criteria, set the Playlist drop-
down list to Random (which is the default value) and activate theOn check-box.
A randomly created list of tracks appears in the playlist pane.

3 To add a criterion that should be matched exactly:

3a Click the Add icon in the Proportional Bias category.

3b Select the desired criterion from theMatch drop-down list.

3c From theWith drop-down list, select the value that you want to set for this
criterion.

3d With the Proportion slider, define which portion of the playlist should match
this criterion.

4 To add a criterion that should be matched approximately:

4a Click the Add icon in the Fuzzy Bias category.

4b Select the desired criterion from theMatch drop-down list.

4c From theWith drop-down list, select the value that you want to set for this
criterion.

4d With the Strictness slider, define how strictly to match this criterion.
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5 Add further proportional or fuzzy biases as desired.

6 To remove a bias, click the Remove icon in front of this bias.

7 To save the current configuration for the dynamic playlist, click the Save icon at
the upper right corner of the Dynamic Playlist category and enter a name.

The saved dynamic playlist configuration can now be accessed from the Playlist
drop-down list at any time.

8 To use the selected dynamic playlist, activate the On check-box.

9 Click Repopulate if you want to replace the current tracks in the playlist area
with the newly generated dynamic playlist.
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Managing your Music Collection

NOTE: Many Services Depend on Proper Tagging

When compressing (ripping) your audio data, tags are stored for each track,
containing meta data like information about the artist, the track, the album,
or the music genre. Usually, the tags are automatically assigned during the
ripping process but sometimes they need to be corrected manually as described
in Procedure 22.6, “Editing Tags, Statistics and Ratings” (page 280).

Many services (like retrieving covers from Amazon, or scrobbling your music
to Last.fm) depend on proper tagging of your collection—otherwise they
will fail or transfer incorrect data.

Amarok offers a lot of options for managing your personal music collection: For exam-
ple, you can let Amarok scan for any changes to your music collection, edit track infor-
mation (like tags or ratings and statistics) or automatically retrieve the cover artwork
for each album.

After initial creation and basic configuration of your collection as described in Section
“Configuring Amarok” (page 281), you can at any time trigger an update by selecting
Tools > Update Collection. This reflects any changes done to your collection folder on
the Collection tab immediately, without waiting for Amarok to update the collection
automatically during the next check.

Tracks of unknown artists or albums are grouped under Unknown at the beginning of
your collection. Compilation albums appear under Various Artists. To mark an album
as compilation album, right-click the album and select Show Under Various Artists.

To search or filter your collection for a certain track or album, enter the title (or part of
it) in the search field at the top. Each character you enter narrows down the search and
the selection in the browser is adjusted as you type. To search for specific metadata
such as Genre or Bitrate, or to combine several search options, click the Edit Filter
button to the right of the search field to open a dialog that provides advanced filter op-
tions.

In the following, find examples for further common tasks you might want to execute.
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Procedure 22.5 Assigning Album Covers

Amarok's Cover Manager lets you comfortably add, correct or fetch any missing
covers for your music collection. If automatic cover retrieval is configured, Amarok
tries to fetch any album covers from an Amazon Web server. If Amarok cannot find
an album cover (which is sometimes the case if the collection is not tagged properly
or if the album is only available via a direct sales channel), you can also manually
assign a cover or custom picture.

If not configured otherwise, album covers are displayed on the Collection tab, in the
context view and on the on-screen display (or on external widgets like PlayWolf).

Retrieval of covers relies on the tags of your music collection: Amarok uses the
Artist - Album query to search Amazon for covers. The better your collection
is tagged, the better the hit rate when automatically retrieving covers.

1 If you want Amarok to automatically retrieve cover artwork for each album, select
Settings > Configure Amarok > General and activate the respective option in the
configuration dialog.

2 Confirm your changes and close the configuration dialog.

3 To define from which Amazon Web server Amarok should get the covers, click
Tools > Cover Manager.
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Figure 22.3 Amarok—Cover Editor

4 From the Amazon Locale drop-down list choose the location of the Web server
that suits your needs best.

5 If Amarok could not retrieve all covers automatically, you can check for any
missing covers by setting the View to Albums Without Cover.

6 If necessary, change the Amazon Locale, then click Fetch Missing Covers.

7 If retrieval is still not successful or if you are not satisfied with a certain cover,
right-click the cover and select Fetch Cover to manually refine the search by
editing the search string.

8 To remove a cover, right-click the respective cover and select Unset Cover.

9 If you already have your own cover images, you can assign them by right-clicking
an album cover and choosing Set Custom Cover.

Procedure 22.6 Editing Tags, Statistics and Ratings

Although tags are usually created automatically when ripping your music, it is
sometimes necessary to edit or correct tags. Apart from editing tags, Amarok also
lets you manually edit statistics for a track like the rating or score. Amarok automati-
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cally assigns a score to a song (ranging from 0-100), based on how many times you
have played that song and if you have played it completely (or skipped it). Every time
the song finishes playing, the score is changed.

1 To edit or set tags for an artist, a complete album or individual tracks, right-click
the respective entry on the Collection tab and select Edit Track Details.

2 On the Tags tab, add or adjust the information as desired.

3 To set a custom rating for a track or to change the score, switch to the Statistics
tab.

4 Move your mouse pointer over the star symbols until they change color. The
more stars appear in yellow, the higher the rating. Click the mouse button to set
the rating.

5 If desired, also adjust the track's Score.

6 Confirm your changes with Save & Close.

Configuring Amarok
Amarok offers a variety of configuration options. At first start-up, the most important
settings to configure are the folders for your personal music collection and which back-
end and sound system to use for playback. Although you can use Amarok without a
music collection, it is recommended to create a collection. Most of the powerful, ad-
vanced features are only available with an existing collection.

Apart from that, Amarok comes with integrated Internet services that you can activate
or deactivate, like for example support for Last.fm, a popular Internet radio and
music community Web site.
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Procedure 22.7 Defining Basic Amarok Settings

1 Select Settings > Configure Amarok to access the Amarok configuration dialog.

2 ClickCollection and in the tree view, select the folder (or multiple folders) where
Amarok should scan for your music files.

3 Activate the respective options to make Amarok scan the folders recursively or
watch for changes in your music folders.

4 If you want to import an existing music collection (for example, from an older
Amarok version), click Import Collection and follow the steps on the screen.

5 From the Playback category of the configuration dialog, you can also adjust the
back-end and the output device for playing music, if necessary. To do so, click
Configure to open the Sound and Video Configuration module (also accessible
from the KDE Personal Settings). For more details about the output devices
available from the list, hover your mouse pointer over the respective entries.

6 To discover theWeb services integrated with Amarok, click the Internet Services
category. From there, you can activate, deactivate or configure access to several
services like AmpacheWeb media server, Jamendo legal and free music down-
load, Last.fm music community, Magnatune Store, MP3tunes music locker or
podcasts and shoutcasts directories.
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Some of the services require registration. To sign up for a service or to enter your
data for an already existing account, click the wrench icon next to the service.

7 To use and customize the appearance of anOn Screen Display showing informa-
tion like cover and artist of the currently played track, activate Use On-Screen
Display.

8 Set the appearance options as desired and drag the preview to the desired place
to define the position where the on-screen display should appear.

9 Confirm your changes with Apply .

TIP: Using Amarok Widgets

Instead of using the on-screen display to show information about the current
track, you can also add external widgets to your desktop for displaying infor-
mation or controlling Amarok, for example, the PlayWolf widget. For details
on how to add or download widgets, refer to Procedure “Adding Widgets to
the Desktop” (↑KDE User Guide).

Apart from configuring basic settings, Amarok also allows you to customize most of
the panels in the main window: you can define the way your collection is displayed,
which information to see in the context view and how the tracks in the playlist on the
right are shown.

Procedure 22.8 Customizing the Collection Tab

1 To change the criteria according to which your collection is sorted and displayed,
click the Sort Options icon at the upper right corner of the Collection tab.

2 Select one of the predefined criteria that are displayed at the top of the menu.

3 Alternatively, create your own sort options by using First Level, Second Level,
and Third Level.

4 Define if you want publication year and cover art of the albums to be displayed
in the collection.
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Procedure 22.9 Customizing the Context View

You can choose from a number of applets to be displayed in the context view. These
allow you to access different types of information about the currently played track
by clicking the respective applet. For example, theWikipedia applet searches for the
artist's name and displays the correspondingWikipedia article in the context browser.
Current Track shows the album cover (if available) and the listening statistics related
to the current track. To automatically search for the Lyrics of a track and display them
in the context view, add the Lyrics applet. This applet depends on one or more lyrics
scripts configured for Amarok. To add any scripts, use the Script Manager that is
available from the Tools menu in the Amarok main window.

1 To configure which applets should be displayed, click the wrench icon at the
bottom right corner of the context view. The panel at the bottom of the context
view changes and shows its configurations options.

2 To add an applet, click any of the Add icons.

3 Use the arrow icons to scroll through the list of available applets.

4 Click an entry to add the respective applet.

5 To move applets to a different place within the panel, hover the mouse pointer
over the respective applet until the cursor turns into a crosslines-like form. Move
the cursor to the desired position in the panel, then click again to insert the applet.

6 To remove an applet, click the applet's Remove icon.

7 To leave the configuration mode and to lock the applets in their position, click
the wrench icon.

Procedure 22.10 Customizing the Playlist

Amarok comes with several predefined layout settings for the playlist pane on the
right, but you can also choose to create your own layout from scratch (or based on
one of the default layouts).

1 To select one of the predefined layouts, click the wrench icon at the bottom of
the playlist and select Default, No Grouping or Verbose.
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2 To create your own layout, click the wrench icon and select Configure Playlist
Layouts.

3 Click the default layouts in Available Layouts to see the options configured for
each layout on the Head, Body and Single tabs on the right side.

4 Use the icons below Available Layouts to create a new playlist layout from scratch
or to copy an existing layout as a basis for a new layout. Enter a name for the
new layout.

5 On each of the tabs on the right, configure the elements Amarok should display
by dragging and dropping the desired elements from the top row onto the respec-
tive tab.

6 Change the position of an element on a tab by clicking it and moving it around.

7 To set format options like Italic or Bold or Left, Center, or Right, right-click an
element and select the respective option.

8 To remove an element from a tab, drag it back to the top row.

9 If all options are set according to your wishes, leave the Playlist Layout Editor
with OK to save the newly defined layout.

You can now switch to the new playlist layout at any time by clicking the wrench
icon and selecting the layout's name from the context menu.
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The Amarok Tray Icon
Like other KDE applications, Amarok adds an icon to the KDE system tray. You can
use this icon to control a large number of Amarok's features. Hovering the mouse
pointer over the icon displays information about the track currently played. By scrolling
the mouse wheel simultaneously you can reduce or increase the playback volume. A
single left-click closes the application window without affecting playback. Click again
to reopen the window. Clickingwith themiddlemouse button pauses playback—middle-
click again to resume playback. Right-clicking opens a context menu where you have
access to the player controls and can exit Amarok.

Using the Shift and Ctrl keys together with the mouse gives you access to more advanced
features. Holding Shiftwhile scrolling the mouse wheel seeks through the current track.
Holding Ctrl while scrolling the mouse wheel skips through tracks in the playlist.

You may also drag items and drop them on the tray icon to add them to the current
playlist. A pop-upmenu opens, asking whether to append the track to the playlist, append
and play it, or queue it after the current track.

For More Information
For more information about Amarok 2.x, refer to the following Web sites:

• http://amarok.kde.org/

• http://userbase.kde.org/Amarok

• http://amarok.kde.org/wiki/FAQ

• http://introducingkde4.blogspot.com/2009/01/blog-post
.html

22.2.2 JuK Jukebox
JuK is a jukebox application that lets youmanage your music file collection and playlists.
JuK maintains a list of all files it knows about. This is called the collection list. The list
is specific to JuK and is not shared with other applications. Independent of the collection
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list are playlists. You can have as many playlists as you want and you can share your
JuK playlists with other media players. You can also edit the tags of your music files.

JuK is included in the juk package. If JuK is installed, start it from the main menu or
press Alt + F2 and enter juk. On initial start-up you are prompted for the folders Juk
should scan for your music collection. Find more information about JuK in the online
help.

22.3 Handling Audio CDs
There are many ways to listen to your favorite music tracks. Either play a CD or play
digitized versions of them. The following section features CD player applications as
well as some applications that can be used for digitizing audio CDs.

For information about how to create your own CDs, refer to Chapter 25, K3b: Burning
CDs and DVDs (page 321).

IMPORTANT: CDDA and Analog CD Playback

There are two different ways of playing audio CDs. CD and DVD drives capable
of analog CD playback read the audio data and send it to the sound output
device. Some external drives connected via PCMCIA, FireWire, or USB need to
use CDDA (Compact Disk Digital Audio) to extract the audio data first then
play it as digital PCM. The players featured in the following sections do not
support CDDA. Use XMMS if you need CDDA support.

22.3.1 KsCD—Audio CD Player
KsCD is an easy-to-use audio CD player included in theskscd package. If it is installed,
press Alt + F2 and enter kscd to start the application.
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Figure 22.4 KsCD User Interface

22.3.2 Compressing Audio Data: Ripping
Audio compression can be handled by various tools. The following sections feature a
command line approach to encoding and playing audio data as well as some graphical
applications capable of audio compression.

Compressing Audio CDs with Konqueror
Konqueror is not only a browser and a file manager, it also allows you to rip audio CDs.
Before you start the actual ripping process with Konqueror, configure the handling of
audio CDs and the Ogg Vorbis encoder in the Personal Settings. From the main menu
selectConfigure Desktop, then clickAdvanced >Audio CDs. The configurationmodule
is divided into three tabs:General,Names, andOgg Vorbis Encoder. Normally, a suitable
CD device is detected automatically. Do not change this default setting unless the au-
todetection fails and you need to set the CD device manually. Error correction and en-
coder priority can also be set here. The Ogg Vorbis Encoder tab determines the quality
of the encoding. To configure online lookup of album, track, and artist information for
your ripped audio data, select Add Track Information.

To start Konqueror, press Alt + F2 and enter konqueror. Insert the CD into the CD-
ROM drive and enter audiocd:/ in the Location bar. Konqueror then lists the tracks
of the CD, and some folders.

To keep uncompressed audio data on your disk, just select the .wav files and drag
them into another Konqueror window to copy them to their final destination. To start
the Ogg Vorbis encoding, drag the Ogg Vorbis folder or files from this folder to
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another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis
folder at its destination.

Figure 22.5 Ripping Audio CDs with Konqueror

Command Line Tools for Encoding and Playback of
Audio Data
Ogg Vorbis (package vorbis-tools) is a free audio compression format that is now
supported by the majority of audio players and even portable MP3 players. The Web
page of the project is http://www.xiph.org/vorbis.

Your system comes with several tools supporting Ogg Vorbis. oggenc is a command
line tool used for encoding WAV files to Ogg. Just run oggenc myfile.wav to
transform a given .wav file into Ogg Vorbis. The -h option displays an overview of
the other parameters. Oggenc supports encoding with a variable bit rate. In this way,
an even higher degree of compression can be achieved. Instead of the bit rate, specify
the desired quality with the parameter -q. -b determines the average bit rate. -m and
-M specify the minimum and maximum bit rate.
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ogg123 is a command line Ogg player. Start it with a command like
ogg123 mysong.ogg.

22.4 Playing Movie Files
You can choose between several movie players shipped with your SUSE Linux Enter-
prise Desktop. Kaffeine, for example, can be run with several back-ends, such as Xine
and MPlayer.

To start Kaffeine, press Alt + F2 and enter kaffeine.

The formats you can view with Kaffeine depends on the back-end (by default, Xine is
used). Xine interprets many of the most common multimedia formats available. For
more information, refer to http://www.xine-project.org/.

In case the format is not supported by the player's engine, SUSE Linux Enterprise
Desktop offers to search for a suitable codec which you can then install with YaST.

Figure 22.6 Kaffeine Main Window

Kaffeine can also play multimedia streamed over the Internet, and can be used as a
plug-in for Konqueror. It provides the usual options for playing files in full screen
mode, navigating through files, and more. You can also take a snapshot of the video
and save it as an image.

KDE 4 also ships with Dragon Player, included in the dragonplayer) package.
Dragon Player uses the Phonon, which is a multimedia API that connects to any of
several multimedia frameworks. If Dragon Player is installed, start it by pressing Alt +

290 Application Guide

http://www.xine-project.org/


F2 and entering dragon. For more information on using Dragon Player, refer to the
online help.

22.5 Troubleshooting
In case you do not get any audio output, check the following:

Sound Card Configured?
Check if your sound card is properly configured with YaST. For more information,
see Section “SettingUp SoundCards” (Chapter 5, SettingUpHardware Components
with YaST, ↑Deployment Guide).

Volume Control in Mixer Application?
Check the volume control of the master channel and the other channels available
in a mixer application. For more information, see Section 22.1, “Mixers” (page 269).

Volume Control via Keyboard?
Many keyboards also have keys for controlling the volume. Check the volume
control keys of your keyboard.

Volume Control of the Application?
Most multimedia applications also provide volume controls. Check the volume
control in the application that you use to play music or movie files.

Sound Configuration in Personal Settings?
Check the defaults for the sound system configuration in the Personal Settings.
Access them from the main menu by selecting Configure Desktop. In the Personal
Settings, clickMultimedia to open the Sound and Video Configuration.

External Devices Plugged In Properly?
In case you have external devices like loudspeaker or headphones connected to
your machine, check that they are plugged in properly and that they are connected
to the right ports.
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23Banshee: Playing and
Managing Your Music
Banshee™ is a GNOME media management and playback application that lets you
import CDs, sync your music and video collection to a digital audio player, play music
directly from a digital audio player, create playlists with songs from your library, create
audio andMP3 CDs from subsets of your library, and subscribe to, download, and listen
to your favorite podcasts. Banshee also supports streaming audio through its Internet
Radio plug-in.

To open Banshee, click Computer > Banshee Media Player.

The first time you open Banshee, theMusik Library window opens ready to import
music and videos, or add Internet radio stations.
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Figure 23.1 Banshee Media Player

23.1 Listening to Music
You can listen to music in your library, which means that you will need to import music
from an external source such as a file, folder, or CD, or you can listen to music directly
off a CD. You can also listen to music from Internet radio stations, podcasts, and your
digital audio player (see Section 23.3, “Using Banshee with Your Digital Audio Player”
(page 303) for more information).

Banshee also comes with MP3 support. If your music collection consists of both MP3
and Ogg Vorbis files, you do not need to convert any of the files to a different format.
Just open Banshee and start listening.

If the format you are trying to play is not supported by the player's engine, Banshee
lets you search for a suitable codec which you can then install with YaST.

23.1.1 Importing Music
Banshee can import music from a file, folder, CD, or an alternate music source (such
as a digital audio player).

294 Application Guide



Figure 23.2 Import Music Library

1 In Banshee, clickMedia > Import Media.

2 Select an import source.

3 Click Import Media Source.

23.1.2 Playing Your Music
To play a song, simply select the song in the library and click the play button in the
upper left corner. Use the other buttons to pause a song or play the next or previous
song. Use the loudspeaker button on the right to adjust the volume. You can also use
the items on the Playback menu to repeat or shuffle songs.

Banshee has an integrated CD player.When you insert a music CD, your CD title appears
in the left panel. Select the title and click the play button to play your full CD.

Notification Area Icon
You can keep Banshee hidden in the notification area when you are not interacting with
it by minimizing the Banshee window. You will only see pop-up bubbles identifying
the current song when track changes happen.

If you do not want to see the pop-ups, click Edit > Preferences > Extensions > Notifica-
tion Area Icon > Disable.
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Music Recommendations
Banshee automatically recommends music that you might like, based on the currently
playing song. It finds artists and popular songs that people with similar musical tastes
enjoy.

Figure 23.3 Banshee Music Recommendations

If you do not want to receive recommendations, click View, then deselectContext Pane.

23.1.3 Ripping Your Music
To rip music from a CD and add it to your library:

1 Insert a CD into your CD or DVD drive.

Banshee automatically lists the CD as a source on the left sidebar.
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2 Select the CD title in the source list on the left, then click Import CD in the upper
right corner.

23.1.4 Listening to Internet Radio
You can use Banshee to listen to Internet radio stations and streaming audio. Add your
own stations.

Listening to an Internet Radio Station
To listen to Internet radio stations, select Radio in the source list on the left, then double-
click the station you want to listen to.
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Figure 23.4 Internet Radio Stations in Banshee

Adding a New Internet Radio Station
1 Right-click Radio in the source list, then click Add Station.
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2 Enter the stream details in the Add New Radio Station dialog box, then click
Save.

The new station is added to your list.

23.1.5 Listening to Podcasts
Banshee lets you subscribe, download, and listen to your favorite Podcasts.

Subscribing to a Podcast
1 To subscribe to a podcast, select Podcast in the source list on the left.

2 ClickMedia > Subscribe to Podcast.

3 Enter the URL of the podcast you want to subscribe to.

4 From the pull-down menu select what you want to happen when new episodes
of this podcast are available. You can change it later by right-clicking on the
name of the podcast in the main window.

5 Click Subscribe.

The new podcast is added to your list.

Listening to a Podcast
To listen to a podcast, select Podcasts in the source list, then double-click the podcast
you want to listen to.
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Figure 23.5 Podcasts in Banshee

Right-click Podcasts in the source list to update all podcasts, you are subscribed to,
manage podcast playlists, or set podcast related preferences.

To manage a single podcast you are subscribed to, right-click its name in the main
window, and select one of the offered actions such as episode handling, visiting the
podcast homepage, unsubscribing and deleting, and checking or setting properties.

23.2 Managing Your Music Library
Banshee gives you several ways to organize your music. You can create playlists, and
sort and rate songs. You can also view a variety of information about your music col-
lection, including playback statistics (when a song was last played and howmany times).

23.2.1 Organizing Your Music
1 To create a new music playlist, selectMusic in the source list on the left side.
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2 ClickMedia >New Playlist (or press Ctrl +N). A new playlist is displayed below
Music in the left panel. To rename it, right-click the playlist, select Rename and
enter the name you want.

3 To fill the new playlist, drag songs from the right-hand side of the window to
the relevant playlist entry and drop them.

Use the options on the Edit menu to remove or delete songs and rename or delete
playlists. You can sort a playlist by clicking the title of the column. Click the column
again to reverse the sort. You can also right-clickMusic, then click Sort Playlists.

You can edit the name of the artist, album, and title, as well as the track number and
track count. Simply select a song, then click Edit > Edit Track Information (E), or in
the main window right-click the song and select Edit Track Information. You can also
rate your music, which gives you the ability to play only songs with a certain rating.
To rate a song, select the number of stars you want to assign in the Rating field.

Figure 23.6 Track Editor

If you want to set all fields in a group to the same value, select multiple songs in a
playlist and click Edit > Edit Track Information. Make the changes you want, then click
Sync All Field Values. You can also use the Back and Forward buttons to cycle through
the selected songs.

Click the Properties tab to view detailed information about the selected song, including
the bit rate, the sample rate, when a song was last played, when it was imported, how
long the song is, how many times the song has been played, and where it is stored in
your file system.
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23.2.2 Creating Smart Playlists
You can create playlists that automatically add and remove songs based on criteria you
specify. For example, a smart playlist can contain songs you rated as five stars but that
you have not listened to for six months. Another smart playlist can contain all songs
published in 2010 that you have labeled with the Classical genre.

Banshee automatically updates all smart playlists when a change is made to your music
library. If you import new songs, Banshee checks to see if they match any of your
available smart playlists. When applicable, Banshee also updates your smart playlists
if you just listened to a song or updated a song's metadata.

Creating a Smart Playlist
1 ActivateMusic in the source list on the left side.

2 In the menu bar, clickMedia > New Smart Playlist.

3 Specify a name for the smart playlist, then select the criteria for songs in this
playlist to match.

Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

4 Click Save. The smart playlist is added to your music library.
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23.3 Using Banshee with Your Digital
Audio Player

Banshee supports several digital audio players, including Apple* iPods, Creative*
Nomads*, Dell* DJs, Nokia* N810, and almost any other generic USB Mass Storage
player. Instead of having to use separate applications to get support for your audio de-
vices, Banshee gives you integrated support and lets you copy your music to or from
your device, no matter what format the music is in.

23.3.1 Playing Music from your Digital
Audio Player

To play music from your digital audio player, simply plug your player into your system.
After the system recognizes the device, an icon is displayed in the left panel in Banshee.

Select the icon to display the music on your device in the right panel. Double-click the
song you want to listen to.
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Figure 23.7 Banshee MP3 Playback from a Nokia N810

To view or change device properties, right-click your device, then select Device Prop-
erties. From there, you can view various pieces of information. For example, if you
have an iPod, you can update the owner's name.
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Figure 23.8 Banshee iPod Device Properties

23.3.2 Adding Music to Your Digital Audio
Player

To add tracks to your player, simply drag them from your music library to your device.

Banshee transparently supports the transcoding of your songs for any device. You can
have your music library in any number of formats (including, but not limited to, FLAC,
Ogg Vorbis, MP3, and AAC), and it will be transparently transcoded before it is sent
to your digital audio player.

To remove tracks, select your device in the list of sources, right-click the song you want
to delete, then click Delete from <device_name>.
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23.3.3 Copying Music on Your Digital Audio
Player to Banshee

Banshee supports the importing of music from a digital audio player to your music li-
brary. Simply drag and drop the songs from the digital audio player to your music library.
You can also import all of the music on your digital audio player by right-clicking your
player in the source list and selecting Import.

Figure 23.9 Importing Music from Your Digital Audio Player to Banshee

23.3.4 Synchronizing Your Library
To keep your digital audio player up to date with your Banshee Library, select your
player in the source list, disableManually Manage this Device, then click Synchronize
in the upper right corner.

Banshee also synchronizes the ratings and cover art in your tracks to your iPod.

23.4 Creating Audio and MP3 CDs
1 Insert a blank CD into the CD or DVD drive.

2 Select the songs you want to burn, then click Edit >Write CD.

3 Click Burn. Brasero starts where you can set additional options. Then click Burn
again. For more information about Brasero, see Chapter 26, Brasero: Burning
CDs and DVDs (page 327).

You can track the status of the burn in the bottom left corner of Banshee. A
message box appears when the burn is complete.
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4 Click OK.

23.5 Sharing Your Music
You can automatically update your online Scrobbler [http://www.last.fm] profile
with the music you listen to in Banshee. This lets others see what you are listening to,
and gives you access to charts detailing your listening history. If you join groups such
as the Banshee Group [http://www.last.fm/group/Banshee], you can also
see what other people are listening to.

Before you can share your music, you need to enable the Scrobbler plug-in and enable
song reporting.

1 In Banshee, click Tools > Last.fm > Configure.

2 If you have already registered with Last.fm [http://www.last.fm/], click
Enable Song Reporting. Then use Configure and specify your Last.fm username
and password.

If you have not previously registered with Last.fm, also open theConfigure dialog
and click Sign up for Last.fm. This opens the Last.fm website, where you can
register. Click Enable Song Reporting, then specify your Last.fm username and
password.

3 Click Save and Log In. Banshee starts reporting with the next song you play.

After Scrobbler is configured, use the options on the Tools > Last.fm > Enable
Song Reportingmenu to enable or disable song reporting, visit your user profile
Web page, or visit the Web site of any Scrobbler groups you belong to.

23.6 Configuring Banshee Preferences
1 Click Edit > Preferences.
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2 For example, choose from the General tab whether to write metadata to the im-
ported files or disable features requiring Internet access.

Click Copy Files to Music Folder When Importing to place a copy of the files
you import in your Banshee music folder.

3 For example, choose from the Source Specific tab:

Music
Specify the music folder location. This location is used when you import
music.

• File System Organization: Determine folder hierarchy in the music library, and
how filenames are displayed.

• Miscellaneus: Automatically detect BPM for all songs.

Videos
Specify the video folder location. This location is used when you import
videos.

Podcasts
Specify the podcast folder location. This location is used when you download
podcasts.
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Audio CDs

Import Format
Determine encoding profiles for CD ripping. Select the import format
you want, then click Edit to configure advanced options for that format.

Automatically import audio CDs when inserted
Import will happen automatically when you insert a CD in your drive
and close the tray.

Eject when done importing
Eject media automatically when music import is done.

Use error correction when importing
The error correction tries to work around problem areas on a disk, such
as surface scratches, but can substantially slow down the time it takes
to import.

Play Queue
Configure the play queue.

4 In the Extensions tab enable or disable features such as Cover Art Fetching or
Internet Radio.

5 Click Close to save your changes.
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24Totem: Playing Videos
Totem is the default movie player for the GNOME desktop. Totem provides the follow-
ing multimedia features:

• Support for a variety of video and audio files

• A variety of zoom levels and aspect ratios, and a full screen view

• Seek and volume controls

• Playlists

• Complete keyboard navigation

• Video thumbnailer for GNOME

• Nautilus properties tab

To start Totem, click Computer >More Applications > Audio & Video > Totem.

24.1 Using Totem
When you start Totem, the following window is displayed.

Totem: Playing Videos 311



Figure 24.1 Totem Movie Player Start Up Window

24.1.1 Opening a Video or Audio File
1 ClickMovie > Open.

2 Select the files you want to open, then click Add

You can also drag a file from another application (such as a file manager) to the Totem
window. Totem opens the file and plays the movie or song. Totem displays the title of
the movie or song beneath the display area and in the titlebar of the window.

NOTE: Unrecognized File Format

If you try to open a file format that Totem Movie Player does not recognize,
the application displays an error message and recommends a suitable codec.

You can double-click a video or audio file in the Nautilus file manager to open it in the
Totem window by default.
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24.1.2 Opening a Video or Audio File By URI
Location

1 ClickMovie > Open Location.

2 Specify the URI location of the file you want to open, then click Open.

24.1.3 Playing a DVD, VCD, or CD
To play a DVD, VCD, or CD, insert the disc in the optical device of your computer,
then clickMovie > Play Disc.

To eject a DVD, VCD, or CD, clickMovie > Eject.

To pause a movie or song that is playing, click the button, or clickMovie >
Play/Pause. When you pause a movie or song, the statusbar displays Paused and the
time elapsed on the current movie or song.

To resume playing a movie or song, click the button, or clickMovie > Play / Pause.

To view properties of a movie or song, click View > Sidebar to make the sidebar appear,
then click Properties in the drop-down list. The dialog contains the title, artist, year,
and duration of movie or song, video dimensions, codec, framerate, and the audio bitrate.

24.1.4 Seeking Through Movies or Songs
To seek through movies or songs, use any of the following methods:

To skip forward
To skip forward, click Go > Skip Forward.

To skip backward
To skip backward, click Go > Skip Backward.

To move to next movie or song

To move to the next one, click Go > Next Chapter/Movie, or click the button.
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To move to previous movie or song
To move to the previous movie or song, click Go > Previous Chapter/Movie, or

click the button.

24.1.5 Changing the Zoom Factor
To change the zoom factor of the display area, use any of the following methods:

To zoom to full screen mode
Click View > Fullscreen. To exit fullscreen mode, click the Leave Fullscreen button
or press Esc.

To zoom to half size (50%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:2.

To zoom to size (100%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:1.

To zoom to double size (200%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 2:1.

To switch between different aspect ratios, click View > Aspect Ratio. The supported
aspect ratios include:

• Auto

• Square

• 4:3 (TV)

• 16:9 (Widescreen)

• 2.11:1 (DVB)

The default aspect ratio is Auto.
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24.1.6 Showing or Hiding Controls
To hide Totem window controls, click View > Show Controls and deselect the Show
Controls option. To show the controls on the Totem Movie Player window, right-click
the window, then select Show Controls.If the Show Controls option is selected, Totem
Movie Player shows the menubar, time elapsed slider, seek control buttons, volume
slider, and statusbar on the window. If the Show Controls option is not selected, the
application hides these controls and shows only the display area.

24.1.7 Managing Playlists
To show the playlist, click View > Sidebar, then click Playlist at the top of the sidebar.
The Playlist dialog box is displayed.

You can use the Playlist dialog box to do the following:

• To add a track or movie: Click the Add button. Select the file you want to add
to the playlist, then click OK

• To remove a track or movie: Select the filenames from the filename list box,
then click Remove.

• To save a playlist to file: Click the Save button, then specify a filename

• Tomove a track ormovie up the playlist: Select the filename from the filename
list box, then click the Up button.

• To move a track or movie down the playlist: Select the filename from the
filename list box, then click the Down button

To hide the playlist, click View > Sidebar, or click the Sidebar button.

To enable or disable repeat mode, click Edit > Repeat Mode. To enable or disable
shuffle mode, click Edit > Shuffle Mode.
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24.1.8 Choosing Subtitles
To choose the language of the subtitles, click View > Subtitles > Select Text Subtitles,
then select the subtitles language (DVD) or subtitle file (AVI etc) you want to display.

To disable the display of subtitles, click View > Subtitles > None.

By default, Totem Movie Player chooses the same language for the subtitles that you
use on your computer.

Totem Movie Player automatically loads and displays subtitles if the file that contains
them has the same name as the video file and has an srt, asc, txt, sub, smi, or
ssa file extension.

24.1.9 Taking Screenshots
To take a screenshot of a movie or a visualization of song that is playing, click Edit >
Take Screenshot. You can save a screenshot to either of the following:

• File: Select Save screenshot to file, then click the Browse button to specify a
filename.

• Desktop: Select Save screenshot to the desktop.

24.2 Modifying Totem Movie Player
Preferences

To modify Totem Movie Player preferences, click Edit > Preferences. You can modify
the following:

24.2.1 General Preferences
The Totem General Preferences let you select a network connection speed, specify if
media files should be played from the last used position, and change the font and encod-
ing used to display subtitles.
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Figure 24.2 Totem General Preferences

General Preferences include the following:

Playback
Lets you specify whether to start playing the movie from the last position.

Networking
Select network connection speed from the Connection speed drop-down list box.

Text Subtitles
Lets you specify whether to load the subtitles automatically, and change the font
and encoding used to display the subtitles.

24.2.2 Display Preferences
The TotemDisplay Preferences let you choose to automatically resize the windowwhen
a new video is loaded, change the color balance, and configure visual effects when an
audio file is played.
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Figure 24.3 Totem Display Preferences

Display Preferences include the following:

Automatically resize the window when a new video is loaded
Select this option if you want Totem Movie Player to automatically resize the
window when a new video is loaded.

Also disable the screensaver when playing audio
Select this option if you want Totem Movie Player to automatically disable the
desktop screensaver while an audio file is playing.

Visual Effects
You can choose to show visual effects when an audio file is playing, select the type
of visualization you want to show, and the visualization size.

Color Balance
Specify the level of color brightness, contrast, saturation, and hue.
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24.2.3 Audio Preferences
The Totem Audio Preferences dialog box lets you select the audio output type.

Figure 24.4 Totem Audio Preferences
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25K3b: Burning CDs and DVDs
K3b is a comprehensive KDE program for writing data and audio CDs and DVDs. Start
the program from the main menu or by entering the command k3b. The following
sections brief you on how to start a basic burning process.

25.1 Creating a Data CD or DVD
To create a data CD or DVD, proceed as follows:

1 Select File > New Project > New Data Project. The project view appears in the
lower part of the window.

2 Drag and drop the desired files and directories from the file list to the project
folder.

3 Save the project under a name of your choice with File > Save as.

4 Select Project > Burn from the menu or hit Ctrl + B. A dialog opens with four
tabs offering various options for writing the CD or DVD (see Figure 25.1.)
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Figure 25.1 Customizing the Burning Process

5 Select the Burn Medium. The detected medium and writer are displayed under
this pop-up menu. If you have more than one writer installed, choose which one
you want to use here.

6 Choose the burning speed, usually Auto.

WARNING: Select the Writing Speed with Care

Normally, you should select Auto, which chooses the maximum writing
speed possible. However, if you increase this value but your system is
not able to send the data fast enough, you possibly get faulty disks due
to buffer underruns. If you get these kind of errors, choose a lower
writing speed to be on the safe side.

7 Set the name of the medium under Filesystem > Volume Name. If you need more
detailed information, set your additional data withMore fields.... In most cases
you can leave the options as there is.

8 Start the process with Burn.
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25.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Proceed as follows:

1 Select File > New Audio CD Project from the main menu.

2 Drag and drop the individual audio tracks to the project folder. The audio data
must be in WAV or Ogg Vorbis format. Determine the sequence of the tracks
by moving them up or down in the project folder.

3 If necessary, change the start and end offset of the audio source. Right-click and
choose Edit Source.... Correct the start and end offset and proceed with Ok.

4 Click Burn to open the dialog window.

5 Specify the parameters to adjust burning speed and other options. When burning
audio CDs, choose a lower burning speed to reduce the risk of burning errors
and improve longevity of your media.

When you mix your audio CD with tracks from different albums, in most cases
recording levels vary. You can adjust the volume in the Advanced tab with the
Normalize volume levels option.

6 Start the actual burning process using Burn.

The previous procedure is useful in most cases. However, you can improve your audio
CD with the help of CD Text. With the help of CD Text, you are able to add certain text
information to a CD (such as CD title, artist name, and track name). CD players that
support this feature can read and display this information. To add CD text information
to your audio tracks, select the track first. Right-click and select Properties and enter
your information in the window that opens. You can also download track information
from the Internet by clicking Query Cddb.

25.3 Copying a CD or DVD
To copy a CD or DVD, proceed as follows:
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1 Insert the medium you want to copy.

2 Click Tools > Copy Medium... from the main menu. A dialog box appears as
shown in Figure 25.2.

Figure 25.2 Copying a Medium

3 Specify the source drive you want to copy.

4 CheckCreate image to cache data to the hard disk before writing them on a target
medium.

5 Check Only create image to create an image in the path specified in the Image
tab in theWrite Image Files To option and burn the image later.

6 Click Start to begin with the process.

25.4 Writing ISO Images
If you already have an ISO image, go to Tools > Burn Image or Tools > Burn DVD ISO
Image. Enter the location of the Image to Burn in the window that opens. K3b calculates
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a check sum and displays it inMD5 Sum. Make sure to compare the ISO files you
downloaded from the Internet with the MD5 sum provided by the source of the image.
If the sums are different, the image has not been downloaded correctly.

Choose the medium and writer to use in Burn Medium. Select the writing speed. Set
your preferences, such as number of copies in Settings. Use the tool tip to display a
short note. To burn the disk, click Start.

25.5 Creating a Multisession CD or
DVD

Multisession disks can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions to a multisession disk.

NOTE: About Storage Space on Multisession Disks

Be aware that multisession disks need space to keep an account of all the entries
from your sessions. This leads to a smaller amount of available space on your
disk. The amount depends on the number of sessions.

To start a new multisession disk, do the following:

1 Create your data disk first as described in Section 25.1, “Creating a Data CD or
DVD” (page 321) and add all your files. You cannot start with an audio CD ses-
sion. Make sure that you do not fill up the entire disk, because otherwise you
cannot append a new session.

2 Click Import Session.

3 Start the burning session with Burn.

After a successful burning process, you have created a multisession disk. As long as
the media contains enough space, you can append more sessions if you like. Finish
disks with Finish Multisession (in the multisession tab) only if you are sure you do not
need any new sessions or the space is occupied.
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25.6 For More Information
Apart from the functions described above, K3b offers other functions, such as ripping
music from audio CDs, rewriting CDs, and more. You can find more information about
K3b at http://k3b.org/.
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26Brasero: Burning CDs and
DVDs
Brasero is a GNOME program for writing data and audio CDs and DVDs. Start the
program from the main menu or by entering the command brasero. The following
sections brief you on how to start a basic burning process to get your first Linux-made
CD or DVD.

26.1 Creating a Data CD or DVD
After starting Brasero for the first time, the main window appears as shown in Fig-
ure 26.1.
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Figure 26.1 Main View of Brasero

To create a data CD or DVD, proceed as follows:

1 Click Data project or select Project > New Project > New Data Project... from
the main menu. The project view appears.

2 Drag and drop the desired directories or individual files either from your file
manager or by clicking on Add. To show your directory structure directly in
Brasero, select View > Show Side Panel or press F7.

3 Optionally, save the project under a name of your choice with Project > Save
As....

4 Name your medium. The original label is Data disc (date).

5 Choose the method: on CD/DVD, or in an ISO image file.

6 Click Burn.... A new dialog box appears, depending on what type you have se-
lected in the last step:

• CD/DVD You can define some parameters. like the burning speed or
where to store temporary files. Furthermore, Brasero lets you activate, if you
want to burn it directly and eject the medium after burning.

• ISO Image Specify a filename for your ISO image file.
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7 Start the process with Burn.

26.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Proceed as follows:

1 Select Project > New Project > New Audio Project.

2 Drag and drop the individual audio tracks to the project folder. The audio data
must be in WAV or Ogg Vorbis format. Determine the sequence of the tracks
by moving them up or down in the project folder.

3 Click Burn to open the Disc burning setup dialog box.

4 Specify a drive to write to.

5 Click Properties to adjust burning speed and other preferences. When burning
audio CDs, choose a lower burning speed to reduce the risk of burning errors.

6 Click Burn.

26.3 Copying a CD or DVD
To copy a CD or DVD, proceed as follows:

1 Click Disc Copy or go to Project > New Project > Copy Disc.... The CD/DVD
copy options dialog box opens.

2 Specify the source drive you want to copy.

3 Specify a drive or image file to write to.

4 If necessary, change the burning speed, the temporary directory and other options
in properties.

5 Click Copy.
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26.4 Writing ISO Images
If you already have an ISO image, click on Burn image or go to Project > New Project
> Burn Image.... Choose the medium and writer and change parameters, if necessary,
by clicking Properties. Choose the location of the image file with the popup menu, la-
beled Path. Start the burning process and click Burn.

26.5 Creating a Multisession CD or
DVD

Multisession discs can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. One note of interest is that you are not only limited
to data CDs or DVDs. You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following:

1 Start with a data disc first as described in Section 26.1, “Creating a Data CD or
DVD” (page 327). You cannot start with an audio CD session. Make sure that
you do not fill up the entire disc, because otherwise you cannot append a new
session.

2 Click on Burn. The Disc Burning Setup opens.

3 Select Leave the disc open to add other files later to make the disc multisession
capable. Configure other options if needed.

4 Start the burning session with Burn.

26.6 For More Information
You can find more information about Brasero at http://www.gnome.org/
projects/brasero/.
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27Help and Documentation
SUSE® Linux Enterprise Desktop comes with various sources of information and
documentation, many of which are already integrated in your installed system:

Desktop Help Centers
The help centers of both the KDE desktop (KDE help center) and the GNOME
desktop (Yelp) provide central access to themost important documentation resources
on your system, in searchable form. These resources include online help for installed
applications, man pages, info pages, and the Novell/SUSE manuals delivered with
your product. Learn more about your desktop's help center in Section 27.1, “Using
the KDE Help Center” (page 334) and Section 27.2, “Using GNOME Yelp”
(page 336).

Separate Help Packages for Some Applications
When installing new software with YaST, the software documentation is installed
automatically in most cases and usually appears in the help center of your desktop.
However, some applications, such as GIMP,may have different online help packages
that can be installed separately with YaST and do not integrate into the help centers.

Documentation in /usr/share/doc
This traditional help directory holds various documentation files and the release
notes for your system. Find more detailed information in Section “Documentation
Directory” (Chapter 27, Help and Documentation, ↑Administration Guide).

Man Pages and Info Pages for Shell Commands
When working with the shell, you do not need to know the options of the commands
by heart. Traditionally, the shell provides integrated help by means of man pages
and info pages. Read more in Section “Man Pages” (Chapter 27, Help and Docu-
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mentation, ↑Administration Guide) and Section “Info Pages” (Chapter 27, Help
and Documentation, ↑Administration Guide).

27.1 Using the KDE Help Center
From the KDE desktop, you can access the KDE help center in various ways: If you
need information fromwithin an application, simply click the application'sHelp button
or press F1 to open the application's documentation in the help center. If you start the
help center from the main menu, or from the command line with khelpcenter, you
are taken to the main window of the help center from which you can browse the help
topics.

Figure 27.1 Main Window of the KDE Help Center

The menu and the toolbar provide options for printing contents from the help center,
searching the currently displayed page, and navigating and customizing the help center.
The display field in the right part of the window always shows the currently selected
contents, such as online manuals, search results, or Web pages.

The navigation area in the left part of the window contains several tabs:

Contents
Presents a tree view of all available information sources. The help center addresses
various target groups, such as users, administrators, and developers. Click the book
icons to open and browse the individual categories. Under the heading Administra-
tion, for example, you can also browse man (manual) and info (information) pages
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associated with command line programs. The help center also provides access to
some online databases that cover special hardware and software issues for your
product. All these sources can be searched conveniently once a search index has
been generated.

The contents of your help center depends on which software packages are currently
installed and which languages are selected as your system languages.

Glossary
Provides a quick reference where you can look up the definitions of words that
might be unfamiliar to you.

Search Options
Holds options for the full text search of the help center. You can combine several
search criteria.

Procedure 27.1 Searching the Help Center

To use the full text search KDE help center offers, generate a search index and set
the search parameters. If the search index has not yet been generated, the system au-
tomatically prompts you to do so when you click the Search tab.

1 To search for a term, click into the text field and enter the search string.

2 To combine your search strings with operands, clickMethod and select the
operand to use.

3 Choose an option fromMax. Results to limit the number of hits to display.

4 To restrict your search to certain types of documentation, choose an option from
Scope selection. With Default, a predefined selection of documents is searched.
All includes all types of documents in the search. Custom lets you define which
documents to include in your search. Just activate the documents you want in
the list.

5 When you have set the options according to your wishes, click Search. The search
results are then displayed as a list of links in the display field and can be navigated
with mouse clicks.
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Procedure 27.2 Generating a New Search Index

1 To create a new search index, select Settings > Build Search Index from the menu.
A window opens, showing a list of the documentation currently available in the
help center.

2 Select the documents to integrate in the search index and click Build Index. After
the index has been generated, you can use the full text search.

27.2 Using GNOME Yelp
On the GNOME desktop, to start Yelp directly from an application, either click the
Help button or press F1. Both options take you directly to the application's documentation
in the help center. However, you can also start Yelp from the main menu, or from the
command line with yelp and then browse through the main window of the help center.

Figure 27.2 Main Window of Yelp

The menu and the toolbar provide options for navigating and customizing the help
center, for searching and for printing contents from Yelp. To view a table of contents,
clickHelp Topics. The help topics are grouped into categories presented as links. Click
one of the links to open a list of topics for that category. To search for an item, just
enter the search string into the search field at the top of the window.
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27.3 Browsing Man and Info Pages
From Your Desktop

With the KDE or GNOME desktop, you can also access (or print) man pages and info
pages:

KDE
In Konqueror, to view the man page for ls, type man:/ls in the location bar. If
there are different categories for a command, Konqueror displays them as links.
To display the info page for grep, for example, type info:/grep.

In the KDE help center, check out Administration in the table of contents to browse
man pages and info pages.

GNOME
Run yelp man:ls or yelp info:ls to display the man or info page. Alter-
natively enter man:ls or info:ls in the search field of Yelp.

Figure 27.3 Viewing a Man Page With Konqueror

27.4 Additional Help Resources
In addition to the online versions of the Novell/SUSE manuals installed under /usr/
share/doc, you can also access the product-specific manuals and documentation on
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the Web. For an overview of all documentation available for your product check out
your product-specific documentation Web page at http://www.novell.com/
documentation/.

If you are searching for additional product-related information, you can also refer to
the following Web sites:

• openSUSE Wiki English [http://en.opensuse.org] and http://www
.opensuse.org

• SUSE Support Database [http://en.opensuse.org/SDB:SDB]

• Novell Technical Support Knowledgebase [http://www.novell.com/
support/]

• Novell Forums [http://forums.novell.com/]

• Novell Cool Solutions [http://www.novell.com/coolsolutions/]

• KDE Documentation Web site [http://www.kde.org/documentation]

• DocumentationWeb site for KDE applications [http://www.kde-apps.org]

• GNOME Documentation Web site [http://www.gnome.org/learn/]

You might also want to try general-purpose search engines. For example, you might
try the search terms Linux CD-RW help or OpenOffice file conversion
problem if you were having trouble with the CD burning or with OpenOffice.org file
conversion. Google™ also has a Linux-specific search engine at http://www
.google.com/linux that you might find useful.
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28Getting to Know Linux
Software
Linux* comes with a wealth of applications, often offering more than one solution to
specific needs. The difficulty is finding the application that suits your needs best. The
next few sections introduce some of the most powerful Linux counterparts of common
Windows software. Each section is dedicated to one particular field of application and
presents an overview of the Windows applications and Linux equivalents for several
tasks. Below each table, find further information about the Linux applications with
links to more information. This list is by no means complete, because software devel-
opment is an evolutionary process and new applications are constantly being created.

TIP: Applications not Installed by Default

Not all applications mentioned below are installed on your system by default
and some may not be shipped with your product. If the application you want
to use is missing, ask your system administrator. If the application is provided
by your product, you can install it with YaST. Use the search function of the
YaST software management tool to find the name of the wanted package.
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28.1 Office Applications
This section features the most popular and powerful Linux office and business software
solutions. These include office suites, databases, accounting software, and project
management software.

Table 28.1 Office Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

OpenOffice.org, StarOffice, KOf-
fice

Microsoft* OfficeOffice Suite

OpenOffice.org, StarOfficeWriter,
KWord

Microsoft Word, Word-
Perfect

Word Processor

OpenOffice.org, StarOffice Calc,
Gnumeric, KSpread

Microsoft ExcelSpreadsheet

OpenOffice.org, StarOffice Im-
press, KPresenter

Microsoft PowerPointPresentation

OpenOffice.org, Calc, Kst, Gnu-
plot, Grace (Xmgr), LabPlot

Microsoft ExcelData Plotting

OpenOffice.org, Base, Rekall,
kexi, Mergeant, PostgreSQL

Microsoft AccessLocal Database

GnuCash, KMyMoneyMicrosoft Money,
Quicken

Financial Account-
ing

Planner, TaskjugglerMicrosoft ProjectProjectManagement

VYM (View Your Mind), Free
Mind, KDissert

MindManager, Free
Mind

Mind Mapping
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28.1.1 Office Suites
OpenOffice.org

OpenOffice.org is a stable open source equivalent to Microsoft Office including a
word processor (Writer), a spreadsheet (Calc), a database manager (Base), a presen-
tation manager (Impress), a drawing program (Draw), and a formula editor for
generating mathematical equations and formulas (Math). The user interface is
similar to the Microsoft Office suite. For more details, see http://www
.openoffice.org/ or read Chapter 1, OpenOffice.org: The Office Suite
(page 3).

StarOffice
StarOffice, a proprietary office suite software developed by Sun Microsystems, is
similar to OpenOffice.org. It is available onmultiple platforms like Linux,Windows
and Solaris. It contains the same modules as the OpenOffice.org suite. It also in-
cludes certain advanced features not available with the open source version. For
more details, seehttp://www.sun.com/software/star/staroffice/.

KOffice
KOffice is the fully integrated office suite designed for the KDE desktop. It comes
with various modules, like word processing (KWord), spreadsheets (KSpread),
presentations (Kpresenter), several image processing applications (Kivio, Karbon14,
Krita), a database front-end (Kexi) and many other applications. For more details,
see http://www.koffice.org/.

28.1.2 Word Processing
Writer

Writer is the stable word-processing and desktop publishing module of the
OpenOffice.org and StarOffice. The StarOffice Writer features some advanced
functionalities not available with OpenOffice.org. For more details, see http://
www.openoffice.org/product/writer andhttp://www.sun.com/
software/star/staroffice.

KWord
KWord is the stable frame-based word-processing module of the KOffice Suite.
KWord's easy-to-use features help you to create professional looking documents
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and it can handle large amounts of texts. For more details, see http://www
.koffice.org/kword/.

28.1.3 Spreadsheets
Calc

Calc is the spreadsheet and data plotting module of the OpenOffice.org and
StarOffice suites. It is easy to learn and offers a wide range of features. For more
details, see http://www.openoffice.org/product/calc.html and
http://www.sun.com/software/star/staroffice.

KSpread
KSpread is the spreadsheet module of the KOffice Suite. It is a scriptable spreadsheet
program which provides both table-oriented sheets and support for complex
mathematical formulas and statistics. Formore details seehttp://www.koffice
.org/kspread/.

Gnumeric
Gnumeric is a spreadsheet solution for the GNOME desktop environment that can
also read files created with other spreadsheets. It's built-in functions and tools are
extremely accurate. For more details, see http://www.gnumeric.org.

28.1.4 Presentations
Impress

Impress is the presentation module of the OpenOffice.org and StarOffice suites.
Impress lets you create multimedia presentations with 2D and 3D clip art, special
effects, animation, and drawing tools. Impress can create PDF files from your
presentations, and it is able to view, edit and save files in several file formats, in-
cluding the *.ppt format, which is used byMicrosoft PowerPoint. For more details,
see http://www.openoffice.org/product/impress.html. and
http://www.sun.com/software/star/staroffice.

KPresenter
KPresenter is the presentation module of the KOffice Suite. KPresenter can prepare
complete sets of slides containing text and graphics in a variety of formats, and
embed all sorts of objects. KPresenter is also able to load presentations from
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Microsoft PowerPoint, MagicPoint and OpenOffice.org Impress documents. For
more details see http://www.koffice.org/kpresenter/.

28.1.5 Data Plotting
Calc

See Calc (page 342).

Gnuplot
Gnuplot is a very powerful and portable command line controlled data plotting
software. It is also available for MacOS and Windows platforms. Plots created by
Gnuplot can be exported to various formats, such as PostScript, PDF, and SVG,
allowing you to process these plots easily. For more details see http://www
.gnuplot.info/index.html.

Grace
Grace is a 2D plotting tool for many platforms including Linux. It can create and
edit plots with a graphical user interface. Grace supports an unlimited number of
graphs per plot. For more details, seehttp://plasma-gate.weizmann.ac
.il/Grace/

Kst
Kst is the data plotting module for the KOffice suite. It allows for real-time data
viewing and plotting with basic data analysis. For more details, see http://kst
.kde.org/.

LabPlot
LabPlot is a plotting tool for creating and managing 2D or 3D data plots and was
written for KDE. Graphs can be produced both from data and functions and one
plot may include multiple graphs. It also offers various data analysis methods. For
more details, see http://labplot.sourceforge.net/.

28.1.6 Local Databases
Base

Base is the database module of the OpenOffice.org and StarOffice suites. It can be
used to create “self-contained” database documents with all relevant data, table
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definitions, reports, and forms. Formore details, seehttp://www.openoffice
.org/product/base.html and http://www.sun.com/software/
star/staroffice.

Gnome-DB
GNOME-DB provides a unified data access architecture to GNOME. It is useful
for any application that accesses persistent data. It consists of a data abstraction
layer (Libgda), a database widget library and a database front-end (Mergeant). For
more details, see http://www.gnome-db.org/.

Kexi
Kexi is an integrated data management application. It can be used for creating
databases, inserting data, performing queries, and processing data. Forms can be
created to provide a custom interface to your data. For more details, see http://
www.koffice.org/kexi/.

PostgreSQL
PostgreSQL is an object-relational database management system that supports an
extended subset of the SQL standard, including transactions, foreign keys, sub-
queries, triggers, and user-defined types and functions. For more details, see
http://www.postgresql.org/.

Rekall
Rekall is a database management tool that supports many database applications
like MySQL,PostgreSQL and Xbase. Rekall can be used for many tasks such as
reports, forms, queries and others. For more details, see http://www
.thekompany.com/products/rekall/.

28.1.7 Financial Accounting
KmyMoney

KmyMoney is a personal financial manager for the KDE desktop. It enables users
of open source operating systems to keep track of their personal finances and offers
a broad array of financial features and tools. For more details, see http://
kmymoney2.sourceforge.net.
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GnuCash
GnuCash is a software tool to control personal and business finances. It enables
users to keep track of income and expenses and it is also used to manage bank ac-
counts, and stock portfolios. Formore details, seehttp://www.gnucash.org/.

28.1.8 Project Management
Planner

Planner is a project management tool for the GNOME desktop aiming to provide
functionality similar to the project management tools used underWindows. Amongst
its features are Gantt charting and different display types for tasks and resources.
For more details see http://live.gnome.org/Planner.

Taskjuggler
Taskjuggler is a project management tool that enables the user to control projects
using Gantt charting features. It can also be used to generate reports in different
formats (XML, HTML or CSV). Taskjuggler can be controlled from the command
line but also offers a graphical front-end. For more details see http://www
.taskjuggler.org.

28.1.9 Mind Mapping
FreeMind

FreeMind is a mind-mapping like tool for structuring ideas, thoughts and concepts.
It can copy nodes (or the style of nodes) and paste texts from sources such as HTML,
RTF, and mails. The mind maps can be exported into various formats, such as
HTML and XML. For more details, see http://freemind.sourceforge
.net/wiki/index.php/Main_Page.

VYM
VYM (ViewYourMind) is a mind-mapping like tool for structuring ideas, thoughts
and concepts. VYM mind maps are created in XML which can be exported to
HTML. For more details see http://insilmaril.de/vym.

Semantik
Semantik (previously KDissert) is a mindmapping-like tool for structuring idea.
Users can generate various outputs from the mind map, such as PDF files, text
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documents andHTMLfiles. Formore details seehttp://freehackers.org/
~tnagy/kdissert/.

28.2 Network
The following section features various Linux applications for networking purposes.
Get to know the most popular Linux browsers and e-mail and chat clients.

Table 28.2 Network Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, Firefox,
Opera, Epiphany

Internet Explorer, Firefox*,
Opera

Web Browser

Evolution, Kontact,
Mozilla Thunderbird

Microsoft Outlook*, Lotus
Notes,Mozilla Thunderbird*

E-Mail Client/Personal
InformationManagement

Gaim, Empathy, Kopete,
Konversation, XChat

MSN, AIM*, Yahoo!* Mes-
senger, XChat, Gaim

Instant Messaging/IRC
Clients

EkigaNetMeeting, LifeMeetingConferencing (Video and
Audio)

Ekiga, SkypeX-LiteVoice over IP

gftp, kbearleechftp, wsftpFTP Clients

28.2.1 Browsers
Epiphany

Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of
its features and extensions are similar to Firefox. For more details, see http://
projects.gnome.org/epiphany/.
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Firefox
Firefox is a Web browser that runs on various platforms, including Linux, MacOS,
and Windows. Its main features include customizable searches, pop-up blocking,
RSS news feeds, password management, tabbed browsing, and some advanced
security and privacy options. For more details, see http://www.mozilla
.org/products/firefox/ or read Chapter 17, Firefox: Browsing the Web
(page 179).

Konqueror
Konqueror is a multiple application created for the KDE desktop. It acts as web
browser, file manager and document viewer. It supports most common web stan-
dards, such as CSS(2), Java applets, JavaScript and Netscape plug-ins, DOM, and
SSL. Formore details, seehttp://www.konqueror.org/ or read Chapter 16,
Konqueror: Browsing the Web (page 171).

Opera
Opera is a powerful web browser with an optional e-mail client and a chat module.
Opera offers pop-up blocking, RSS feeds, built-in and customizable searches, a
password manager, and tabbed browsing. For more details see http://www
.opera.com/.

28.2.2 E-Mail Client / Personal Information
Management

Evolution
Evolution is a personal information management application for the GNOME
desktop. It includes e-mail, calendar, and address book functionalities. For more
details, seehttp://projects.gnome.org/evolution/ or readChapter 6,
Evolution: E-Mailing and Calendaring (page 75).

Kontact
Kontact is the personal information management suite for the KDE desktop. It in-
cludes e-mail, calendar, address book and Palm sync functionalities. For more de-
tails, see http://www.kontact.org/ or read Chapter 5,Kontact: E-Mailing
and Calendaring (page 57).
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Mozilla Thunderbird
Mozilla Thunderbird is the e-mail client of the Mozilla suite. It is also available
for Microsoft Windows and MacOS. For more details, see http://www
.mozilla.com/en-US/thunderbird/.

28.2.3 Instant Messaging / IRC Clients
Empathy

Empathy is an instant messenger tool for the GNOME desktop. It consists of a rich
set of reusable instant messaging widgets, and a GNOME client. For more details,
see http://live.gnome.org/Empathy .

Konversation
Konversation is the IRC client of the KDE desktop with many functionalities. For
more details, see http://konversation.kde.org.

Kopete
Kopete is an easy-to-use instant messenger tool supporting many protocols. For
more details, see http://kopete.kde.org/ or read Chapter 13, Kopete:
Instant Messaging (page 149).

Pidgin
Pidgin (previously Gaim) is a multi-platform instant messaging client supporting
many commonly used instant messaging protocols, allowing the user to log into
various different services from a single application. For more details, see http://
pidgin.im/ or read Chapter 14, Pidgin: Instant Messaging (page 157).

28.2.4 VoIP, Video and Audio Conferencing
Ekiga

Ekiga (previously GNOMEMeeting) is a free and open source video conferencing
and VoIP application. Ekiga supports both the SIP and H.323 protocols, and is
fully interoperable with Microsoft NetMeeting and LifeMeeting. For more details
see http://www.ekiga.org/ or read Chapter 15, Ekiga: Using Voice over
IP (page 161).
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Skype
Skype is an application for several platforms (Linux, Windows, Mac Os X) that
can be used for phone calls over the Internet with a good sound quality and with
end-to-end encryption. When using Skype, configuring the firewall or router is not
necessary. For more details, see http://www.skype.com/. Information on
Skype and openSUSE is avaiable from http://en.opensuse.org/Skype
_HOWTO.

28.2.5 FTP Clients
gftp

gftp is an FTP client using the GTK toolkit. Its features include simultaneous
downloads, resume of interrupted file transfers, file transfer queues, download of
entire directories, FTP proxy support, remote directory caching, passive and non-
passive file transfers, and drag and drop support. For more details, see http://
gftp.seul.org/ or readChapter 18, gFTP: TransferringData From the Internet
(page 199).

KBear
KBear is a graphical FTP client that can connect to multiple hosts simultaneously.
The user can copy or move files or directories between the hosts by drag and drop
or cut and paste. It also has a dynamic site database. For more details, see http://
sourceforge.net/projects/kbear/.

28.3 Multimedia
The following section introduces the most popular multimedia applications for Linux.
Get to know media players, sound editing solutions, and video editing tools.

Table 28.3 Multimedia Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KsCD, Amarok, Grip, Ban-
shee

CD Player, Winamp, Windows
Media Player

Audio CD Player
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Linux ApplicationWindows ApplicationTask

K3bNero, Roxio Easy CD CreatorCD Burner

KAudioCreator, Sound
Juicer

WMPlayerCD Ripper

Amarok, XMMS, Rhythm-
box

Winamp, Windows Media
Player, iTunes

Audio Player

Kaffeine, MPlayer, Xine,
XMMS, Totem, RealPlayer

Winamp, Windows Media
Player

Video Player

AudacitySoundForge, Cooledit, Auda-
city

Audio Editor

alsamixer, Kmixsndvol32Sound Mixer

LilyPond, MusE, Noteedit,
Rosegarden

Finale, SmartScore, SibeliusMusic Notation

KinoWindowsMovieMaker, Adobe
Premiere, Media Studio Pro

Video Creator and
Editor

xawtv, motv (analog), tv-
time, kdetv, zapping, Kaf-
feine

AVerTV, PowerVCR 3.0,
CinePlayer DVR

TV Viewer

28.3.1 Media Players
Amarok

Amarok is a powerful media player for the KDE desktop. It handles various audio
formats and plays streaming audio broadcasts of radio stations on the Internet. For
more details, see http://amarok.kde.org/ or read Section 22.2.1, “Amarok
Music Player” (page 271).
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Banshee
Banshee is a media player that can encode and decode various media formats.
Banshee can play, import, and burn audio CDs. For more details, see http://
banshee-project.org/ or read Chapter 23,Banshee: Playing andManaging
Your Music (page 293).

Grip
Grip is a CD-player and ripper for the GNOME desktop. It has the ripping capabil-
ities of cdparanoia built in, but can also use external rippers. For more details, see
http://www.nostatic.org/grip/.

Kaffeine
Kaffeine is a multimedia application that supports many audio and video formats.
For more details, see http://kaffeine.kde.org/.

KsCD
KsCD is a CD player application for the KDE desktop. Its user interface is very
similar to that of a normal hardware CD player. For more details, see http://
docs.kde.org/en/3.3/kdemultimedia/kscd/.

MPlayer
MPlayer supports many media formats and can also save all streamed content to a
file. For more details, see http://www.mplayerhq.hu/.

RealPlayer
RealPlayer is a proprietary cross-platformmedia player by RealNetworks that plays
a number ofmultimedia formats. Formore details, seehttp://www.real.com/
player/.

Totem
Totem is the default multimedia player for the GNOME computer desktop environ-
ment. Totem is fully integrated with GNOME Nautilus. For more details, see
http://projects.gnome.org/totem/ or read Chapter 24, Totem: Playing
Videos (page 311).

Xine
Xine is a multimedia player for Linux that supports different front-end player ap-
plications. Another important feature is the ability to manually correct the synchro-
nization of audio and video streams. For more details, see http://www
.xine-project.org/.
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XMMS
The X Multimedia System 2 (XMMS2) is an audio player for Linux systems that
supports audio and video formats. For more details, see http://wiki.xmms2
.xmms.se/.

28.3.2 CD Burners
Banshee

See above for Banshee (page 351).

Brasero
Brasero is a disc-burning program for the GNOMEDesktop allowing users to burn
audio and data CD/DVDs on the fly. For more details, see http://projects
.gnome.org/brasero/ or read Chapter 26, Brasero: Burning CDs and DVDs
(page 327).

K3b
K3b is a CD and DID authoring application for the KDE desktop environment for
Unix-like computer operating systems. It provides a graphical user interface to
perform most CD/DVD burning tasks and contains a built-in DID ripper. For more
details, see http://www.k3b.org/ or read Chapter 25, K3b: Burning CDs
and DVDs (page 321).

28.3.3 CD Rippers
Grip

See above for Grip (page 351).

KAudioCreator
KAudioCreator is a front-end tool for ripping audio CDs and encoding WAVE
files. For more details, see http://www.icefox.net/programs/
?program=KAudioCreator.

Sound Juicer
Sound Juicer is a front-end application to the cdparanoia CD ripping library. It al-
lows the user to extract audio output from compact discs and convert it into audio
files that a personal computer or digital audio player can understand and play. It
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supports ripping to many audio codecs. For more details, see http://www
.burtonini.com/blog/computers/sound-juicer.

28.3.4 Audio Editors
Audacity

Audacity is a digital audio editor application. Its cross-platform allows users to
mix tracks, apply effects to them, and export the results to WAV or Ogg Vorbis.
For more details, see http://audacity.sourceforge.net/.

28.3.5 Sound Mixers
ALSA mixer

ALSA mixer is the mixer program for the Advanced Linux Sound Architecture
(ALSA). It is used to configure sound settings and to adjust the volume. It has an
ncurses user interface and does not require the X Window System. It supports
multiple sound cards with multiple devices. For more details, see http://www
.alsa-project.org/main/index.php/Main_Page.

28.3.6 Music Notation
LilyPond

LilyPond is a music sheet editor. Because the input format is text- based, the user
can work with any text editor to create note sheets. Users do not need to tackle any
formatting or notation issues, like spacing, line-breaking, or polyphonic collisions.
For more details, see http://lilypond.org/web/.

MusE
MusE is at the moment a MIDI/Audio sequencer with recording and editing capa-
bilities. The project works on a complete multitrack virtual studio for Linux. For
more details, see http://www.muse-sequencer.org/.

Noteedit
Noteedit is a powerful score editor for Linux. It creates sheets of notes and exports
and import scores to and from many formats. It features a graphical user interface.
For more details, seehttp://noteedit.berlios.de/.
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Rosegarden
Rosegarden is a free music composition and editing environment. It features an
audio and MIDI sequencer and a score editor. For more details, see http://
rosegardenmusic.com/.

28.3.7 Video Creators and Editors
Kino

Kino is an easy and reliable digital video editor with export to many formats. The
program supports many basic video editing and assembling tasks. It captures video
to disk in Raw DIV, AVI, and Quicktime formats. For more details, see http://
www.kinodv.org.

28.3.8 TV Viewers and Editors
xawtv

xawtv is a TV viewer and recorder suite. It supports both analog and digital audio
and video broadcasts using either a TV tuner or a Satellite receiver card DB-S. For
more details, see http://linux.bytesex.org/xawtv/.

kdetv
kdetv is a TV viewer and recorder application for the KDE desktop supporting TV
using a tuner card. For more details, see http://www.kdetv.org.

28.4 Graphics
The following section presents some of the Linux software solutions for graphics work.
These include simple drawing applications as well as fully-fledged image editing tools
and powerful rendering and animation programs.

Table 28.4 Graphics Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KolourPaintMicrosoft PaintSimple Graphic Editing
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Linux ApplicationWindows ApplicationTask

GIMP, KritaAdobe Photoshop, Paint Shop
Pro, Corel PhotoPaint, GIMP

Professional Graphic
Editing

OpenOffice.org Draw,
Inkscape, Dia

Adobe Illustrator, CorelDraw,
Freehand

Creating Vector Graph-
ics

Inkscape, Dia, KivioWebDraw, Freehand, Adobe
Illustrator

SVG Editing

POV-Ray, Blender,
KPovmodeler

3D StudioMAX,Maya, POV-
Ray, Blender

Creating 3D Graphics

DigiKam, f-spotSoftware provided by the
camera manufacturer

Managing Digital Pho-
tographs

Vuescan, GIMPVuescanScanning

gwenview, gThumb, Eye
of Gnome, f-spot

ACDSeeImage Viewing

Blender
Blender is a powerful rendering and animation tool available on many platforms,
including Windows, MacOS, and Linux. For more details see http://www
.blender.org/.

Dia
Dia is the Linux equivalent of Visio. It supports many types of special diagrams,
such as network or UML charts. Export formats include SVG, PNG, and EPS. To
support your own custom diagram types, provide the new shapes in a special XML
format. For more details see http://projects.gnome.org/dia/.

digiKam
digiKam is a smart digital photo management tool for the KDE desktop. Create
albums, add tags to spare you from copying images around different subdirectories,
and eventually export your images to your own Web site. For more details see
http://www.digikam.org/ or read Chapter 20, DigiKam: Managing Your
Digital Image Collection (page 223).
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Eye of Gnome (eog)
Eye of Gnome is an image viewer application for the GNOME desktop. For more
details, see http://projects.gnome.org/eog/.

f-spot
f-spot is a flexible digital photograph management tool for the GNOME desktop.
It lets you create and manage albums and supports various export options like
HTML pages or the burning of image archives to CD. You can also use it as an
image viewer on the command line. Formore details, seehttp://f-spot.org/
Main_Page or read Chapter 21, F-Spot: Managing Your Digital Image Collection
(page 247).

gThumb
gThumb is an image viewer, browser and organizer for the GNOME desktop. It
supports the import of your digital images via gphoto2, allows you to carry out
basic transformation and modifications, and lets you tag your images to create al-
bums matching certain categories. For more details, see http://gthumb
.sourceforge.net/.

Gwenview
Gwenview is a simple image viewer for KDE. It features a folder tree window and
a file list window that provides the easy navigation of your file hierarchy. For more
details, see http://gwenview.sourceforge.net/home/.

Inkscape
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio
can find a similar range of features and a familiar user interface in Inkscape. Among
its features, find SVG-to-PNG export, layering, transforms, gradients, and grouping
of objects. For more details, see http://www.inkscape.org/.

Kivio
Kivio is a flow-charting application that integrates into the KOffice suite. Former
users of Visio find a familiar look and feel in Kivio. For more details, see http://
www.koffice.org/kivio/.

KolourPaint
KolourPaint is an easy-to-use paint program for the KDE desktop. You can use it
for tasks such as painting or drawing diagrams and editing screen shots, photos,
and icons. Formore details, seehttp://kolourpaint.sourceforge.net/.
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KPovmodeler
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop.
KPovmodeler does not require a detailed knowledge of POV-Ray scripting because
it translates the POV-Ray language into an easy-to-understand tree view. Native
POV-Ray scripts can be imported to KPovmodeler as well. For more details, see
http://www.kpovmodeler.org.

Krita
Krita is KOffice's answer to Adobe Photoshop and GIMP. It can be used for pixel-
based image creation and editing. Its features include many of the advanced image
editing capabilities you would normally expect with Adobe Photoshop or GIMP.
For more details, see http://www.koffice.org/krita.

OpenOffice.org Draw
See OpenOffice.org (page 341).

POV-Ray
POV-Ray (Persistence of Vision Raytracer) creates three-dimensional, photo-real-
istic images using a rendering technique called ray tracing. Because there is a
Windows version of POV-Ray, it does not take much for Windows users to switch
to the Linux version of this application. For more details, see http://www
.povray.org/.

GIMP
GIMP (GNU ImageManipulation Program) is an open source equivalent to Adobe
Photoshop. It is a raster graphics editor used to process digital graphics and pho-
tographs. For more details, see http://www.gimp.org/ or read Chapter 19,
GIMP: Manipulating Graphics (page 205).

VueScan
VueScan is a scanning software available for several platforms. You can install it
parallel to your vendor's scanner software. It supports the scanner's special hardware,
like batch scanning, autofocus, infrared channels for dust and scratch suppression,
and multiscan to reduce scanner noise in the dark areas of slides. It features simple
and accurate color correction. For more details, see http://www.hamrick
.com/vsm.html.
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28.5 System and File Management
The following section provides an overview of Linux tools for system and file manage-
ment. Get to know text and source code editors, backup solutions, and archiving tools.

Table 28.5 System and File Management Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Dolphin, Nautilus, Kon-
queror

Windows ExplorerFile Manager

kate, GEdit, (X)Emacs, vimNotePad, WordPad,
(X)Emacs

Text Editor

ScribusAdobe DistillerPDF Creator

Adobe Reader, Evince,
Okular, Xpdf

Adobe ReaderPDF Viewer

GOCRRecognita, FineReaderText Recognition

zip, tar, gzip, bzip2, etc.zip, rar, arj, lha, etc.Command Line Pack
Programs

Ark, File RollerWinZipGUI Based Pack Pro-
grams

YaST, GNU PartedPowerQuest, Acronis, Parti-
tion Commander

Hard Disk Partitioner

KDar, taper, dumpntbackup, VeritasBackup Software

Adobe Reader
Adobe Reader for Linux is the exact counterpart of theWindows andMac versions
of this application. The look and feel on Linux are the same as on other platforms.
The other parts of the Adobe Acrobat suite have not been ported to Linux. For more
details, seehttp://www.adobe.com/products/acrobat/readermain
.html.
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Ark
Ark is a GUI-based pack program for the KDE desktop and supports common
formats. You can view, select, pack, and unpack single files within an archive. For
more details, read Section “Displaying, Decompressing, and Creating Archives”
(Chapter 2, Working with Your Desktop, ↑KDE User Guide).

Dolphin
Dolphin is the default file manager for KDE 4. Dolphin offers several view modes,
file previews and split views. For more details, see http://dolphin.kde
.org/ or read Section “Using Dolphin File Manager” (Chapter 2, Working with
Your Desktop, ↑KDE User Guide).

dump
The dump package contains both dump and restore. dump examines files in a file
system, determines which ones need to be backed up, and copies those files to a
specified disk, tape, or other storage medium. The restore command performs the
inverse function of dump—it can restore a full backup of a file system. For more
details, see http://dump.sourceforge.net/.

Evince
Evince is a document viewer for PDF and PostScript formats for the GNOME
desktop. For more details, see http://www.gnome.org/projects/
evince/.

File Roller
File Roller is a GUI-based pack program for the GNOME desktop. It provides
features similar to Ark's. For more details, see http://fileroller
.sourceforge.net/home.html.

GEdit
GEdit is the official text editor of the GNOME desktop. It provides features similar
to Kate's. For more details, see http://www.gnome.org/projects/
gedit/.

GNU Parted
GNU Parted is a command line tool for creating, deleting, resizing, checking, and
copying partitions and the file systems on them. If you need to create space for
new operating systems, use this tool to reorganize disk usage and copy data between
different hard disks. Formore details, seehttp://www.gnu.org/software/
parted/.
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GOCR
GOCR is an OCR (optical character recognition) tool. It converts scanned images
of text into text files. For more details, see http://jocr.sourceforge
.net/.

gzip, tar, bzip2
There are plenty of packaging programs for reducing disk usage. In general, they
differ only in their pack algorithm. Linux can also handle the packaging formats
used on Windows. bzip2 is a bit more efficient than gzip, but needs more time,
depending on the pack algorithm. .

Kate
Kate is a module of the KDE suite. It has the ability to open several files at once
either locally or remotely. With syntax highlighting, project file creation, and ex-
ternal scripts execution, it is a perfect tool for a programmer. For more details, see
http://www.kate-editor.org/.

KDar
KDar stands for KDE disk archiver and is a hardware-independent backup solution.
KDar uses catalogs (unlike tar), so it is possible to extract a single file without
reading the whole archive and it is also possible to create incremental backups.
KDar can split an archive into multiple slices and trigger the burning of a data CD
or DVD for each slice. For more details, see http://kdar.sourceforge
.net/.

Konqueror
Konqueror is a file manager that can also be used as a Web browser, document and
image viewer, and CD ripper. For more details, see http://www.konqueror
.org/ or read Chapter 16,Konqueror: Browsing theWeb (page 171) to learn about
Konqueror's Web browsing functions.

Nautilus
Nautilus is the default file manager of the GNOME desktop. It can be used to create
folders and documents, display and manage your files and folders, run scripts, write
data to a CD, and open URI locations. For more details, see http://www.gnome
.org/projects/nautilus/ or read Section “Managing Folders and Files
with Nautilus” (Chapter 2, Working with Your Desktop, ↑GNOME User Guide).
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Okular
Okular is the document viewer for KDE 4 which is replaces KPDF. Apart from
PDF files, Okular allows you to view a great number of file formats. Its functional-
ity can be easily embedded in other applications. For more details, see http://
okular.kde.org/ or read Chapter 4, Viewing PDFFiles and Other Documents
with Okular (↑KDE User Guide).

taper
Taper is a backup and restore program that provides a friendly user interface to allow
backup and restoration of files to and from a tape drive. Conversely, files can be
backed up to archive files. Recursively selected directories are supported. For more
details, see at http://taper.sourceforge.net/.

vim
vim (vi improved) is a program similar to the text editor vi. Users may need time
to adjust to vim, because it distinguishes between commandmode and insert mode.
The basic features are the same as in all text editors. vim offers some unique options,
like macro recording, file format detection and conversion, and multiple buffers in
a screen. For more details, see http://www.vim.org/.

GNU Emacs and XEmacs
GNU Emacs is an extensible, customizable, self-documenting, real-time display
editor. XEmacs is based on GNU Emacs. Both offer nearly the same functionality
with minor differences. Used by experienced developers, they are highly extensible
through the Emacs Lisp language. They support many languages, like Russian,
Greek, Japanese, Chinese, and Korean. For more details see http://www
.xemacs.org/ and http://www.gnu.org/software/emacs/emacs
.html.

Xpdf
Xpdf is lean PDF viewing suite for Linux and Unix-like platforms. It includes a
viewer application and some export plug-ins for PostScript or text formats. For
more details, see http://www.foolabs.com/xpdf/.

28.6 Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems
for professional software development.
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Table 28.6 Development Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KDevelop, Eric, Eclipse,
MonoDevelop, Anjuta

Borland C++, Delphi, Visual
Studio, .NET

IntegratedDevelopment
Environments

Qt, GTK+MFC, Qt, GTK+Toolkits

GCCVisualStudioCompilers

GDB, ValgrindVisual Studio DebuggerDebugging Tools

Glade, Qt DesignerVisual Basic, Visual C++GUI Design

CVS, SubversionClearcase, Perforce, Source-
Safe

Versioning Systems

Anjuta
Anjuta is an IDE for GNOME/GTK+ application development. It includes an editor
with automated formatting, code completion, and highlighting. As well as GTK+,
it supports Perl, Pascal, and Java development. A GDB-based debugger is also in-
cluded. For more details see http://anjuta.sourceforge.net.

CVS
CVS (Concurrent Versions System) is one of the most important version control
systems for open source. It is a front-end to the Revision Control System (RCS)
included in the standard Linux distributions. For more details, see http://
ximbiot.com/cvs/.

Eclipse
The Eclipse Platform is designed for building integrated development environments
that can be extended with custom plug-ins. The base distribution also contains a
full-featured Java development environment. For more details, see http://www
.eclipse.org.

Eric
Eric is an IDE optimized for Python and Python-Qt development. For more details,
see http://www.die-offenbachs.de/eric/index.html.
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GCC
GCC is a compiler collection with front-ends for various programming languages.
Check out a complete list of features and find extensive documentation at http://
gcc.gnu.org.

GDB
GDB is a debugging tool for programs written in various programming languages.
For more details, see http://www.gnu.org/software/gdb/gdb.html.

Glade
Glade is a user interface builder for GTK+ and GNOME development. As well as
GTK+ support, it offers support for C, C++, C#, Perl, Python, Java, and others.
For more details, see http://glade.gnome.org/.

GTK+
GTK+ is a multi platform toolkit for creating graphical user interfaces. It is used
for all GNOME applications, GIMP, and several others. GTK+ has been designed
to support a range of languages, not only C/C++. Originally it was written for
GIMP, hence the name “GIMP Toolkit.” For more details, see http://www.gtk
.org. Language bindings for GTK+ are summarized underhttp://gtk.org/
features.html#LanguageBindings.

KDevelop
KDevelop allows you to write programs for different languages (C/C++, Python,
Perl, etc.). It includes a documentation browser, a source code editor with syntax
highlighting, a GUI for the compiler, and much more. For more details, see
http://www.kdevelop.org.

MonoDevelop
MonoDevelop is an open source integrated development environment for the Linux
platform, primarily targeted for the development of software that uses both Mono
and Microsoft .NET framework. MonoDevelop integrates features similar to that
of Eclipse and Microsoft's Visual Studio such as Intellisense, source control inte-
gration, and an integrated GUI and Web designer. For more details, see http://
www.monodevelop.com/.

Qt
Qt is a program library for developing applications with graphical user interfaces.
It allows you to develop professional programs rapidly. For more details, see
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http://trolltech.com. Language bindings for Qt development are summa-
rized under http://developer.kde.org/language-bindings/.

Qt Designer
Qt Designer is a user interface and form builder for Qt and KDE development. It
can run as part of the KDevelop IDE or in stand-alone mode. QtDesigner can be
run under Windows and even integrates into the Visual Studio development suite.
For more details seehttp://trolltech.com/products/qt/designer
.html.

Subversion
Subversion does the same thing CVS does but hasmajor enhancements, likemoving,
renaming, and attachingmeta information to files and directories. For more details,
see http://subversion.tigris.org/.

Valgrind
Valgrind is a suite of programs for debugging and profiling x86 applications. For
more details, see http://valgrind.org/.
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